windows 7 freezing

Discussion in 'Windows 7 Help and Support' started by rcmedical, Aug 19, 2009.

  1. rcmedical

    rcmedical New Member

    Joined:
    Aug 18, 2009
    Messages:
    2
    Likes Received:
    0
    hi everybody ,
    before i continue here are my specs:
    toshiba satellite a135-s4467
    core2duo t5200 with integrated graphics
    160 gb hard drive
    2gb of memory

    i installed windows 7 and it just lags terribly. there are times when it doesnt respond. the
    i really dont know what to do at this point. my ram is at a good level. but my cpu usage seems to be very high. (that's my theory).

    when i look at cpu usage system idle processes catches you eye.
     
  2. textureDnB

    textureDnB New Member

    Joined:
    Jun 29, 2009
    Messages:
    652
    Likes Received:
    6
    Check your CPU usage by the percentage on the bottom of task manager. The process list can cause confusion since "System Idle Process" is actually the amount of time your NOT using the processor.
    The behavior you describe is often due to a graphics driver or other driver not being correct.
    Go to the device manager (right click computer -->select properties -->on the top left click device manager)
    Look there for any yellow exclamation marks.
     
  3. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,851
    Likes Received:
    1,569
    Have you installed the latest drivers released for your product? You'll usually find them on the manufacturers website

    Toshiba : Worldwide Top Page
     

Share This Page

Loading...