Windows 7 goes to Hybrid sleep instead of sleep

Discussion in 'Windows 7 Help and Support' started by Picartman, Sep 27, 2009.

  1. Picartman

    Picartman New Member

    Joined:
    Jul 24, 2009
    Messages:
    28
    Likes Received:
    0
    Basically I push the sleep button and the computer stays on but the keyboard lights turn off, so I suppose it's in hybrid sleep. I want my computer to go into Sleep mode and completely shut off. I don't see an option in the power options to disable hybrid sleep, and I even tried to disable it though the cmd prompt. My motherboard is an EVGA X58 of that helps.
     
  2. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    #2 RAK, Sep 28, 2009
    Last edited: Oct 5, 2009
  3. Picartman

    Picartman New Member

    Joined:
    Jul 24, 2009
    Messages:
    28
    Likes Received:
    0
    I'm using the one I got a while back from the beta release. I also remember seeing that setting and now it disappeared. What could I have touched to mess it up?
     
  4. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    The "Sleep" function, is, by default, the same as Hybrid sleep. The power will always be on. The alternative, which means a short boot up on resuming use of he computer, is,of course, "hibernate".
    But, anyway. Try this:
    A) In the elevated command prompt, (Right click and run as Administrator)
    type powercfg -h on and press Enter.
    B) Now, if you wish, set your Power Plan settings to the recommended settings for Hibernate. But I think the system is looking for the "hyberfil.sys" file in the root, which you may have accidentally have deleted. The command above will restore it after a reboot.
    Fwiw. The Windows 7 Beta release has expired. I do not know all the symptoms this may produce, but it will fold on you with limited functions. This could be one of them, although I doubt that.
     
    #4 RAK, Sep 28, 2009
    Last edited: Sep 28, 2009
  5. Picartman

    Picartman New Member

    Joined:
    Jul 24, 2009
    Messages:
    28
    Likes Received:
    0
    This is all I see after I entered that prompt.

    http://i37.tinypic.com/5ysy78.png

    I just want my computer to go to sleep and turn off so don't have to hear the fans while I try to sleep lol.
     
  6. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Sorry. I have run out of ideas and can only suggest a reinstall. (But not with the BETA.) I think my last post covered your problem and request.
     
    #6 RAK, Sep 28, 2009
    Last edited: Sep 28, 2009
  7. gavin19

    gavin19 New Member

    Joined:
    Aug 8, 2009
    Messages:
    442
    Likes Received:
    11
    Hibernation is already on/active because it shows up in the Power plan settings. To manually invoke hibernation -

    Run > rundll32.exe PowrProf.dll, SetSuspendState

    I got the info from here btw as I never use hibernation, I was just curious :D
     
  8. Picartman

    Picartman New Member

    Joined:
    Jul 24, 2009
    Messages:
    28
    Likes Received:
    0
    Damn dude it suck I'd have to use that every time though :\ I wish there was some way to just fix it.
     
  9. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    I have only just taken the trouble to look at your last picture. I can see you now have the hibernate option. So what is it now that you are actually wanting to do.?
    You can program, through the power options, for the computer to hibernate when you press the sleep button. (Through "Power buttons and lid")There is no need to type the command from Gavin everytime if you do that.
    Alternatively. If you right click the desktop, a drop down will pop up. Select "New" and then "Shortcut" Now another window will pop up. Copy and paste the command into the blank panel ("Type the location..etc) Then, in the next window, just call it hibernate or your choice.
     
  10. Picartman

    Picartman New Member

    Joined:
    Jul 24, 2009
    Messages:
    28
    Likes Received:
    0
    Ok sleep is when the computer turns off but starts up very quickly, right now when I push the sleep button, the computer is going into hybrid sleep instead of normal sleep. I don't want my computer to be in hybrid sleep because the computer seems to still be turned on, just no signal goes to the monitor unless I tap my keyboard, then the computer turns on again.
     
  11. gavin19

    gavin19 New Member

    Joined:
    Aug 8, 2009
    Messages:
    442
    Likes Received:
    11
    No, that's hibernation. In Sleep mode the computer is 'suspended' but not actually turned off. See here for the differences.

    What do you mean by 'seems to still be turned on'? All three, Sleep, Hybrid, and Hibernation, should all deaden the PC. It sounds like it isn't properly sleeping, in other words ACPI isn't working it's just APM. It could be due to an outdated bios, or one particular program that is running that's preventing proper sleep. It could also be something like your LAN adapter's power settings, try going into Device Manager and changing the 'Power Management' options for the LAN adapter.

    In the meantime just use the .bat file I've attached. Save it somewhere and create a shortcut to it, then drag that shortcut to desktop/startmenu or wherever you like. Just double click to invoke hibernation. It's not ideal but it will suffice until you find a proper solution. You will need to rename the attached 'hib.txt' to 'hib.bat' for it to work.
     
    #11 gavin19, Sep 28, 2009
    Last edited: Sep 28, 2009
  12. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Not forgetting that you he can also click the START globe - then the arrow to th right of shutdown and select hibernate or sleep. But this thread is going nowhere. I'm out.
     
  13. Picartman

    Picartman New Member

    Joined:
    Jul 24, 2009
    Messages:
    28
    Likes Received:
    0
    I did do that. I did click on sleep. This is exactly what my PC does. My monitor loses its signal, my mouse lights turn off, and my Saitek keyboard's lights turn off. If I click the mouse or tap any key on the keyboard, it will wake back up.

    Also gavin19, I downloaded your file, renamed it to hib.bat, ran it, and what I just previously described happened. I "woke" the computer up again by pressing the space bar.
     
  14. Picartman

    Picartman New Member

    Joined:
    Jul 24, 2009
    Messages:
    28
    Likes Received:
    0
  15. pbcopter

    pbcopter Honorable Member

    Joined:
    Jan 15, 2009
    Messages:
    226
    Likes Received:
    12
    Hi,
    Hybrid sleep and sleep are the same thing as far as the sleep part is concerned. The system should shut down and only have a small amount of power going to the RAM so that a fast startup is possible (no fans or lights). The difference is that in hybrid sleep, all the data that is in RAM is also stored to the hard drive (like in hibernation) so that if the power is turned off at the switch, you will still return to where you were but a liitle slower than with sleep.
     
  16. Picartman

    Picartman New Member

    Joined:
    Jul 24, 2009
    Messages:
    28
    Likes Received:
    0
    Ok well then if they're the same thing, then the issue must be that my hibernation isn't properly turned on. How do I do that? Remember I already tried that .bat previously posted and the cmd line and I checked in the power options as well. Where else could I have possibly disabled Hibernation in the OS?
     
  17. Picartman

    Picartman New Member

    Joined:
    Jul 24, 2009
    Messages:
    28
    Likes Received:
    0
    Hell yes I fixed it. I enabled S3 instead of S1 sleep in the BIOS. That was such an easy fix. -_-
     

Share This Page

Loading...