Windows 7 IE8 (64 bit) dosn't work

Discussion in 'Windows 7 Software' started by kiwipaul, Nov 4, 2010.

  1. kiwipaul

    kiwipaul New Member

    Joined:
    Nov 4, 2010
    Messages:
    6
    Likes Received:
    0
    Hi

    I've got OEM version of W7 Pro 64 bit. I've had it about 2 months and everything is working fine except IE8 64 bit. I normally use Firefox so haven't been to concerned.

    I'm now trying to figure out why my IE8 64 bit dosn't work. The IE8 32 bit works fine.

    The error I get when I start IE8 64 is

    The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.


    I've downloaded IE8-WindowsVista-x64-ENU and tried installing that but get the error


    Internet Explorer 8 is not supported on this operating system.


    I've checked in control panel system and it reports my o/s IS 64 bit.


    Any ideas.
     
  2. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    Use the System File Integrity Checker

    If everything turns out fine, try this method:

    Under Control Panel -> Programs go to the left-side panel and select "Turn Windows features on or off"

    Uncheck Internet Explorer 8, allow it to completely uninstall, and then restart the computer.

    Repeat this process, but check Internet Explorer 8, to completely re-install the browser.

    Was there ever a time when it worked? Otherwise, I suspect you may have a corrupt installation. I can confirm it works fine on nearly every 64-bit version of Windows. Have you tried running other 64-bit applications and do they work?
     
  3. kiwipaul

    kiwipaul New Member

    Joined:
    Nov 4, 2010
    Messages:
    6
    Likes Received:
    0
    Use the System File Integrity Checker

    Ran this and examined 5,000 page log file and found iexplore.exe and various other files gave this error
    "Hashes for file member \SystemRoot\WinSxS\amd64_microsoft-windows-i..-optional.resources_31bf3856ad364e35_8.0.7600.16385_en-us_09122aaf762607df\iexplore.exe.mui do not match actual file [l:32{16}]"iexplore.exe.mui" :
    Found: {l:32 b:3sRhA9Ucf3JlXeE9FQQVwoTZcAM2OmXdsrEmMZ/BBbo=} Expected: {l:32 "
    Whatever the hell that means

    If everything turns out fine, try this method:

    Under Control Panel -> Programs go to the left-side panel and select "Turn Windows features on or off"

    Uncheck Internet Explorer 8, allow it to completely uninstall, and then restart the computer.

    Repeat this process, but check Internet Explorer 8, to completely re-install the browser.
    Did this and got same problem

    Was there ever a time when it worked? Otherwise, I suspect you may have a corrupt installation. I can confirm it works fine on nearly every 64-bit version of Windows. Have you tried running other 64-bit applications and do they work?

    IE8 64 bit has never worked but other 64 bit appp work fine.

    Given up on IE8 downloaded IE9 64 bit and that works fine.

    Thanks for the help never heard of SFC before and will remember for the future
    [/QUOTE]
     
  4. nehoma

    nehoma Honorable Member

    Joined:
    May 8, 2009
    Messages:
    491
    Likes Received:
    7
    I have tried IE 9 and I like it but it is buggy. It does not work on my Tesco's website nor does it work on my bank account site.
     

Share This Page

Loading...