Windows 7 install quits at Welcome Screen

I have a Gateway ML6720 with
1GB of RAM
Inter(R) pentium dual cpu t2310 @ 1.46 Ghz 1.47 Ghz
windows vista home x32

I have been trying for a month to update to Windows 7 but every time I try it stops me when its gets ready to load the Startup screen, its says "welcome", and then it says "shutting down", then it boots up to the vista recovery partition of my computer. I use the custom install, formatting the hard drive, and deleting all my information, and it continues to do this. I'm not sure where to go or what to do about this problem, can anyone help me?


Essential Member
Most all of us agree that an upgrade is not the route to take. It leaves useless files on your system and can cause conflicts.

Save all you Documents, Pictures, contacts, videos, music, etc to a flash drive,

Be aware, you will need to re-install your 3rd party applications.

There i poll going on now and "clean" install is winning by a mile,.

I woulds up the RAM yo at least 2GB

Try these downloads directly from Gateway
Gateway Support Drivers & Downloads

What do you think its doing at the welcome screen to make it want to shut down, is it my drivers? I use the custom "clean" install and it still will not work, im not sure what else to do.


Essential Member
Can you get into Windows at all?

I can't when I upgrade to windows 7, and I had to recover back to Windows Vista because it couldn't or wouldn't repair the windows 7 partition, I want to try again, but I don't know how well it will work and I want to make sure all problems that I may run into are fixed before I go through all the hassle. I updated my BIOS, but I don't know if that problem fails during system startup at the welcome screen.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.