Windows 7 intermittently drops wired internet/lan connection.

Discussion in 'Windows 7 Networking' started by AlanAngle, Jan 28, 2010.

  1. AlanAngle

    AlanAngle New Member

    Joined:
    Jan 28, 2010
    Messages:
    6
    Likes Received:
    0
    In a nutshell, my Windows 7 Ultimate (64bit) PC intermittently drops it's internet connection. Why?

    Background: My PC is wired to my ADSL modem/router which is directly connected to the phone line. I also have wireless connectivity turned on within the router for a laptop to connect wirelessly.

    Every few hours or so, when using my PC, I find I cannot access the internet and pages will not load. Eventually, Windows7 will update the network icon in the task-tray to show the exclamation mark symbol on the network icon. Opening up the Network And Sharing Centre will show the red cross between the "Multiple Networks" and "The Internet".

    I'm running Sun's VirtualBox on this machine and that creates a Network connection for itself. This doesn't seem to affect the intermittent dropping (i.e. the intermittent drops occur whether the VirtualBox connection is in use or not), and indeed, I have VirtualBox installed on two other machines (one Windows XP and the other Vista Home Premium (32bit)) and these operate with no issues.

    When the connection does drop, I cannot access any internet pages, nor can I access the router's web admin page at http://192.168.1.1/, so I'm assuming I've lost all local LAN access too.

    It's definitely not the router (or the internet connection itself) as my laptop, using the wireless connection (and running Vista Home Premium) continues to be able to access the internet (and the router's web admin pages) just fine.

    Every time this happens, I can immediately restore all internet and LAN access by opening Network Adapter page, disabling the "Local Area Connection" and then re-enabling it. Give it a few seconds and everything is fine again. I assume this is because, beneath the GUI, it's effectively doing an "ipconfig /release" then "ipconfig /renew".

    The IP assignment for the Windows 7 machine is the same both before and after the "drop". I have a DHCP server on the router issuing IP Addresses, however my Windows 7 machine uses a static address (192.168.1.2). I've also tried it with a dynamic IP Address (served up from the ADSL router) and there's no difference.

    There are also no specific clues within the various System Event Logs, other than an event that relates to the connection dropping which is a "DNS Client Event" and this is generated after the connection has dropped and is an event detailing that DNS information can't be found for whatever website I may be trying to access, just after the connection has dropped.

    The network adapter chipset is Realtek PCIe GBE Family Controller and I have confirmed that this is the correct chipset for the motherboard (Asus M4A77TD PRO), and in fact, Windows Update installed an updated driver for this on 12/Jan/2009. The details of the update say that it's a Realtek software update from December 2009. Incidentally, I was still having the same intermittent problems prior to this update. It seems to have made no difference at all.

    Does anyone know why this is happening and how to fix it? I've searched for answers to this and seen quite a few other people (even on MSDN/Technet forums) experiencing the same or almost the same problem, but with no clear resolution. Suggestions of turning off IPv6 on the LAN adapter, and ensuring there's no power management "sleeping" the network adapter have been tried but do not cure the problem. There does not seem to be any particular sequence of events that cause it to happen either. I've had it go twice in 20 minutes when just randomly browsing the web with no other traffic, and I've also had it go once then not go again for 2-3 hours with the same sort of usage.

    Can anyone tell me why this is happening and how to make it stop?
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    You can try Realtek, I know that they have updated some of their drivers as recently as a couple weeks ago, so that may be an option. You can also try this, sometimes it helps.
    1. Right-click “cmd” icon and select “Run as Administrator“. This should launch the command prompt with elevated permisions.
    2. Run the following command to check the enabled offload tasks:
    netsh int ip show offload
    This is what I get->
    Interface 1: Loopback Pseudo-Interface 1
    Interface 11: 192.168.1.69
    ipv4 transmit checksum supported.
    udp transmit checksum supported.
    tcp transmit checksum supported.
    tcp giant send offload supported.
    ipv4 receive checksum supported.
    udp receive checksum supported.
    tcp receive checksum supported.
    3. Run the following command to disable all Task offloads:
    netsh int ip set global taskoffload=disabled (This should disable all the offloads)
    4. Disable and Enable the NIC (IMPORTANT)
    5. Check if all Offloads are disabled from an elevated command prompt.
    netsh int ip show offload
    If you've done this correctly the results shouldn't show any offloads
    This is what I get->
    Interface 1: Loopback Pseudo-Interface 1
    Interface 11: 192.168.1.69
    6. To reverse this simply
    netsh int ip set global taskoffload=enabled (This should re-enable all the offloads)
    7. Disable and Enable the NIC (IMPORTANT)
    Keep us posted
     
  3. AlanAngle

    AlanAngle New Member

    Joined:
    Jan 28, 2010
    Messages:
    6
    Likes Received:
    0
    Many thanks for your reply. I have tried what you suggest, however, my "netsh" command shows no offloads running (I'm sorry I can't include an exact output dump here as I'm on a different PC at the moment (I will endeavour to post this later today).

    However, I have found some interesting new information regarding this problem:

    On another forum, someone suggested that I should try running Windows in "Safe Mode With Networking" and see if the problem continues to occur. This was a fantastic suggestion and I don't know why I didn't think of it sooner myself.
    So, I proceeded to run in Safe Mode with Networking for a number of hours, and amazingly, the "drops" didn't occur once. It was a positive discovery, however, due to the intermittent nature of the original problem, I wasn't completely convinced that the problem was cured.

    One thing I did note is that the fan on my GFX card was running alot louder than normal. This is due to the fact that I have an ASUS ENGTS250 graphics card (ASUSTeK Computer Inc.) which had a known problem with a noisy fan until a BIOS update fixed the issue.
    (See the "Manufacturer Response" here: Newegg.com - ASUS ENGTS250/DI/512MD3 GeForce GTS 250 512MB 256-bit DDR3 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card - Desktop Graphics / Video Cards for details).

    Well, running in safe mode had the fan running (incorrectly) at full speed (as it did before the BIOS update), but with an (apparently) stable network connection. Obviously some driver was not loaded for the GFX card when in Safe Mode so this got me thinking about the GFX card (since the very noisy fan was quite obvious when running in Safe Mode).

    I rebooted into normal mode, and found that Nvidia had a very up-to-date new driver for my GFX card (only about 1 week old), so I downloaded the appropriate driver and installed it. After installation and a reboot, I was able to use my PC for an entire day with NO NETWORK DROPS!!!
    This was on Saturday. However, on the Sunday, I also had my PC for pretty much the entire day and experienced 2 network drops. No other changes have been made to my PC in this time.

    So, the story seems to be that updating my graphics card drivers seems to have improved (if not completely fixed) the issue, however, I'm still searching for a proper fix for this problem. Hopefully, this information may help anyone who may have additional ideas as to why this problem is occuring in the first place. (And why does new GFX card drivers have anything to do with the network?)

    Any further ideas of what's causing this issue and how to fix this particular problem?

    Thanks In Advance.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    You are difinitely on the right track. I would suggest continuing updating all of your drivers where ever you find an update is available, even checking to see if there is a bios update for the MoBo. Did you check with the RealTek site to see if the network adapter has a more recent driver? If your computer seems to run fine in safemode with networking then that would suggest that there is some application and or service that is starting up at boot time which is producing this problem perhaps trying this step by step clean boot process will help you find the culprit How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
     
  5. AlanAngle

    AlanAngle New Member

    Joined:
    Jan 28, 2010
    Messages:
    6
    Likes Received:
    0
    Hi Trouble,

    Thanks again for replying.

    Yes, I checked RealTek's website for the very latest network drivers. I've been running them since last weekend, and they were only about a week old when I downloaded them. In and of themselves, they didn't make much difference, however, with the updated drivers for the GFX card, it seems a lots better (if not quite cured completely).

    Yesterday, I found a very recent BIOS update for my Mobo, so flashed that last night. Not had much time to see exactly what impact that's made, but I'll keep my eyes on it. I will also endeavour to scour the net for updated drivers for everything else.

    It's very interesting that the network seems to be fine in safe mode. I totally agree that there's something in there (driver etc.) that's getting started during normal boot up that seems to intermittently interfere with the network.

    I guess this is going to be a long process of "clean booting" and trying lots of different combinations of driver loading/disabling etc. until I find out just what it is that's causing the issue.

    I'll keep you informed! Thanks again for your help so far!
     
  6. Glennr

    Glennr New Member

    Joined:
    Feb 5, 2010
    Messages:
    8
    Likes Received:
    0
    Not the adapter

    I have the same problem. Connection OK for severel hours, perhaps 8, then I cannot connect to anything including the router. There is no triangle on the tray icon and if I open the network and sharing, there is no indication of this. If I click on diagnose, windows will find an unknown problem but cannot fix it. Resetting the router does not help. I have none of the reported problem services running. I have the latest drivers, firmware and BIOS for everything. Doing a restart will fix it every time.
    I installed a wireless USB adapter and turned off the Realtek on board LAN. The problem still happens randomly.
    It has happened twice while I was actively using the internet. The first symptom was a bit of a slow down and icons and pictures would display as an X on web pages. Then about 30 seconds later there is no connection and the web browser (IE or Firefox) will display the button to diagnose the problem.

    Both the wireless and LAN connection use the same router, but if it was a router I would think that a router reset would fix it and not a windows restart. Also, a wireless laptop Vista will keep going.
    I have turned off all forms of power settings (hibernation, allow windows to power off options, etc.) but if the problem happens while I am actively using the internet that wouldn't make much sense.

    I also changed from spyware doctor to Norton 360 (firewall change) but this didn't help.

    Any other ideas?
     
  7. seniorgeek

    seniorgeek New Member

    Joined:
    Feb 21, 2010
    Messages:
    2
    Likes Received:
    2

    Hello fellow problem solvers,


    I am a newbie to the site. My laptop (Toshiba Satellite) has been dropping the wireless connection every 10 minutes or so since I upgraded to windows 7. I have spent hours researching and trying all the things that seemed to have solved it for other folks. None of these worked for me. Not new drivers, not changing power options, not updating firmware, not even disabling and enabling so many things that I can’t remember most of them.

    In desperation I opened my router (Linksys WRT54RX4) and began going through all my options for wireless networks.

    One of the settings is for UPnP – Universal Plug and Play. When devices have UPnP technology they will connect to each other automatically over the network. On my router it is disabled by default. I wondered if enabling UPnP in my router would have any affect on how my laptop and router connected. I enabled UPnP in my router and rebooted it.

    Since that time, my connection has been much more stable and my laptop loads pages faster that it did prior to enabling UPnP. My signal strength has dropped to poor a few times but as soon as I click a new URL it returns to full strength.

    If your router has UPnP (my setting is in the Administration tab of the router) and you still have not solved this issue, enable UPnP and see if your connectivity improves. As long as you have a firewall and security you should be fine with this enabled.

    If this work around turns out to be temporary I will let you know. I say work around because I like so many, have no clue what the real issue is.

    As a famous programmer once said “Anyone who installs a new system deserves it!”

    Good Luck
     
    Trouble and (deleted member) like this.
  8. Glennr

    Glennr New Member

    Joined:
    Feb 5, 2010
    Messages:
    8
    Likes Received:
    0
    Don't Think UPNP is the Fix

    This sounds like a different problem. Upnp "shouldn't" have this effect. There are many reasons for network connectivity issues. In your case, when you lose the connection how do you restore it? If you can reconnect simply by saying "connect" again or even if the troubleshooter will fix it, it is a different problem. One test is to connect your laptop with a cable or connect another device and see what they do or lastly get (or borrow) a usb network adapter and see it that works.

    What is happening to me and others is that I have both a wired and a wireless connection to my router. About every 8 hours or so, there will be no access to the internet. The ONLY solution is to reboot the PC. rebooting the router will not do it, trying to reconnect will not do and the troubleshooter can not figure out what the problem is. PC worked fine with Vista. Other non-7 devices stay connected.

    Since two separate network devices lose connection to the internet (including the router itself) I have to believe that this is a Windows 7 issue.
     
  9. dabusi

    dabusi Well-Known Member

    Joined:
    May 11, 2010
    Messages:
    2
    Likes Received:
    0
    I am experiencing the same problem and find this post on search engine. May I know if there is any solution so far? One thing I have noticed during my troubleshooting is that the network dropping will always happen when I am opening some websites. Do you have the same situation?
     
  10. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
    Comment..

    You can try: ICSI Netalyzr

    You can check to see if this box is cleared: See Below
     

    Attached Files:

  11. Glennr

    Glennr New Member

    Joined:
    Feb 5, 2010
    Messages:
    8
    Likes Received:
    0
    Not The Same

    Mine would happen without even being active on the internet. In other words, I would be away for several hours then come back and there would no longer be any connection.
    Remember, the defining thing with this problem was that there is NO indication of connection lose. You could just not get anyware. The troubleshooter and the connection icon would show no errors. And the only way out was a reboot.

    HOWEVER, my problem has gone away (I think). I had updated drivers and BIOS but that wasn't it. The only thing that I can think of is one of the MS updates did it even though none of them specificaly stated they fixed network issues. The only other thing that I did was to change my ISPs default DNS server to OPEN DNS.
     
  12. AmeliePlate

    AmeliePlate New Member

    Joined:
    Jun 17, 2013
    Messages:
    10
    Likes Received:
    0
    Re: Comment..

    Windows 7 has this bug and didn't resolve this yet, for this purpose i start using the Realtek because it's really better to manage this LAN and wireless connectivity.
     

Share This Page

Loading...