Windows 7 joining/leaving and rejoining a domain

Discussion in 'Windows 7 Help and Support' started by MartinDay007, Jul 16, 2010.

  1. MartinDay007

    MartinDay007 Senior Member

    Joined:
    Jul 16, 2010
    Messages:
    4
    Likes Received:
    0
    I have a number of new Window 7 laptops and have joined the company domain with no problems (SBS running Windows 2003).

    When I was on the domain I set up a number of printers by browsing the server \mainserver\\OkiC9650 and finding the printer and it and correctly installs the drivers and provides me with full functionality for the printer.

    However, if for some reason I have to leave and then rejoin the domain, and I don't delete the printers first, when I rejoin the domain the printers are no longer showing (as one might expect), and when I try to add them again, or add anything connected to the \mainserver\\OkiC9650 I get an error.

    “Windows cannot connect to the printer.” Operation failed with error 0x00000006




    It don't think it is anything to do with the printer as I can't connect to any printer in this way.



    Although the 0x00000006 indicates a permission problem it is not that or a setting problem as it works the first time and no changes are made other than leaving and rejoining the domain.



    It happens with four laptops, two different makes, and three different models.



    I don't think it is a Server problem as I have tried leaving the domain, and deleting the Computer name from the Active Directory, and even tried giving the joining computer a different name between leaving and joining. I was hoping if it was recognised as a new computer it would work at least once - but still no good.



    I am therefore left with the assumption that the problem is with Windows 7, there must be some sort of reference not being cleared that results in a 'duplication' type error when I try the same action again.


    If I delete the printer first, before leaving the domain, I can rejoin the domain again and setup the printer correctly, the problem is when I don't delete the printer first, I can never then connect to the printer in this way (I can connect directly to the printer if I use the printers IP address).


    I am convince the problem is with Windows 7 - can anyone suggest where the \mainserver\\ reference is being held in Windows 7, or if I am barking up the wrong tree if they could suggest what tree I should be barking at?


    I don't experience any other problems.



    Thanks


    Martin




     
  2. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    Try this :
    Set up the printer as a local printer and create a new port with a type of port : Local Port, in the enter port name put \\Servername\Printersharename and install the driver.​
     
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Just a guess, but I suspect that the problem is associated with a unique identifier called a SID. When the machine is disjoined and then rejoined to the domain is gets a brand spanking new Machine SID, and as a result previous domain resources built with access tokens from a previous access control list associated with the old Machine SID are no longer able to resolve properly.

    EDIT: Error, I used the term "Machine SID" when I actually should have used the term "Domain Computer Account SID". Same principle applys.
     
    #3 Trouble, Jul 16, 2010
    Last edited: Jul 16, 2010
  4. MartinDay007

    MartinDay007 Senior Member

    Joined:
    Jul 16, 2010
    Messages:
    4
    Likes Received:
    0
    Thanks
    Zvit
    for replying, I can confirm that I can set up a printer using the port and/or directly to the printers IP. The problem is that then I don't get all the server configured policies or even things like the Duplex facility, which I do get when I join in the standard way.
     
  5. Yousif Jedo

    Yousif Jedo New Member

    Joined:
    Jul 17, 2012
    Messages:
    2
    Likes Received:
    0
    I face the similar problem and I try the following solution and it fix the problem
    1- unzipe the attachment into C drive
    2- change the computer name to the one u want to join the domain
    3- open CMD and and make sure you are in C drive then type Psgetsid to see the Current SID
    4- Type sidchg and wait for sid change to finish see the screen shot
    5- restart the computer and then join the domain

    Capture.JPG
     

    Attached Files:

Share This Page

Loading...