windows 7 losing network connection

Discussion in 'Windows 7 Networking' started by dinjun, Jan 1, 2010.

  1. dinjun

    dinjun New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    I have upgraded my pc from windows xp to windows 7. Now everytime I'm downloading files, it loses connection. I have a laptop with windows xp on it and it works fine on the same modem. I have cable internet. Time Warner has been here several times and their equipment is working fine. I have disable the firewall, updated all drivers, and checked for conflicts. But cannot find problem. It's not wireless connected thru lan port. Any help would be greatly appreciated.
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Check task manager and see if bonjour and or mdnsresponder is running. If so, open services.msc and set bonjour to manual and stop it. Also while in services, look near the top and see if you have the other bonjour service, it will be near the top and contain a string that looks like a guid some Adobe apps like CS3 install this and it has been know to cause problems. Also disable IPv6 in the properties of your network card, and try setting the DNS servers manually in the properties of IPv4 if there presently pointing at the inside edge of your router try just adding 8.8.8.8 and 8.8.4.4 and see if that makes any difference. If none of that helps post back and we'll see if we can think of anything else.
     
  3. dinjun

    dinjun New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    I've disabled bonjour. didn't have the others . disabled IPv6 and reset my DNS servers in IPv4 to the suggested address, but it still does it. Spend 4 hours on the phone with Windows support trying to figure out the problem. Then spend and hour on the phone with Vonage support. Then called my ISP and spend 2 hours with them trying to correct the problem. My ISP is sending another tech out Tues and is going to exchange my cable modem. They also suggested that I might want to try another network card. Seems like everyone is blaming the other, and no one can figure out what the problem is.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    It very well could be an issue with the Network Interface Card. Can you say specifically which NIC you're using. And when you say "It's not wireless connected thru lan port", the lan port on what specifically.
    If you'd like you can always try this and see if it helps
    1. Right-click “cmd” icon and select “Run as Administrator“. This should launch the command prompt with elevated permisions.
    2. Run the following command to check the enabled offload tasks:
    netsh int ip show offload
    This is what I get

    Interface 1: Loopback Pseudo-Interface 1
    Interface 11: 192.168.1.69
    ipv4 transmit checksum supported.
    udp transmit checksum supported.
    tcp transmit checksum supported.
    tcp giant send offload supported.
    ipv4 receive checksum supported.
    udp receive checksum supported.
    tcp receive checksum supported.

    3. Run the following command to disable all Task offloads:
    netsh int ip set global taskoffload=disabled (This should disable all the offloads)
    4. Disable and Enable the NIC
    5. Check if all Offloads are disabled from an elevated command prompt.
    netsh int ip show offload
    If you've done this correctly the results shouldn't show any offloads
    This is what I get
    Interface 1: Loopback Pseudo-Interface 1
    Interface 11: 192.168.1.69
    If after some testing, this hasn't proved to be any help with your issue, you can simply run the following command to turn the offloads back on
    1. netsh int ip set global taskoffload=enabled
    2. Disable and Enable the NIC
    3. netsh int ip show offload ( to see if they're back)
     
  5. dinjun

    dinjun New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    have tried, and here is what I get when I go to the cmd screen:
    Interface 1: Loopback Pseudo-Interface 1
    Interface 11: roadrunner
    tcp large send offload supported.

    and it doesn't make a difference if it enabled or disabled.
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
  7. dinjun

    dinjun New Member

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    Hey Trouble,
    I really appreciate all of your help and suggestions. Time Warner and Vonage are both sending new routers and I'm going tomorrow to get a new network card. Thanks for the list, it will help me pick a card that works with windows 7. You have been a great help.
     

Share This Page

Loading...