Windows 7 Missing Fonts

Discussion in 'Windows 7 Help and Support' started by Rudolf, May 4, 2012.

  1. Rudolf

    Rudolf Active Member

    Joined:
    May 4, 2012
    Messages:
    6
    Likes Received:
    0
    Hi all,

    my mother's laptop has Windows 7 and has missing fonts. I tried a couple of things like copying fonts from one Windows 7 machine to another but it appears the fonts are already there. I also tried the reset fonts option from the control panel (>fonts). I also tried running some scannow command in prompt and it reported some errors it couldn't fix. Check these screens out:

    Screenshot1. Screenshot2.

    As you can see, when I type something in Google search the letters don't show. Plus, everything is in Times New Roman and sometimes the letters are really small. Tried setting the Arial font 16pts in Mozilla Firefox but didn't work. When inserting the USB stick text is missing from the popup menu.

    So.. anyone any ideas on how to fix this?

    Thanks in advance.

    P.S. I know there are other, similar threads but I'm not sure if bumping is wished here.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I am not familiar with other languages, so perhaps that situation could be involved. But the fact the System File checker finds some errors is a problem. I have seen some files put on a system by an OEM, but they should not effect your fonts.

    You might check the link to see if you can find out what files SFC cannot repair. They may be relevant.

    How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7

    Replacing the fonts is fairly easy to do, so if you cannot, possibly you are trying to replace the wrong ones or they are corrupted but still there.
     
  3. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    302
    Hi

    If You have a PC with Windows 7 that is working normally copy the whole fonts folder and move it to your mother's computer's desktop.

    Select all the fonts in it, right click and say install.

    When it asks you if you want to overwrite the existing fonts, say yes to all.

    When it's done the fonts will all be updated.

    If it still doesn't work correctly then you'll have to move on to configuration problems of some kind, but do that first so you know that the fonts aren't corrupted or not registered in some way.

    Mike
     
  4. Rudolf

    Rudolf Active Member

    Joined:
    May 4, 2012
    Messages:
    6
    Likes Received:
    0
    Well, the problem is fixed. After copying fonts such as Verdana from my own Windows 7 machine to my mother's Windows 7 laptop all I had to do was restart the laptop. That last thing I hadn't done yet and magically solved the problem. So copying fonts is indeed the solution.

    Thanks again for your support.

    Regards Rudolf
     

Share This Page

Loading...