Windows 7 networking whilst using permissions

Dear All,

I currently have a workgroup set up involving 4 computers with Windows 7. The network, prior to my modifications, worked very well, all of the computers were able to access each other's folders.

The only problem with this set up, however, was that there was no permissions set; more accurately, every user had access to every file.

I have now significantly changed the permissions for a folder on one of the computers (we will call it C1). Whereas there was an 'Everyone' user group, I have now deleted this, and there are remaining a 'Staff' user and a 'Manager' user. Now, none of the other computers can access the folder (although they can access other folders on C1 that have not had the permissions changed). All 4 computers have identical Staff and Manager accounts, with identical passwords.

Where the plot thickens, is that when I connect my XP laptop to the network, it will happily connect to the folder with the changed permissions, provided that I give either the 'Staff' or 'Manager' account with associated password.

The permissions are essential as this network is being used in an environment where free access to all files is undesireable.

Any assistance on this would be gratefully received.

Thanks in advance,



Noob Whisperer
First make sure that you log off and log back on the other computers with the Staff and or Manager accounts so that both those users on the other computers receive a new Access Token, reflecting your permission changes. Access tokens are updated at log on, but you may want to try rebooting just to see if there is a caching problem.
If that doesn't help make sure you examine closely both shared permissions under the sharing tab as well as ntfs permissions under the security tab, make sure that in both cases they reflect the permissions that you want. I suspect that they are both ok since the XP machine with the correct username and password is able to access the files, but it won't hurt to check. For a better understanding of how share and ntfs permissions work together you may want to read the following article when you have time.
Hope this helps and keep us posted.

Last edited:
You will probably need to go into Advanced Sharing options on your Win7 machines (in Network and Sharing Center) and enable "User accounts and Passwords" at the bottom of the Work Network section.

The usual way I set these up in a business environment is to remove the Everyone listing, then itemize user by user who can do what. I don't use common accounts accross multiple machines *except* for one IT account, which nobody has the password for but me.

Dear All,

Thank you for your replies, this is very much appreciated.

I managed to solve the problem by removing the homegroup set up that was previously put on the computers, running as well as the workgroup network. I must admit that today was the first time I encountered Windows 7 and perhaps this may have been something very obvious to you all!

I am likely to do more work with Windows 7, so I will certainly look up the information you have both given time and effort to help me; undoubtedly it will be useful in the near future!

Thanks once again, and I hope you all have a lovely evening.



I must admit that today was the first time I encountered Windows 7 and perhaps this may have been something very obvious to you all!
Glad you're up and going. But, believe me, nothing in win7 is ever obvious to anyone. Win7 is clearly the most deeply obfuscated version of windows yet.

Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.