Windows 7 - No Connections Are Available

#1
I am using Windows 7 64-bit Home Premium. I have had this issue for a while and cannot seem to get it resolved. While the issue has not caused me any problems with working on my network/Internet, it is an annoying bug.

When I click on the Network icon on my system tray, I am told that there are no connections available. The Network icon itself though is showing that I am connected. I can access the Internet and my network without issue. I have two LAN adapters in my PC and the issue occurs with both of them. I have tried updating the drivers, uninstalling and reinstalling, disabling and enabling, all to no avail.

Going into the Network and Sharing Center shows that I am not connected to any network. If I pull up the Network Map, it shows my other computers, but that there is no connection to the Internet.

Does anyone have any idea how to fix this issue? I cannot seem to find a resolution on the 'net.

I've attached some screen shots as to what I see.

Thanks,
Merg
 


Attachments

Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Are you using both Network adapters at the same time? You say you tried disabling, so I assume you have run just one.

Looks like your connections get to the switch on the Router, or whatever you are using for an internet appliance, but something isn't correct for the internet connection.

Could you type the following in a command prompt window and attach the resulting text file, which should be on your desktop, using the paperclip on the advanced replies. Edit it for any personal info if you like.

ipconfig /all > %userprofile%\Desktop\ipconfig.txt

You can paste this in a command window by right clicking and select paste.
 


#3
When I get home this evening, I'll post it. And yes, I am only using one adapter at a time. It was working for a while, so I'm not sure when this started. As you can see by the system tray icon it looks fine so I didn't notice the issue until I had clicked on it one day.

- Merg
 


#4
Here's my IPCONFIG results...

Code:
Windows IP Configuration


   Host Name . . . . . . . . . . . . : PC
   Primary Dns Suffix  . . . . . . . : 
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No


Ethernet adapter Local Area Connection 2:


   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Realtek PCI GBE Family Controller
   Physical Address. . . . . . . . . : 00-26-18-94-04-BB
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes


Ethernet adapter Local Area Connection:


   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 00-
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::184a:5eb2:4ed7:ce6a%14(Preferred) 
   IPv4 Address. . . . . . . . . . . : 192.168.1.101(Preferred) 
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Thursday, February 14, 2013 8:51:08 PM
   Lease Expires . . . . . . . . . . : Tuesday, March 25, 2149 5:42:42 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 285222424
   DHCPv6 Client DUID. . . . . . . . : 00-
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled


Tunnel adapter isatap.{3A842E89-699C-43C2-8364-66B9B9CF1763}:


   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes


Tunnel adapter isatap.{8BA9EF62-2F8B-4153-A2B9-66A5B2C28B60}:


   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
I am only using one adapter at a time.

- Merg
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#5
Since I am not the network expert on the site, I will mention a couple of things.

Did you remove the "DNS Suffix Search List. . . . . . :" from your listing? If not, I wonder why it isn't there.

Did you remove the physical address from the Local Area Connection? Perhaps it is because you have two adapters, but the other one does show an address.

I assume you have IPv6 turned off or Unbound, according to one poster.

You have one heck of a Lease time. I have never seen one that goes for 136 years! I would probably have it set to something a little shorter, but I do not have a dedicated address, perhaps you do.

You DNS servers address looks like many others, although my Router gives me addresses on the net and not just the gateway. Are you running a Router and Modem, or some type of Gateway with those devices combined? There may be some type of flow through DNS address ability in some of the settings on the router, you might check. You might try manually setting in the Google DNS public addresses to see if it helps. (8.8.8.8 and 8.8.4.4)

So basically the only thing I can suggest, since your IP addresses seem to be OK is to reset everything, including your Modem and/or Router.
 


#6
I did not remove the DNS Suffix Search List from either adapter listing. I did remove the MAC address from the active LAN connection. I just forgot to do it from the other one (that's fixed now, too).

As for my lease time, I use DHCP Reservations with an indefinite lease time (via DD-WRT on my WRT160N router), so that is how the lease time shows up in Windows. I am actually using OpenDNS with Google DNS as a backup and have those settings on the router itself. I have tried a reset of my modem and router. I have IPv6 turned off.

However, I am connected to the router via a 5-port Rosewill switch. When I think about it, the issue might have started after I added that. If I remember, I'll try a reset of that and even try bypassing it when I get home.

- Merg
 


Last edited:
#7
Well, I bypassed the Rosewill Switch and still have the same issue. This is freakin' annoying.

- Merg
 


#8
Well, I finally resolved the issue and figured that I'd post my resolution here so that others will not have to go through this problem...

This was posted over at Microsoft Technet back in February 2010:
I found a solution for (my version of) this problem. My tray icon never showed the red X, but if I clicked on the icon, the popup showed a bigger icon with a red X, and said "Not connected". As in your case, Internet worked, but I'm unable to setup a VPN connection because it insists on using a non-existent modem, obviously because I'm "not connected" (which I am).

I monitored the processes running the NlaSvc and Netprofm services (using ProcMon), and noticed that both were denied read/write access to subkeys within the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList hierarchy.


The processes were running as Network Service and Local Service, respectively, so I tried adding full access for these service accounts to the entire subkey mentioned above. Notice that permissions are not automatically inherited in the registry, so you may need to explicitly "replace all child object permissions with inheritable permissions from this object".


Within seconds, Network and Sharing Center tells me I'm connected to my domain. Yay!
A reboot was required to fix the tray icon and its popup.
Basically, find the NetworkList tree in the Registry, right-click on it and select Permissions. Click the Add button and enter in the user name of "Network Service". After selecting OK, be sure to update the permissions for the new user for "Full Control" and "Read". Repeat the user addition for "Local Service". Click on the Advanced button and check the box for "Replace all child object permissions from this object". Select Apply. Exit on out of the dialog boxes. Restart the computer and the Network icon and Network and Sharing Center should report the correct information.

HTH,
Merg
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.