Windows 7 not consistently recognizing optical drives and external HD

Discussion in 'Windows 7 Help and Support' started by afwm1985, May 29, 2011.

  1. afwm1985

    afwm1985 New Member

    May 29, 2011
    Likes Received:
    Okay I have been having this problem for the past two months or so where my BIOS and/or Windows 7 is only sporadically recognizing my two optical drives and my external HD. I can't seem to find a fix!

    First, here are my specs:

    OS: Windows 7 Ultimate
    CPU: AMD Athlon II X3 445
    Motherboard: Gigabyte GA-770T-USB3
    RAM: 8GB (4 x 2GB) ADATA DDR3 1333 (PC3 10666) Model AD3U1333B2G9-DRH
    Video Card: Palit GeForce GT 240 512MB GDDR5 Model NE5T2400FHD51
    HD: Western Digital Caviar Blue 500GB Model WD5000AAKS
    External HD: Seagate Expansion External Drive 1TB USB 2.0 Model ST310005EXA101-RK
    Optical Drive #1: Lite-On iHES208 Internal Blu-ray Reader & DVD/CD Writer
    Optical Drive #2: Lite-On iHBS112 Internal Blu-ray Writer
    PS: Corsair Enthusiast Series CMPSU-650TX 650W

    First, the external HD. When I boot, the detecting storage devices screen will always detect my internal HD, but it only detects the Seagate about 10% of the time. So, for instance, when I try to boot Ubuntu from the Seagate, most of the time it hasn't been detected as a boot option. However, once I get into Windows, I can always access the Seagate. I am fairly certain the issue is not with the Seagate because my laptop always recognizes it. I also tried extending the time for detecting storage devices in the BIOS, thinking maybe it just needed more time to get picked up, but that had no effect. Not sure if this is a BIOS or Windows issue.

    Now, the optical drives. My computer now almost never detects the iHES208, and usually does detect the iHBS112. However, for some reason if I try to boot a ISO from the iHBS112 it just boots Windows. Also, when I try to burn it doesn't work. I bring up CDBurnerXP and it has both drives in the drop-down, but no matter which drive I select CDBurnerXP says I need to insert a blank disc even though there is one in it. Tried it with both drives. But if I put a install disc for some program into the iHBS112, for instance, it will read/install whatever's on the disc just fine.

    When I first built the computer back in January, it recognized everything just fine. I'm not sure what set off the problems. Any thoughts!? Even just on how to figure out what the problem is?

Share This Page