Windows 7 not recognizing full 4 gigs

Discussion in 'Windows 7 Hardware' started by Deadpixel, Jan 7, 2010.

  1. Deadpixel

    Deadpixel New Member

    Joined:
    Jan 7, 2010
    Messages:
    2
    Likes Received:
    0
    Hello all, first poster here. I am sorry if this has been posted before but I took a quick scan through various threads and couldn't find a solution for my problem. I recently upgraded from windows XP to windows 7. While in XP I had 2.4 gigs of RAM shown, I have 4 gigs. After I upgraded to windows 7 to maximize my full 4 gigs it seems as if it still only recognizes 2.4 gigs. I tried going through all the various options and couldn't find a legit way to fix my problem, so I came here. Is there anyone who can tell me how exactly to fix this?


    Thanks in advance.
     
  2. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
  3. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    As Joe ays, there is a limit on ram in 32Bit computing. But that does seem a lot that your system is stealing. Try this:
    1. Right-click Command Prompt in the Accessories program group of the Start menu. Click Run as Administrator.
    2. At the command prompt, enter "bcdedit /set IncreaseUserVa 3072"
    3. Restart the computer.
     

Share This Page

Loading...