Windows 7 Professional and it is not easily recognizing other workgroup computers or stay connected

Discussion in 'Windows 7 Networking' started by btemples, May 24, 2012.

  1. btemples

    btemples New Member

    Joined:
    May 24, 2012
    Messages:
    2
    Likes Received:
    0
    My new laptop running Windows 7 Professional and it is not easily recognizing other workgroup computers. When, and if, it does, it does not staying connected to other computers and a wireless printer on my workgroup.
    I have a desktop that is running Windows XP Home. It is sharing its printer and external hard drive to all computers in the workgroup. When I got on the router, I was able to get the Windows 7 machine to see XP box long enough to map a drive and load the printer.
    After rebooting, Windows 7 did not recognize the drive map or the printer. I pinged the XP box and got Destination Host unreachable. The only thing I can ping is the router. Also, when I went to load the wireless printer (with Windows 7 drivers) it did not see the printer even though the printer’s connection light is on. I have two Vista Business machines and one Windows 7 Home computers in my workgroup. These are not having any problems. From those other machines, they can ping each other but they cannot ping the new box.
    It is acting like a setting in Business has it isolated itself and is not allowing traffic. I have searched this problem and it seems to be common but I have not seen a post addressing the Business question. I have tried everything that the help files and forums stated (setting discovery, disabling IPv6, disabling firewall on both, uninstalling virus protection, etc.) with no result. Is there a setting in Business that would prevent it from being visible? What can I do to get this resolved?
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hello and welcome to the forum.
    Make sure the the workgroup name is the same on all nodes.
    Make sure there is not a NetBIOS name conflict or IP address conflict.
    Make sure you enable netBIOS over TCP/IP in the properties of IPv4 in the properties of your network adapter.
    Make sure to start the NetBIOS helper service in the services console (services.msc) and set the startup type to automatic.
    IF the problem persists, zip up a copy of your System Information Utility (msinfo32) and attach it to your next post and we'll have a look and see if we can spot anything.
    Regards
    Randy
     

Share This Page

Loading...