Windows 7 Professional Desktop (wired) can not view Windows 7 Laptop (wireless) on Workgroup

#1
I have a Windows 7 Desktop mainly used as a server to store files and I have a Windows 7 Laptop used to mainly access and store files to the desktop. I do not use homegroups because I find that workgroups work better for what I am doing. I have researched hours and hours on forums and googling troubleshooting tips but I can not find one thing that will fix my problem. So here it is....
My laptop can see, view and access my desktop no problem. It shows up on the network and also sees the media devices on it. I can ping and view and alsp remote to desktop. So this is working as expected.
My desktop however cannot see my laptop on the network. I can ping and view laptop by ip address though. I can also see the laptop as a media device. I just cannot see the laptop as a computer on the network.
I have renamed workgroup, reconfigured windows firewall, disabled windows firewall, and pretty much done everything basic and also some minor registry changed but converted back becuase problem did not fix.
I appreciate any help thanks.
 


Trouble

Noob Whisperer
#2
devoduo;
Hello and welcome to the forums.
If you cannot see the laptop, then something on the laptop is blocking netbios information propagation. So....
Open network and sharing center and from the left column select "Change advanced sharing settings"
Under category "Home or Work" turn on
Network Discovery and File and Printer Sharing
Then type ncpa.cpl into the search or run dialog box and hit enter
Select then right click the network adapter that the laptop is using to connect to the network and choose properties
Select Internet Protocol Version 4 and click the Properties button then click the Advanced button
Select the WINS tab and select the box that says "Enable NetBIOS over TCP/IP" and OK your way back out of there. Then type
services.msc into the search or run dialog box and hit enter
Scroll down to TCP/IP NetBIOS Helper service and double click
Set the startup type to Automatic and Click the Start Button.
On the laptop, pick one folder or file and Share It just as a test. (Can be an empty folder or a blank text file, doesn't matter, but set the share permissions as well as the NTFS permissions under the security tab as you would want)
Reboot the machine.
Test the new share on the laptop from the desktop by typing
\\TheIpAddressOfTheLaptop\ShareName
and then
\\TheComputerNameOfTheLaptop\ShareName
If that still does not work then,
Inspect the laptop for any third party software Firewalls (ZoneAlarm or Comodo, etc.) and Internet Security Suites (Norton/Symantec, McAffee, AVG, etc.) remove them and replace with MSE and the built-in Windows Firewall.
Keep us posted.
 


#3
Ok I am at work right now but will try when I get home in about 4 hours and update. I know that I have Netbios enabled over tcp/ip forsure and network discovery and file sharing.
 


Trouble

Noob Whisperer
#4
OK, thanks and keep us updated. If you find yourself uninstalling any of the software suites, please do so using the control panel and then you may also want to run the vendors proprietary uninstaller for your specific product. There is a pretty good link to most of them here http://windows7forums.com/blue-screen-death-bsod/50402-removal-tools-antivirus-software-drivers.html
 


#5
Well still have no luck. Went through all of that and tried some more of my knowledge and still coming up with the same problem.
 


Trouble

Noob Whisperer
#6
Can you still ping either and both from the other, by IP address.
Can you ping either and both from the other by Machine Name. Please make sure that the machine name of the problem machine is unique on the network.
Clear netbios cache on both
type nbtstat -R (command prompt)
then ping again by IP and name from each to the other
check the netbios cache
type nbtstat -c
Are these the only two machines on the network?
Check the following services on the problem machine
type services.msc into the search box and hit enter
confirm that the following services are started, consider setting the startup type to automatic
Computer Browser
Function Discovery Provider Host
Function Discovery Resource Publication
Network Connections
Network List Service
Network Location Awareness
Network Store Interface Service
Server
SSDP Discovery
TCP/IP NetBIOS Helper
Workstation
 


#7
Well still no luck....all the services you stated were already enabled. My laptop name is Decameron-pc and my desktop is devanserver-pc. I can see devandell-pc on devanserver-pc now but still can't access it. Can ping ip and devanserver-pc on devandell-pc but can only ping ip not devandell-pc on devanserver-pc. I do not understand why this is working. It doesn't make since. If I hook the laptop wired then no problems.
 


#8
Sorry to dig this up from the past, did you ever resolve this issue? I am having the same problem.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.