Windows 7 Random Sleep Issues Even After Reinstall & New Keyboard & Mouse & BIOS Default Settings

Discussion in 'Windows 7 Help and Support' started by AkashaJSummer, Sep 8, 2011.

  1. AkashaJSummer

    AkashaJSummer Senior Member

    Joined:
    Jun 27, 2011
    Messages:
    45
    Likes Received:
    0
    I built a system a year ago, & sleep has always worked fine until a few weeks ago when Windows 7 began to start waking instantly the moment I put it to sleep. Now I have to turn off the power management settings of the mouse & keyboard to stop it from waking. Sometimes it works in reverse too & won't wake with the mouse or keyboard ever when set to in the power management settings.

    I have checked to see what is waking it... & nothing is listed. I have tried 3 different brand keyboard & mouse (with nothing else plugged in), & I have reinstalled Windows 7... but now it always wakes instantly or not at all. I have also reset the BIOS default settings [ASUS P6T Deluxe V2] but the problem persists.

    This is totally boggling my mind, any ideas would be much appreciated.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    We have seen many different reasons for sleep problems on some systems. If it just started, do you remember changing anything? Have there been any Windows updates around the time the problems started?

    Have you checked the Event Viewer to see if any error or warning messages are persistent?

    What did you use to show what might be keeping the computer from sleeping?

    Are you streaming any media?

    Have you checked the task scheduler to see if any tasks might be running?

    If you did not use Powercfg to check for wake items, you might check into that. Open an administrative command prompt and type:

    Powercfg -?

    which will show what switches are available for the utility. Perhaps you will see something you could check.
     
  3. AkashaJSummer

    AkashaJSummer Senior Member

    Joined:
    Jun 27, 2011
    Messages:
    45
    Likes Received:
    0
    do you remember changing anything? No
    Have there been any Windows updates around the time the problems started? Not sure
    Have you checked the Event Viewer to see if any error or warning messages are persistent? Yes
    What did you use to show what might be keeping the computer from sleeping? Powercfg
    Are you streaming any media? No
    Have you checked the task scheduler to see if any tasks might be running? Yes

    I believe all these things would be erelevant because I reinstalled Windows 7 & the first thing I did was check the sleep issue with only a mouse & keyboard & monitor plugged into the PC, plus I tried 3 different brand keyboard & mouse. Because it didn't solve the problem I went ahead & re-imaged my PC back to the state it was in before reinstalling Windows 7.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    After you try putting it to sleep, and it wakes, the powercfg -lastwake does not show anything nor does powercfg -requests.. Sounds like you already checked this, just want to make sure.

    Do you have to change the settings on both the mouse and keyboard for it to sleep, or just one? If both need to be changed, I wonder if the HID service could be involved.

    I will assume you have tried different ports for your USB devices...

    Where are you getting the USB drivers for your system?
     
  5. AkashaJSummer

    AkashaJSummer Senior Member

    Joined:
    Jun 27, 2011
    Messages:
    45
    Likes Received:
    0
    I have to change the power settings on both the mouse and keyboard for it to sleep when connected to the motherboard usb ports...but not when the mouse/keyboard are connected first to a usb hub & then to the motherboard usb ports. When connected to the usb hub the pc sleeps but the mouse/keyboard does not wake it. This is also true for when the mouse/keyboard are connected to my pci usb card.

    I have tried different usb ports.

    When ever I unplug the mouse/keyboard & put into a different usb port the "HID Keyboard Device" & "HID-compliant mouse" drivers install automatically.

    Capture.JPG
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You seem to have thrown some new devices into the situation. An external USB hub and a USB add-on card. Since I do not run either of those, I am not familiar with how they might be involved with your situation, but I assume you have the latest drivers for the card.
    For a wireless device to be able to wake the computer, it may need to stay active. I do not run that kind, so I cannot verify its operation.

    The fact you cannot wake if the mouse or keyboard is connected to the hub is probably normal. I don't think going through a hub is the same as connecting directly. I run Bluetooth devices and I have to use the power button to wake.

    What is the output of the powercfg -lastwake after your unwanted wake occurs?
     
  7. AkashaJSummer

    AkashaJSummer Senior Member

    Joined:
    Jun 27, 2011
    Messages:
    45
    Likes Received:
    0
    Previously when sleep was working I had both the mouse/keyboard connected to the hub.

    Interestingly, today the keyboard usb receiver that is plugged into the hub instantly woke my PC!...so I had to disable it's power settings to get it to stay asleep. Yesterday the power settings for the keyboard where active & it was plugged into the hub, but the pc went to sleep & would not wake. It has been going back & forth like this...I have tried all different combinations of the power settings to try & find which HID is? causing the problem. At one stage I narrowed it down to one of the HID by process of elimination but the rules changed & suddenly the HID I had isolated no longer caused the problem. The fact that when I reinstalled Windows, in it's default state, it still instantly woke is puzzling...all I had plugged in was the monitor & the mouse receiver into the motherboard usb port...then I tried another port...then I tried different brand keyboard/mouse in different usb port combinations. Could it be something to do with the motherboard? I contacted them but their advice did not solve the problem (reset CMOS, change a few BIOS settings).

    Capture.JPG
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I have a basic P6T and never had any problems with sleeping. I seem to remember something about one of the variants, but it has been too long. Possibly you could find something on the net. I will try to compare the boards to see if I notice something that might be relevant.

    You are changing so many things so quickly, I cannot keep up. I would just run a basic setup with no USB hub and see if you can get it to work.

    Someone in another thread stated they found a task checked in the Task Scheduler but did not show up as a last wake entry. You might check yours by opening Task Scheduler, Microsoft-Windows-Multimedia. See if SystemSound is listed and and under the Conditions Tab, see if "Wake the Computer to run this Task" is checked. This is not a default setting for Windows, but for some reason his was checked. When I checked it on my system, it did keep the system awake, but did show up on the lastwake report.
     
  9. AkashaJSummer

    AkashaJSummer Senior Member

    Joined:
    Jun 27, 2011
    Messages:
    45
    Likes Received:
    0
    "Wake the Computer to run this Task" was unchecked.

    I included the info on the hub & pci usb card because I thought it might give a clue as to what might be causing the issue...but to make things easier just disregard that info.

    So to clarify...the pc wakes instantly when a mouse/keyboard is plugged into the motherboard usb ports, & I have to disable the power settings to get the pc to sleep.
     

Share This Page

Loading...