Windows 7 Registry nightmare

#1
Ok, I have been having this problem for a couple days now and have searched countless sites for answers. I am not able to run Regedit, Regedt32 or any type of .reg script file. From within Windows, I get either Access Denied or can't find file. From an Elevated Command Prompt, after running a directory check to ensure the file is present, I can type Regedit or Regedt32 and I get the error...The system can't find the file (whatever file I'm trying to run).

I have also, through Explorer, gone through and Rt clicked properties and attempted the allow full access on these file with some saying Access Denied.

Has anyone else ran into this problem yet? If so, please, please let me know how to fix this.

I am running: Win 7
6.1.7600 Build 7600
x64 based Pentium Dual Core HP Pavilion

I look forward to any an all replies.

Thank you,

Joe
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
I would say you might first need to fun an SFC /scannow from an elevated command prompt.

I am not running as a normal user, but as a User/admin, I can run regedit fine. Use Winkey + R then type regedit and hit OK.

Has anything happened that might have messed up your Win 7 install?
 


#3
First, you should check your privilege, your current account may not be the administrator so you cannot make changes. Then if you still cannot fix the problem, you scan your computer to check the presence of virus.
 


Mitchell_A

Essential Member
#4
If the two above suggestions don't fix your problem, maybe try taking ownership of those files
Download this registry file to add "Take Ownership" to the context menu then navigate to the files, right click on them and select.. you guessed it, "Take Ownership"
Add take ownership to context menu in windows 7
 


RAK

Extraordinary Member
#6
Have you by chance been modifying he registry in the past, or gpedit seting? If the latter, have a look here
The message you're getting can sometimes be related to a policy malfunction.


In start type Gpedit.msc.Open user configuration. - Administartive templates - System.
Scroll down to "prevent access to registry editing tools" and make sure it says "not configured"(that's the default) or "disabled"
 


reghakr

Essential Member
#7
What have you been doing in the registry:rolleyes:

I might have a vbscript to help you out.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.