Windows 7 Windows 7 Registry Permissions

Discussion in 'Programming and Scripting' started by DSell88, Nov 6, 2009.

  1. DSell88

    DSell88 New Member

    Joined:
    Nov 6, 2009
    Messages:
    2
    Likes Received:
    0
    Greetings,

    I'm currently in the process of building a Windows 7 image for my institution. I'm trying to implement a few registry hacks that we've standardly used at least as long as I've been here. All of the keys still exist, but here's the one weird thing: the administrators usergroup does not have permission to edit any of these keys in Windows 7.

    The only way to edit them is by giving ownership to the Administrators usergroup. We like to script first config stuff, since that way we can do everything in one fell swoop rather than trying to remember what we did from year to year, and I've tried a couple of different approaches to taking care of this problem using scripts. I've tried using takeown, and searching for a powershell solution, and the closest I've gotten is with subinacl.

    However, even though the most recent version as far as I can find (circa 2004) seems to process the key and all of its subkeys without any errors, nothing appears to change when I look up the permissions manually. Any ideas?
     

Share This Page

Loading...