Windows 7 RTM Offline Help & Support Broken

#1
Hi,


I am current using Windows 7 RTM 32-bit and I am having issues with the Help and Support feature in Windows. All of the links seems to be broken, and images are not appearing. There are also weird keywords appearing in the content, e.g __elbasuer__ (Reusable reversed). I have came across a few posts in the forum, but none specifies a reasonable solution to the problem. My friend, who is using the same RTM build is having the exact same problem with me as well. Below, I provide a few screenshots regarding the issue:


Page displayed when the Home button is press, or when Help and Support is first launched:
http://img28.imageshack.us/img28/4615/homepageo.jpg


Page displayed when the Ask button is pressed:
http://img246.imageshack.us/img246/6539/askbutton.jpg


Search for a common term 'Internet Explorer' returns 0 results:
http://img7.imageshack.us/img7/9978/searchm.jpg

Switching to Online Help will solve all the problems, but that wouldn't be accepted as a permanent fix as sometimes I might not have internet access and not to mention, it is slower than the offline help.

I really hope someone would enlighten me with a solution to fix the annoying issue on the Help and Support.


Thanks in advance.
 


RAK

Extraordinary Member
#2
The error did appear in certain downloads, in particular those originating from a Chinese site. Maybe not in your case - just an offer.
 


#3
I am certain that the ISO I downloaded is official as the SHA-1 hashes matches the one released by Microsoft. I have also used the disc to install a new copy in a virtual machine, and the Help and Support issue did not occur there. I have searched the internet about the issue, and seems like Windows Vista was previously having the similar issue caused due to the xml handling by Dreamweaver 8. However, that fix does not work in my Windows 7 installation in this case.

Regards
Plexion
 


#5
I'm sorry but that doesn't fix the problem I am having =(

The help works fine in online mode, but not in offline mode, which I think does not have anything to do with winhlp32.exe

Regards,
Plexion
 


#6
i was actually experiencing the same problem on broken links, icons cannot be displayed and all those stuff..i tried also the winhlp32 but did not work.
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#7
Have you tried running a sfc /scannow from and administrative command prompt?
 


#8
Have you tried running a sfc /scannow from and administrative command prompt?
Saltgrass,
i tried it.but at the end it says 'windows did not find any integrity violations'..:(
 


reghakr

Essential Member
#9
Here is the solution, I found after long time research.It`s caused by bluetooth software. I had the same "elbauser" corroptud help file. After you do this you`ll have windows original offline help files

  1. Click on Start, type regedit.exe in the Search field, and press Enter.
  2. Provide consent to User Account Control if prompted.
  3. In the left hand navigation pane, expand each registry key until you are at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Assistance\C lient\1.0\Namespaces\OEM\en-US\Topics.
  4. Delete the "BCRM_Bluetooth_Help" string value (REG_SZ).
  5. Close the Registry Editor and re-launch Windows Help and Support.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.