Windows 7 system missing from Explorer -> Networking -> Computers

Discussion in 'Windows 7 Networking' started by derekoharrow, Aug 10, 2010.

  1. derekoharrow

    derekoharrow New Member

    Joined:
    Aug 10, 2010
    Messages:
    2
    Likes Received:
    0
    Hi,

    My main Windows 7 PC is no longer appearing from the other PC's under Explorer->Networking->Computers. As a consequence, this also means that it's not visible to my WDTV Live which I use to access media files from the PC over CIFS.

    This PC is the only one on my network which is running Windows 7 Ultimate x64. The others are all running Home Premium x86 (all fully patched).

    I first thought this was a problem with the WDTV Live HD as these are known to have "challenges" talking to Win7, but I've been through all the diagnostics and still can't make any progress.

    If I directly try to access this PC, using \\computername\ then it works fine, it's just not visible in Explorer, hence the WDTV Live can't see it (and you can't add direct names/connections to the WDTV Live as a work-around).

    This was all working fine before I went on holiday, but since I've come back it has stopped working (and the PC was turned off the whole time I was away and no-one had access to it). MS did apply a patch when I got back, so I'm wondering if one of them has messed it up (KB2286198 to be precise).

    I've tried the usual things - checked the workgroup name (WORKGROUP), turned-off the firewall, tried all of the WDTV diagnostics/changes people recommend, etc, and still no joy.

    Anyone got any ideas/suggestions as to how to fix this? It's really annoying!

    Thanks in advance!
    Derek
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    derekoharrow:
    Hello and welcome to the forum.
    Double check the Network and Sharing Center, Change advanced sharing settings and make sure that network discovery hasn't been turned off for some reason, you may also want to make sure file and printer sharing is turned on and of course you will need to make sure that the machine is actually sharing something.
    Additionally, open the service console, by type services.msc into the search or run dialog box hit enter, scroll down to SSDP Discovery and make sure it is started. You may even want to set it to automatic for the startup type.
    You may also want to check the properties of IPv4 for your network adapter
    Type ncpa.cpl into the search or run dialog box and hit enter.
    Right click your adapter(s) and choose properties
    In the properties dialog box select Internet protocol version 4 and click the properties button
    In the resultant properties dialog box click the advanced button
    In the advanced dialog box select the WINS tab at the top
    and near the bottom choose the Enable NetBIOS over TCP/IP radio button
    OK your way back out of there.
    You may want to reboot the machine just to make sure any and all changes take effect.
     

Share This Page

Loading...