Windows 7 will not connect to wired network at work.

#1
My work network consists of a cable modem with a static IP from there it goes into a Cisco 871W wireless router/vpn then into a 48 port switch. My problem is that all other computers running Windows 2000 professional and XP connect to this network except for the new laptop running Windows 7. I can connect immediately to all other networks, whether they are wireless or wired except for this one. I can connect to the Cisco 871W through the vpn from a outside internet connection.
 


Trouble

Noob Whisperer
#2
try this
type ncpa.cpl into the search box and hit enter
right click your wired adapter and choose properties
at the top of the properties dialog box select the button that says configure
in the resultant dialog box select the advanced tab
in the left column choose Speed & Duplex, it may say something like Link Speed/Duplex Mode or something else, whatever
in the right column use the drop down arrow and change auto negotiation to 100 half and reboot
if that doesn't help try 10 half and reboot
if neither helps return it to auto negotiation
keep us posted.
 


#3
I tried both settings and it tries to connect, shows "network 2" for a second then kicks it back and shows "unidentified network" with the yellow triangle.
 


#4
Oh, and then sometimes it gives me an IP conflict warning screen.
 


Trouble

Noob Whisperer
#5
That's interesting unidentified usually means you're not getting DHCP and Win7 is substituting an APIPA address without a default gateway, while an IP conflict would mean that you did get an IP from DHCP but for some reason it's duplicated somewhere else on the network, probably assigned statically and wasn't provisioned for with the DHCP scope or excluded from the scope.
Were you able to do a ipconfig /all to see what if anything you are getting in the way of DHCP from whatever is providing it on your network. Also you may want to check with whoever is managing the network and make sure that their is no mac filtering or other security provisions in place that may be causing your issue.
 


#6
 


Attachments

#7
It's strange. I can unplug the network cable from the laptop running 7 and plug it into another laptop running xp and it connects immediately.
 


Trouble

Noob Whisperer
#8
check the ipconfig /all information that the computer running xp displays and compare them. Is the IPv4 information complete?
You are not getting valid useable DHCP information from the router.
The 169.254.49.229 is an APIPA address and there is no default gateway present
The IPv6 information is a "Link Local Address" which I believe is IPv6's version of APIPA and for communicating between nodes on the same subnet (not positive).
If your existing network does not support a full blown implementation of IPv6 then you need to resolve the IPv4 problem.
Have you tried an ipconfig /release and then an ipconfig /renew? Are you in a situation where you can assign static values to the properties of IPv4 just to see if the problem is between your NIC and the DHCP server? Have you tried disabling IPv6 from within the properties of your adapter, just to see if there is an issue with the DHCP server (Router? guessing) having problems with IPv6?
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top