Windows 7 won't boot...without my old hard drive

Discussion in 'Windows 7 Help and Support' started by Morbidious, Apr 10, 2010.

  1. Morbidious

    Morbidious New Member

    Joined:
    Apr 10, 2010
    Messages:
    8
    Likes Received:
    0
    Hello,
    I've recently installed win 7 home premium on a new hard drive. I have two HD in my PC.

    C:\ hard drive with XP installed
    D:\ hard drive with windows 7 installed

    For some reason w7 won't boot unless the old xp drive is set to priority. If i set the new drive with w7 as priority it just hangs at DMI pool data... This is annoying as i was planning on formatting the xp drive and removing it.

    Any ideas what the problem is?

    Thanks
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    That happens because the boot files were placed on the first active partition, the XP drive. In order to fix it you need to make the Win 7 partition active, then do one of the following.

    Boot into Windows, open an administrative command window and using the drive letter of the Windows install, type the following:

    bcdboot C:\Windows /s C:

    Wait for a response then exit the window. This will put the boot files in the C: partition (I am assuming you do not have a 100mb System Reserved Partition).

    Disconnect the XP drive or make the Win 7 drive primary in the bios and reboot.

    An alternative method, after making the Win 7 partition active, is to set it first in the bios or disconnect the other drive and run the startup repair option from the install DVD or Repair CD 2 or three times.

    Just a note, I have not seen anyone get a DPI pool data message, but usually it is a bootmgr not found.
     
  3. Morbidious

    Morbidious New Member

    Joined:
    Apr 10, 2010
    Messages:
    8
    Likes Received:
    0
    Thanks for the reply saltgrass
    Unfortunately copying the files using that command didn't work..........neither did the second method,.windows stated that there was nothing to fix.
    Is there a way i can manually copy the boot files to the win7 drive? I suppose i could keep the setup as it is, but i really don't want two hard drives in my pc. I only installed a new hard drive just in case anything went wrong during the w7 installation ( which incidentally went smoothly and painlessly)

    Thanks again
     
  4. Morbidious

    Morbidious New Member

    Joined:
    Apr 10, 2010
    Messages:
    8
    Likes Received:
    0
    I should point out that the bcdboot C:\Windows /s C: did work and copied the boot files. I set the win7 drive as priority in the bios but it still didn't boot. Had to revert back to the original priority
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Did you set the partition to active?

    How about attaching a picture of your Disk Management window using the snipping tool.
     
  6. Super Sarge

    Super Sarge New Member

    Joined:
    Jun 4, 2009
    Messages:
    1,737
    Likes Received:
    64
    Have you tried going to run type msconfig in the boot tab select the os you want as your default that should fix you right up, next time you boot you should get a option to select the os you want to boot to.
     
  7. Morbidious

    Morbidious New Member

    Joined:
    Apr 10, 2010
    Messages:
    8
    Likes Received:
    0
    Got it sorted guy's. I used this sequence to rectify:


    bcdboot c:\windows /s c:

    bootsect /nt60 c: /mbr

    diskpart

    sel vol c

    act

    sel vol d

    inact

    exi

    Thanks for replying to my OP
     

Share This Page

Loading...