Windows 7 Windows 7 World of Warcraft issues.

Discussion in 'Windows Games' started by Dennis Coghill, Nov 14, 2010.

  1. Dennis Coghill

    Dennis Coghill New Member

    Joined:
    Nov 14, 2010
    Messages:
    2
    Likes Received:
    0
    I recently upgraded to Windows 7 and my fps is terrible, to the point of not being able to play, in or out of major cities. Currently i am running the lowest resolution and settings and it seems to not really change anything (except minimally; 2-3 fps faster than my previous settings that ive raided at for 2+ years). Are there any fixes for this? Below is my dxdiag, any help is appreciated. Email/post questions or more info needed.


    Operating System: Windows 7 Home Premium 32-bit (6.1, Build 7600) (7600.win7_gdr.100618-1621)
    Language: English (Regional Setting: English)
    System Manufacturer: Dell Inc.
    System Model: Inspiron 531s
    BIOS: oC)Phoenix - AwardBIOSTeDell System v6.00PG
    Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4400+ (2 CPUs), ~2.3GHz
    Memory: 3072MB RAM
    Available OS Memory: 3006MB RAM
    Page File: 2520MB used, 3492MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    DxDiag Version: 6.01.7600.16385 32bit Unicode

    Card name: NVIDIA GeForce 6150SE nForce 430
    Manufacturer: NVIDIA
    Chip type: GeForce 6150SE nForce 430
    DAC type: Integrated RAMDAC
    Device Key: Enum\PCI\VEN_10DE&DEV_03D0&SUBSYS_020E1028&REV_A2
    Display Memory: 1065 MB
     

Share This Page

Loading...