Windows 7 x64 fresh build random bsod

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by Ton, Jun 19, 2010.

  1. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    I built my pc a couple of days ago, and from the first day i ve been getting bsod with various errors like system service exception, page fault i nonpaged area, bad pool header, memory management. Internet explorer and firefox are crashing also and after that sometimes the bsod follows.
    Here's a screenshot with the installed programs (firefox and nod32 were installed but then uninstalled)
    i also attach the minidumps.

    Operating System: Windows 7 x64 Professional
    Processor: Amd phenom II x4 965 BE
    Motherboard: GA-890GPA-UD3H (rev. 2.0)
    Video Card: onboard
    Memory: G.Skill F3-10666CL9D-4GBECO (2x2GB)
    Hard Drive: Samsung Spinpoint F3 1TB (150+781 partition)
    Network Adapter: Zyxel G-202 usb
     

    Attached Files:

    #1 Ton, Jun 19, 2010
    Last edited: Jun 19, 2010
  2. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Hey.

    You're getting various errors which usually lend itself to being a hardware problem. Let's not look there as of yet.

    Some of the errors are 0x3b and memory management ones.

    This driver is too old and must be updated:
    Code:
    WlanGZ64 WlanGZ64.SYS Mon Sep 22 23:14:10 2008
    It is for your wireless adapter. Please install the latest one found on this page:

    ZyXEL

    Also, there is a slightly newer video driver available so I recommend you install that:

    Drivers & Support | GAME.AMD.COM

    Other than that, things look to be fairly alright. After making these changes, please let us know how it's going and/or post a new crash dump if necessary.
     
  3. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Another thing I noticed is that your memory is slightly unusual in that it is meant to be run at less than standard voltage. According to the page I link to, it is supposed to have 1.35v as opposed to standard 1.5v.

    So, you can go into your motherboard bios and set the vdimm memory voltage to 1.35v and also set the timings manually too, which are
    9-9-9-24, 2N.

    Doing this and also updating the wireless adapter and video card driver should alleviate all the bsod I think.

    G.SKILL-Products
     
  4. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    Firstly thank you for the replies,
    i have a question, in the g-202 driver zip there are two folders one 2k_xp and one vista, i guess for the windows 7 i use the files that are in the vista one right? I did update the zyxel one but in device manager it says version 2.2.0.7 instead of 5.20.

    Also about the video driver version i went to Motherboard/Integrated Video Drivers and went to Individual Drivers where i downloaded the South Bridge Driver, the problem is that when i run the installer is says that the north bridge filter driver is not installed even though i ve installed it earlier, so even if i reinstall it, next ti me it will say that its not installed.

    So i decided to download the full catalyst software suite. when i run it and tried to install what drivers it had, in the process an error occured and then i had a bsod where windows needed start up repair, i managed to log in again and i uninstalled the drivers with the suite and installed them again, this time no erros occured.

    I also changed the volts from bios before messing with the catalyst suite.
    I m attaching the new dumps and a screen from cpu-z, is the ram now correctly set?

    If i reinstall windows is it possible that it will be solved? Is there a specific order in which i should install the drivers? i think that all the drivers i need(including vga) are in my motherboards site. GA-890GPA-UD3H (rev. 2.0) - GIGABYTE

    If i install the 32bit version now, since 512mb of my memory will be used for the gpu(right now it says installed 4gb usable 3,5gb) will all the remaining ram be used? i m asking cause i ve heard that in 32bit the max memory is a little more than 3gb.
     

    Attached Files:

  5. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Alright, first about the USB adapter driver.

    When done installing, the driver date should be 3/26/2010. Here is how to install it:

    1) Extract the Vista folder from the driver download to a folder on the pc.
    2) Open device manager. Expand the network section and then right click on the Zyxel one. Choose update driver software. Browse my computer. Let me pick. Have disk. Browse. Then find and double click on WlanGZGV64.inf in the folder you extracted.

    Hit ok then hit next and it will install.


    ------

    Now about the video driver. You can install the vga driver which is from May 4, 2010 from the link for your motherboard that you posted in the last post. Just be sure to choose Windows 7, 64 bit in the downloads and it will be there.

    ------

    I wouldn't reinstall Windows as of yet because it is probably the usb lan driver causing issues. Update that as advised and then after, let us know how it's going and/or post new crash dump then.

    Good move by setting the memory in the motherboard bios. I'll need to see a screenshot of the memory tab of CPU-Z to see if it is now correct. :)

    You're welcome and good luck.
     
  6. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    I did a bios update, i had FA and i installed FC and for now everything seem to be fine :)

    As for the zyxel driver i did what you said and its still the same version. I noted that when i open the WlanGZGV64.inf with the notepad it says
    DriverVer = 07/29/2008,2.2.0.27
    I have downloaded the correct zip from the site so can you verify it please?

    edit: here is the memory tab from cpu-z.
     

    Attached Files:

    #6 Ton, Jun 19, 2010
    Last edited: Jun 19, 2010
  7. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Memory looks good. You can change the bank cycle time to 31 as per SPD, from the 33 you have it set to now.

    Here's a little trick you can do about the Zyxel driver. Take the 64 bit .sys file from the Vista folder and copy it directly over the one in C:\Windows\System32\drivers

    then reboot. That will for sure update the driver and should be reflected in the device manager.

    Hopefully bsod are now gone. Good move about updating bios. :) As always, keep us updated and tell us how it's going.
     
  8. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    Sorry about not being clear but i meant when i open the WlanGZGV64.inf that i downloaded. So i think that its not that it doesnt update its that what i have downloaded doesnt isnt updated :S thats why i ask you to verify if that's what it says.

    Bios must have been the problem for sure since i dont have any bsod until now which is a perfect sign if you take in mind that before the update i had a bsod every five to ten minutes!
     
  9. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    I dont know why but from the moment i turned on my pc today i am getting bsod again!
    I didnt have even a single problem yesterday after the bios update.
    Now that i am in safe mode it seems more stable, if i dont get bsod it probably means that its a driver problem, right?
    Here are today's dumps.

    edit: i got a bsod in safe mode :(
    i updated the minidump rar, the last minidump is in safe mode..
     

    Attached Files:

    #9 Ton, Jun 20, 2010
    Last edited: Jun 20, 2010
  10. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    We're dealing with a mixture of a few problems.

    First, there is this 0x24 error which is the first seen in the thread now:

    Code:
    Use !analyze -v to get detailed debugging information.
    
    BugCheck 24, {1904fb, fffff88006d5fb58, fffff88006d5f3c0, fffff880012460fd}
    
    Probably caused by : Ntfs.sys ( Ntfs!NtfsAcquireFcbWithPaging+12d )
    
    Followup: MachineOwner
    ---------
    That tells us that there is either a physical error with the hard drive itself (most likely), connection to it or damage to a storage driver. It actually in rare instances can be caused by antivirus, which leads me to your other errors, one of which has been a 0x3B stop. That is caused when video drivers pass bad data to the kernel code, and antivirus is usually responsible for this as well...

    Code:
    Use !analyze -v to get detailed debugging information.
    
    BugCheck 3B, {c0000005, fffff960000a409e, fffff88009957a70, 0}
    
    Probably caused by : win32k.sys ( win32k+3409e )
    
    Followup: MachineOwner
    For now, here is the prescription to attempt alleviation of all errors.

    1) Uninstall ESET NOD32 in the normal method and then use the special utility found here to ensure its complete removal from the system:

    AV Uninstallers - Windows 7 Forums

    2) Install MSE. It is lightweight with a very small footprint, free and great because it is actually in Microsoft's best interest to rid the net the best they can of Malware. Other companies do not have this incentive. For this and many other reasons, MSE is a great antivirus solution and also, it simply never ever causes bsod. Very reliable unlike all other a/v.

    3) Open an elevated command prompt. Copy and paste the following comand then hit enter to detect and resolve any file system structural damage.

    Code:
    chkdsk /r
    If you have more than one hard drive or partition, run the command for them too like this, changing the drive letter to match...

    chkdsk /r D:
    chkdsk /r E:

    4) Have you copied the Zyxel driver over the existing one at C:\Windows\System32\drivers yet? It seems to be the 2008 version still, in the crash dumps.

    Good luck with this. It should all prove helpful. Let us know how it went and as always, please post a new crash dump if needed after.
     
  11. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Just another post to clarify a little.

    1) From one of the crash dumps, we can easily see that the tcp/ip network stack has been involved:

    Code:
    [B][COLOR=Red]tcpip[/COLOR][/B]!WfpAleCaptureImageFileName+0x3a
    fffff880`06b1adf0 fffff880`0164c39e : fffffa80`0357f350 00000000`00000000 00000000`00000000 00000000`00000000 :[B][COLOR=Red] tcpip[/COLOR][/B]!WfpCreateProcessNotifyRoutine+0x63
    fffff880`06b1aed0 fffff800`03197d13 : fffffa80`0357f350 fffff880`06b1bca0 fffffa80`0357f350 00000000`00000002 : [B][COLOR=Red]tcpip[/COLOR][/B]!CreateProcessNotifyRoutineEx+0xe
    That's why it's imperative to make sure the new .sys is placed in C:\Windows\System32\drivers

    for the Zyxel adapter. The old 2008 driver is simply always going to cause problems.

    2) I realize you said you removed ESET, but definitely use the tool I linked to, to completely remove it. This ESET driver is still on the machine:

    Code:
     eamonm   eamonm.sys   Mon Mar 29 11:03:23 2010
    You can also check after and delete the file yourself then reboot, from C:\Windows\System32\drivers
     
  12. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    I installed it again yesterday but i didnt have any problems that time. I guess i wont be installing it again.
    Also i uninstalled it after the first bsod today, i run the uninstaller you link now but it said it didnt find anything so we are fine.
    As for the zyxel driver i am saying that the file provided from zyxel says 2008.
    ftp://ftp2.zyxel.com/G-202/driver/G-202_5.20.zip if you download it and go to driver/vista/WlanGZGV64.inf and open it with notepad you ll see it says 2008.

    I have 2 hard drives, one sata samsung spinpoint f3 1TB partition in 150gb (C), 731gb (E) and one wd 320gb ide (D). I removed the second one now and i dont have any errors. Though it seems strange to me that the it's hdd's fault since i bought it like 5 months ago and hdd sentinel said it was 100% healthy :/
     
  13. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Attached to my post is the new proper .sys from the Zyxel driver package. All you need to do is extract it, then right click on the .sys and choose copy.

    Then navigate to C:\Windows\System32\drivers

    and right click in empty space and choose paste. It will ask if you want to overwrite or replace the original and you should tell it yes.

    Then reboot and the new driver with 3/26/2010 will be in use.
     

    Attached Files:

  14. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    i am doing a chkdsk on E: and when i reboot it will do one on C: , i will do what you say with the drivers after that.
    Just take a look thought at this pic, on the left is the driver directory and on the right are the properties of those two wlan files and from the wlangzgv64 you provided (which also says version 2.2.0.27)
     

    Attached Files:

  15. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    For some reason, the driver name isn't being shown correct in the folder and there are actually two versions of it.

    Power off the machine and then remove the usb adapter. Power on to Windows then go to C:\Windows\System32\drivers and delete
    WlanGZ64.sys and WlanGZG.sys

    After, plug in the usb adapter then install from the Vista extracted folder using the device manager as per this previous post:

    http://windows7forums.com/windows-7-support/44239-windows-7-x64-fresh-build-random-bsod.html#post156138

    When it's done, you should only have WlanGZGV64.sys in the driver folder. I see what you mean about the .inf date but that's fine. It's that we need to get the proper file name and version in the driver folder like as above shows to do.

    Good luck heh heh :)
     
  16. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    Power off the machine and then remove the usb adapter --- done
    Power on to Windows then go to C:\Windows\System32\drivers and delete
    WlanGZ64.sys and WlanGZG.sys --- done
    Extract the Vista folder from the driver download to a folder on the pc. --- done
    Open device manager. Expand the network section and then right click on the Zyxel one. Choose update driver software. Browse my computer. Let me pick. Have disk. Browse. Then find and double click on WlanGZGV64.inf in the folder you extracted.

    Hit ok then hit next and it will install. --- done

    i did exactly what you said, and the driver that is in the driver's folder after these steps is WlanGZG.sys which is a bit weird if you take in mind that this .sys file wasnt in the vista folder and if i do a search it only exists in the system32/drivers/ folder.

    On another subject i have the ide hdd connected to the mobo as a slave while using the same cable i have my dvd-recorder (ide) connected as a master. Do you think that this may cause problems?

    also no bsod since removing the hdd but i cant be sure its fixed cause that's what i thougt yesterday!
     

    Attached Files:

    • wl.PNG
      wl.PNG
      File size:
      126.3 KB
      Views:
      279
    #16 Ton, Jun 20, 2010
    Last edited: Jun 20, 2010
  17. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    I think there is just some renaming going on with the .sys file while it is being installed. It's probably alright now which is cool.

    About the IDE situation. You'll want to make the hard drive the master and the dvd recorder the slave because the hard drive is the faster device. How it is now, the dvd recorder is setting the speed for the cable and is inhibiting the hard drive speed.

    It's actually very much better if you have two IDE slots, to put each on its own connection. But if you only have one, then just make sure you're using an 80 pin cable as opposed to 40.

    Glad to hear of no bsod though. Keeping fingers crossed.
     
    #17 TorrentG, Jun 20, 2010
    Last edited: Jun 20, 2010
  18. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    I havent connected the ide drive yet as i wanted to see if any other bsod occurs. Good news is that i didnt have any. Bad news is that i have other errors, some programs crash out of the blue , firefox mainly, and another problem is that every rar i download is corrupted :/ I tried different links and different ways of downloading (through FF, throught FDM ) the only one that worked partially was torrent, but in the beginning even though it said that the file was 100% i tried exctracting it and again it was corrupted, so i did force hash recheck in utorrent and from 100% it went to 96%. i redownloaded it, installed an sfv checker and after reboot the one i downloaded using bittorent was fine,but i downloaded other rars again with FDM/utorrent and the problem still exists..

    i am seriously considering of reinstalling windows 7 and maybe the 32bit version.
     
  19. Ton

    Ton New Member

    Joined:
    Jun 19, 2010
    Messages:
    26
    Likes Received:
    0
    Is it possible that the change in bank cycle time is causing the problem with the corrupt rar's?
    Btw i just had a new bsod :(
     

    Attached Files:

  20. pcs3657

    pcs3657 New Member

    Joined:
    May 6, 2010
    Messages:
    210
    Likes Received:
    13
    try system restore to the first possible date available this will help
     

Share This Page

Loading...