Windows 7 x64 Ultimate using only one core of T5600 core 2 duo

#1
Hi!

So the issue I'm having is that I recently installed Windows 7 Ultimate (from XP Ultimate) and the computer was working really slowly.

First I opened task manager and found only one CPU was being monitored, there was only one window for one CPU, not two windows with only one firing!

This I found strange, checked the WEI and my processor got a 2.3 rating (its a Core 2 Duo @ 1,83Mhz, a T5600), I then downloaded a tone of widgets to check if they could "see" the other core, nothing. I went into msconfig, the no. of processors box is unchecked, if I check it, the drop down menu only gives me the option of picking 1 CPU.

I found a guy with the same problem using Vista, but I can't seem to be able to use his fix: http://forums.techarena.in/vista-hardware-devices/1010605.htm (bottom of page, can't find the HAL detection checkbox)

I am running Windows 7 Ultimate on an HP nx9420 laptop with 3GB of RAM, a new HDD (250GB), the old one just stopped working really, and the Core 2 Duo T5600 @ 1,83Mhz that is running only one core.

Help is much appreciated, because I've been at this problem for a week, the computer is DEAD slow and I can't find anything online.

THANX!
 


#2
Hi.

Enable Hyperthreading (HT) in the bios.
 


#4
Wow!

Now thats a quick reply!!

Thank you for your input kemical, but I already have Windows 7 installed, just not working properly.

Ok, I tried enabling HT in BIOS like explained here: I need to find out how to enable hyperthreading in Window 7 Pro I have already checked the BIOS and it is still set right. Installation is on a P4 HT processor.
with no luck!
At least in DEVICE MANAGER it shows I have two processor cores, the only progarm in Windows so far that recognises it!!

Perhaps I did it wrong...so how do you enable HT in BIOS?
Need further assistance!
 


Last edited:
#5
If device manager is now showing 2 cores, the bios is now set well.

Perhaps it is the setting in msconfig under the boot tab/advanced that needs to be restored to original (check off), saved and reboot.

Other than that, check the task manager at top of the Performance tab. View | CPU History

Set it to be "One Graph Per CPU".

You're welcome.
 


#6
I don't believe it, it actually worked.
I'd done this (msconfig) before, with no change, thats why the surprise!!

Maybe now that the processors have been reinstalled and the msconfig settings have been confirmed again, that did the job.

ETERNALLY GRATEFUL!!!
 


Last edited:
#7
Oh cr@p!!

I spoke too soon! I put the computer to sleep and what happened was it went back to using and acknowledging only one core!!!

Any ideas on how I could prevent this from happening. I'm trying to recreate what I did earlier...with no success, mind you!
So was that before a fluke? I don't get it anymore!

Need help, again!
 


#8
Just making sure y'all didn't forget about this thread...first responses came super quick, just posting one extra to make sure xD
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#9
Jacko did you upgrade from xp or do a clean install with 7?
 


#10
Hi kemical!

Not an upgrade, a clean install, with format (but supposedly the "format" the win7 DVD does is basically an erase, not a proper format. But I somehow doubt thats the core of the problem.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#11
Correct but if you had upgraded then that was a possible cause.. What about the bios? Is it the latest version?
 


#12
I'm not sure if this has a baring on the situation at hand but from looking at your original post you say you have Windows 7 X64 Ultimate with only 3 gig or ram. Windows 7 of the 64 bit flavor needs at least 4 gigs of ram for stability.
I would add the extra ram and then reinstall your copy of Windows 7, doing a clean install again.
 


Last edited:
#13
Does the device manager still show two cores or only one now?
 


#14
I am not sure which version of BIOS I'm using, because I still can't get into BIOS (I've tried all the F's and esc, but I only get in the boot order or a choice to the system I want to use, which is only win 7 anyway) have never updated it to my knowledge.

I didn't know about the RAM, but can that seriously effect picking up, or not acknowledging a second core. Stability, ok, but using only one core? If nothing else goes, I'll try it.

TorrentG, the device manager still shows both cores, it does all the time.
 


#15
Shutdown the computer in the normal way using the start menu. Once the machine is off, pull the plug out of the wall and wait for at least 15 seconds.

Plug it back in and boot to Windows. See how that goes for ya.
 


#16
Its a laptop, so I guess you want me to pull the battery out as well. Will do.

Out of curiousity, system information gives me only one core...device manager still two.

Oh, and I did a check using the resource and performance monitor and the BIOS came back "Win32_SystemBIOS.GroupComponent" ... so it might actually be the BIOS being out of date and 32bit?
 


Last edited:
#17
I did it twice to be sure! And no luck!

Is the BIOS also bit-based? So I would need 64bit BIOS instead of 32?
 


#18
Nope. Bios has nothing to do at all with architecture. It doesn't matter at all if you're running 64 or 32 bit OS.

Visit the manufacturer's site for your model. If they have a new bios update, install the latest one per their instructions.

If there are none newer, go into your bios and set it to use the optimized default values.
 


#19
Wow, I checked and my old BIOS is from 2006!?!
They have a 2008 update, I'll throw that in, see what happens.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#20
Sounds like it could the problem.. Let's hope so.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.