Windows 7/ Xbox 360 Streaming

Discussion in 'Windows 7 Networking' started by Holmes108, Aug 5, 2009.

  1. Holmes108

    Holmes108 New Member

    Joined:
    Jan 14, 2009
    Messages:
    8
    Likes Received:
    0
    Okay, I've done a lot of searching and can find almost no info regarding this... hopefully someone may have an idea.

    My Windows 7 machine has streamed music to my 360 flawlessly through the Xbox dashboard since day one...

    Now, out of the blue, my xbox constantly loses connectivity with my PC. It still sees my PC, but when I click it to brose music... it just says "connecting...." etc until an error appears.

    It took much trial and error, but I believe I see the issue. It appears my "Turn on Media Streaming" function keeps resetting to "off"... I'll switch it to "on"... go back, and my Xbox will see the music and start playing it... by the time I'm halfway through a song, it just stops playing and won't connect to my PC again.

    Sure enough, when I go back to my sharing center, it says Media Streaming is turned off... Media Center works fine, but I cannot get this to stop happening when using my 360 dashboard. It has worked for months flawlessly. I'm not aware of any software or updates I've installed recently that could have affected my PC in this manner.

    Any suggestions would be greatly appreciated.

    Thanks.

    Andy.
     
  2. RogerG

    RogerG New Member

    Joined:
    Jul 4, 2009
    Messages:
    48
    Likes Received:
    0
    Have you considered your router as maybe being responsible?
    What router do you have?

    Try unplugging it, and plugging it back in after 30 seconds or so, and see if it helps.
     
  3. Holmes108

    Holmes108 New Member

    Joined:
    Jan 14, 2009
    Messages:
    8
    Likes Received:
    0
    D-Link DI-604... it's always worked well, all the way back to the original Xbox system. I had tried that at one point early on in my troubleshooting, but that was a couple weeks ago already. I'll give it another shot and take a look at some settings in there though.

    It's really strange. I can't help but think that a fresh windows install might fix the issue, but I'm not ready to do that yet. I did a reformat recently and don't want to have to reinstall everything again on a whim.... plus, if there was some update/software that caused the problem, it's likely to happen again until I know the culprit.

    Thanks for the suggestion though.

    Edit: Also, I don't know how relevant this is, but when I click on "change advanced sharing options" in the network/sharing center, is says "Media Streaming is On"....

    But when I click on the option "choose media streaming options" it brings me to the screen that says "Media Streaming is not turned on. Media streaming allows you to.... (blah blah).... Turn on Media Streaming?"

    Sometimes when I go back into advanced sharing, it says right on the main page that streaming is on, other times that it's off... but either way, when I go into the next screen to change it, it says it's off. (like the first screen just doesn't always update/refresh.) Setting it back to on always works, for about 2 minutes of a song.

    The whole thing is strange. Perhaps a registry setting that won't stick?
     
    #3 Holmes108, Aug 6, 2009
    Last edited: Aug 6, 2009
  4. Holmes108

    Holmes108 New Member

    Joined:
    Jan 14, 2009
    Messages:
    8
    Likes Received:
    0
    Just also realized... I go to "turn on media streaming".... wait... and within 1-2 minutes, it resets, as I mentioned earlier. When I go into my Services... Media Player Network Sharing service has stopped.

    It allows me to start it again, and I set it to automatic start (instead of delayed start), but when the 1-2 minutes pass, and the streaming setting resets, the service stops again as well.

    Don't know if this helps at all, but it does give me something else to google.....
     
  5. textureDnB

    textureDnB New Member

    Joined:
    Jun 29, 2009
    Messages:
    652
    Likes Received:
    6
    What are your A-V anti spyware programs ? I could see something like Spybots tea timer causing this type of behavior. I know it's a stretch but you could try to re boot immediately after correcting the settings maybe that will force it to stick. What build are you using if this is a daily build or the supposed 7600 RTM anything is possible and maybe not repairable.
     
  6. fraz

    fraz New Member

    Joined:
    Feb 15, 2011
    Messages:
    2
    Likes Received:
    0
    I had this exact problem as well but I found out how to fix it on my pc so here's my solution. Hope it works for everyone else.
    My initial problem was that my xbox couldn't stream content from my Win7 pc. Windows media center streaming worked however so I knew it was something wrong with Windows Media Player. After lots of searching I found out that if I created a new User the streaming worked fine. I used process of elimination to determine there is a set of files that need to be deleted in order to fix the problem. Here's what to do:

    1) open services.msc and Disable "Windows Media Player Network Sharing Service"
    2) Go to the following hidden folder:
    C:\Users\<user>\AppData\Local\Microsoft\Media Player (where <user> is the the account you're logged in as)
    3) Delete all the contents of this folder
    4) Open Windows Media Player 12 and head to Stream -> Turn on Media Streaming
    It should work now.
    So in short my problem had something to do with some application files that existed within Media Player itself. Hope this fix works for others too.
     

Share This Page

Loading...