Windows Back Up not working

Discussion in 'Windows 7 Help and Support' started by Big Dog, Sep 26, 2009.

  1. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    Hi all Windows 7 users,

    I am new to this forum but I have already leaned quite a bit by reading most of these threads...WOW this is great and I am glad I have found this place. I am having one issue that I have not been able to solve and I was hoping somebody here has the answer. I just loaded Windows 7 RTM 64 bit on my new Dell computer using the i7 chip and everything seems to work great except the windows back up feature. When I try to set up a back up I keep getting this message:

    "The backup application could not start due to an internal error;
    The specified service does not exist as an installed service.
    0x80070424"

    I previously was using Windows 7 32 bit and the back up feature worked perfectly. I don't know what I did wrong or if I did anything wrong during the installation process. Can I re-insert the installation disc again and fix it that way? What do I need to do to fix this issue.

    Thanks in advance for your help.
    Greg
     
  2. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    From where are you accessing the backup feature?

    Try his first:.
    Open services (Click Start and type in Services.msc) and scroll down to see if there is a " Windows Backup " service currently. If the Service is present, You can try this before trying to repair (which I do not think will be succesful!)

    Backup your whole registry before you try this

    1) Click Start and type in Regedit
    2) Click on HKEY_LOCAL_MACHINE
    3) Click on SYSTEM and look for folders (i.e. keys) named ControlSet....there is more than one.
    4) Look in each of the ControlSet - Services folders for the "wbengine" folder. You may be missing "wbengine" in one or all of the folders but should have at least one folder with wbengine in there. You must get "wbengine" in ALL of the ControlSet folders including CurrentControlSet. You cannot copy and paste keys in regedit

    .................................
    5) Once you find a wbengine folder...right-click on the folder and click EXPORT.
    6) Save the export file as wbenginefix.reg to your desktop, or somewhere convenient.
    7) Go to your desktop and right-click on the file and click EDIT. The file will open in Notepad.
    8) Look at the key location directly below "Windows Registry Editor Version 5.00"
    It should say:
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\wbengine]

    9) In Notepad, adjust the key location name to match the ControlSet folders with the missing wbengine folder (i.e. ControlSet, ControlSet001, ControlSet002, etc).
    10) Click Save As and name the file wbengine1.reg (or anything you want). Remember to type .reg at the end or else it will save as a .txt file.
    11) Double Click on the wbengine1.reg file you just created and click OK to continue. You should get a message that the registry was successfully updated.
    12) Repeat step 7-11 for EACH ControlSet folder you have.
    13) After all ControlSet folders are updated open Regedit and confirm the wbengine is in ALL of the ControlSet folders.
    14) Restart, or logoff and on, and see if you have been succesful.
     
  3. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    Hi Rak,

    Thanks for the response. I tried what you suggested and I looked in all the system folders (HKEY_LOCAL_MACHINE) and I even did a search for "wbengine" in the entire registry and found nothing. I suppose that's what I am missing. How do I locate & install this "wbengine" into these folders?

    I tried your first suggestion and I did find the Windows Back Up service running already when I entered services.msg. It says it was started but I still can't run windows back up.

    Any suggestions?

    Thanks again
     
  4. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    See if this will do the trick. I have attached my file as a .doc as we are not able to upload .reg files. Just rename the ext from .doc to .reg. Follow the method above with it.
     
    #4 RAK, Sep 27, 2009
    Last edited: Oct 5, 2009
  5. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    Hi Rak,

    Thanks for the suggestion and I did as exactly as you stated and I was not able to get the registry updated.
    I took your file you sent me and saved 3 of them with each one with a different name ControlSet001, ControlSet002 and CurrentControlSet. The all ended in reg and each time I double clicked on them they just opened up in notepad again. They did not say anything about updating the registry. Maybe I did something wrong but I followed your instructions to a T. By the way there are only 3 ControlSet folders under HKEY_LOCAL_MACHINE/SYSTEM. Anyhow how do I update the registry if ever time I click on these files all they do is open up in notepad. They all have the .reg at the end. HELP.....

    I hope this will work because I really want to use the windows back up feature.

    Thanks alot for your help.
    Greg
     
  6. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    You have lost the .reg associate for some reason. We'll start again.
    Now I have uploaded a .zip file.
    Unzio this to a convenient location.
    1. Run "regfix_Vista..etc Here we may have to stop. If your associate has been altered, you may have to do some manual work here. So.
    Right click the above file.
    >Click "Open with", or "Open"
    >Select "Choose default program" and browse to Windows - regedit.exe and select that as the default.

    Now try 1. again.

    It should now work
    2. Now try wbengine.reg again. It should now acknowledge a success.
    3. For your convenience, you may also have the wbengine.exe missing from your Windows System32 folder. So I have included it for you to paste and copy.
     
    #6 RAK, Sep 28, 2009
    Last edited: Oct 5, 2009
  7. JessicaD

    JessicaD New Member

    Joined:
    May 11, 2009
    Messages:
    396
    Likes Received:
    13
    Big Dog,
    Microsoft does have an official Windows 7 Support Forum located here Windows 7 Category . It is supported by product specialists as well as engineers and support teams. You may want to check the threads available there for addtional assistance and feedback.
    Jessica
    Microsoft Windows Client Team
     
  8. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    Thanks Jessica for the tip. I will check that thread out.

    Rak,

    Thanks for the file and I am going to try your step by step instructions again... wish me luck :)

    There's no chance of me screwing things up with the registry is there?
     
  9. Tepid

    Tepid New Member

    Joined:
    Jun 11, 2009
    Messages:
    1,344
    Likes Received:
    38
    Oh yes,, any time you mess with the registry you take a chance on screwing things up.
    That's why Rak instructed you to back up the registry first before attempting this.
     
  10. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    Thanks Tepid and I did a complete back up the registry. Can I also (if things got messed up) just do a restore to a previous point. Isn't that the same thing as restoring the registry.
     
  11. Tepid

    Tepid New Member

    Joined:
    Jun 11, 2009
    Messages:
    1,344
    Likes Received:
    38
    Not always. If the registry gets plenty screwed,, you may not be able to boot at all.
    However, you can try using the 7 disk to repair or restore the system.
    But this is getting off topic and could confuse the issue. One problem at a time.
     
  12. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    It Works...YEAH!!!

    You be the man Rak!!!

    I did exactly as you suggested and now my back up feature is working perfectly! In fact it's running as I type this. :)

    Thanks for all your help and I hope I can return the favor one day...

    This forum is awesome!!!
     
  13. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    No need for "returning" favours M8. We all try to help each other here.

    Fwiw. An opportunit here to comment on another post without drifting. JessicaD,'s seems to flip around quite a few forums with precisely the same advice. Anyoneone who has been following tis thread is welcome to have an examination of that advice! Fwiw, I cannot find any trace of her/Him on the Microsoft sites, but maybe, like me, another "Pseudo"?

    I am very active member, (with another "Pseudo") both on Microsoft sites generally and on the link she published. It has value, if you can work through it. But it is overused and difficult to navigate. Threads can often run into days and pages before a sensible answer pops up and often (like this one, now -lol) drift off thread.

    Forums such as windows7 are more user friendly and, whilst interesting, and sometimes boring, conversations can evolve, the solution. is nearly always forthcoming. This does not preclude any helpers from linking to a genuine solution in another site, instead of merely referring to the huge site in such a general manner as does JessicaD
     
  14. Tepid

    Tepid New Member

    Joined:
    Jun 11, 2009
    Messages:
    1,344
    Likes Received:
    38
    That was going to my comment,, but you put it a bit more eloquently than I would have. So, I decided to not comment on it.
     
  15. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    Windows back up quits after about 40%...

    Hi Rak,

    I need your help again with the windows back up feature. As you know the fix you gave me before worked and I was able to do a back up using the Win 7 interface. Now I am just trying to initiate another back up and now I am getting this message:

    The back up application could not start due to an internal error:
    The specified service does not exist as a installed service.
    0x80070424

    The back up starts and gets about 40% done and then it fails and gives me the above message.

    Did I do something wrong all I did was launch the back up and restore program and click back up now.

    Any suggestions???

    Thanks
     
  16. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    Hi Rak,

    I just checked to see if my webengine.reg are still in the registry and all of them are gone. WTF...How did that happen? I did not delete them. Something must be deleting them. I am going to do what you recommended the first time and see if that works it probably will but why did they disappear in the first place.
     
  17. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    Back Up problems still exist

    I am still having problems with my Windows Back. Rak gave me a solution last week and my back up worked the first time but I keep losing the "wbengine" folder from the registry folders (ControlSet001, CrontrolSet002 and CurrentControlSet) after every time I start or change settings in my windows back up. It work's fine the first time and then they disappear when I am done. I can add them back doing what Rak suggested and I have done it and confirmed they are there but as soon as I start windows back up and run it after it's done all the wbengine folders are gone or the back up fails halfway thru completion. Anybody have any suggestions as to why the folders keep disappearing? Rak I would like to know if you have any suggestions for me.

    Thanks for your help.
     
  18. tblount

    tblount New Member

    Joined:
    Sep 27, 2009
    Messages:
    3,537
    Likes Received:
    64
    This is apparently such a common problem (apparently with a screwup in the registry) that a utility has been written to fix it... UNFORTUNATELY the utility ONLY runs on 32 bit OS. Here is a link
    How to Fix 0x80070424

    Do you have a registry backup you can restore?
     
  19. Big Dog

    Big Dog New Member

    Joined:
    Sep 26, 2009
    Messages:
    36
    Likes Received:
    0
    tblount, Yes I have backed up the registry and everything else seems to be working fine. It's only when I try and run Windows Back Up. It will work if the wbengine folders are present but as soon as I run the back up once and if it succeeds I then go and look to see if the wbengine folders are still there and there gone. I can restore them with the method Rak gave me but I am sure they are not supposed to vanish each time I run Windows Back Up.

    I read about your suggestion for a fix but it's for only the 32 bit version besides I have seen these programs similar to this one and I think all they want is your $29.95 or whatever it is and it's just a bunch of smoke and mirrors. I have purchased and downloaded programs such as these and of course they all will find problems with your computer just so you purchase them and when you run the utility at still comes back with the same problem. Of course this is just my opinion. Sorry to ramble....

    Anyhow back to my issue... is there something else I could do to fix this.
     
  20. tblount

    tblount New Member

    Joined:
    Sep 27, 2009
    Messages:
    3,537
    Likes Received:
    64
    I maybe wasn't clear... did you RESTORE an earlier backed up registry... from before the problem showe up.


    Thre is a lot more you can do:

    You can google and read and try to find a fix.

    You can reinstall windows.

    But here is what I suggest (when you get it fixed)... get another drive and clone to it because there are too many problems/shortfalls with the Windows System Image backup. I have a blog about this:
    http://windows7forums.com/blogs/tblount/71-backup.html
     

Share This Page

Loading...