Windows cannot access the specified device...

#1
I searched the forums for an answer but couldnt find any so here it goes.

I downloaded an application and extracted no problem. Then I try to run the Launcher.exe and I get this error:

"Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item."

I checked my permissions and nothing is blocked, I've ran it as an Administrator, and I've done the compatibility check but nothing works.

Is there anything else I can do to get rid of this error message?
 


#2
does anyone know how to fix this??
 


#3
When you say that you ran as an Admin does that mean that you unlocked the hidden administrator account, logged in and tried it from there? If you haven't open a command prompt by r-clicking on it and select run as admin. Then type the following to unlock the admin account:
net user administrator /active:yes
Log off and log in under the unlocked account and try it then.
 


#4
firefox and carbonite along with other programs give me this same problem. I do right click and run as an administrator and when attempting to run the program afterwards still get the error message - "windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item" I am running win 7 ultimate N x64... this is very frustrating and have been trying permissions, ownership and have trouble getting it to run...
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.