Windows cannot find D:\setup.exe when trying to install a program from a disc

Discussion in 'Windows 7 Software' started by colfmedion, Nov 16, 2011.

  1. colfmedion

    colfmedion Honorable Member

    Joined:
    Jan 31, 2009
    Messages:
    44
    Likes Received:
    0
    Hi,
    Not sure if I am in correct forum cos' I'm not too sure what is causing my problem. About 2 weeks ago I began having issues with burning files to disc, i.e. drag and drop to a RAM disc. Previously no problems. I also noticed later that my 2 optical drives were being shown as SCSI drives instead of ATA. As far as I am aware this should not cause any problems. I had also been having trouble with FSX in that everytime I made a change whilst in FSX (changing an airport after landing) all I would get was a black screen. I could get into my desktop using the keyboard but not into FSX. I decided to reinstall FSX but when I ran the disc I got the message "Windows cannot find D:\setup.exe", and that was as far as I could get. I checked various programs, some on CD and some on DVD and sometimes I got the message and sometimes a program would begin to install as normal. I could not identify any discernable pattern. I spent all afternoon completely rebuilding my PC (it took me 2 hours to get the CPU to sit correctly on the MOBO. Aren't those pegs usless.) The end result being the same as when I started. I am suspecting an error in Windows 7 but that's all I've got. Any help or advice would be much appreciated.
    Tks
    colf
     
  2. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,042
    Likes Received:
    300
    Hi

    What do you see when you look at your DVD drive in Windows Explorer with the flight sim. disk in the drive?

    Can you find the setup.exe file there?

    If you can what happens if you start the install from there?

    Could this be a problem with the DVD drive itself?

    Do you run the game from the DVD drive or can it be removed after the install?
    What I mean here could reading the drive cause problems running the game.

    You could run SFC /scannow and see if you find any errors.

    From the elevated Prompt Right click on the Prompt Icon and select run as administrator. Then type…

    SFC /scannow Scans and restores system files.

    I'd also try uninstalling the DVD drive in device manager and then rebooting so windows re-detects it.
    And update the drivers for the device.

    Mike
     
  3. colfmedion

    colfmedion Honorable Member

    Joined:
    Jan 31, 2009
    Messages:
    44
    Likes Received:
    0
    Hi Mike,
    Thanks for response.
    The DVD fsx shows in Windows explorer in the Devices with removable storage and if I try to run it from there I get the same message. I have tried 3 different drives with the same result. I run FSX from the HDD.
    I think I have a problem in my OS. Everything I have done over the past couple of weeks points to this. I thought initially I had a problem with a disc drive but this is not the case. I have decided that I need a fresh install of Windows 7 and FSX so that I can get rid of a lot of rubbish. Used to do it regularly in XP but this will be my first time in 7. Clearly a much more forgiving OS because I have little doubt that most of the problems I encounter is down to something I have done.
    The one thing I have not done so far is the SFC/scannow. I will do that and see what happens. Incidentally, have several Drive Images of both 7 OS and FSX and have recovered using them with no problems and quite recently but now I cannot even recover the Drive Images. I will post when I get some more info.
    Thanks
    colfmedion
     

Share This Page

Loading...