Windows could not configure one or more system components

#1
I'm trying to do a clean install of Windows 7 build 7000 32-bit (downloaded from microsoft.com) on a 30 GB partition. During the "Completing installation..." phase, I get a pop-up with this message:

Windows could not configure one or more system components. To install Windows, restart the computer and then restart the installation.
I looked in the logs, here are the last lines of X:\Windows\Panther\setuperr.log:

[gle=0x80004005]
2009-01-11 20:12:43, Error CSI [email protected]/1/12:04:12:43.250 (F) CMIADAPTER: AI failed. HRESULT = c002001b [Error,Facility=(0002),Code=27 (0x001b)]
Element:
[208]"<sppInstaller xmlns="urn:schemas-microsoft-com:spp:installer" xmlns:manv3="urn:schemas-microsoft-com:asm.v3" xmlns:spp="urn:schemas-microsoft-com:spp:installer" xmlns:wcs="urn:schemas-microsoft-com:wcs.v1" />"
[gle=0x80004005]
2009-01-11 20:12:43, Error CSI [email protected]/1/12:04:12:43.250 (F) d:\win7beta\base\wcp\cmiadapter\installers.cpp(348): Error c002001b [Error,Facility=(0002),Code=27 (0x001b)] originated in function Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller::ResolveAndInvokeInstaller expression: hr
[gle=0x80004005]
2009-01-11 20:12:43, Error CSI [email protected]/1/12:04:12:43.343 (F) CMIADAPTER: Exiting with HRESULT code = c002001b [Error,Facility=(0002),Code=27 (0x001b)].
[gle=0x80004005]
2009-01-11 20:12:43, Error CSI [email protected]/1/12:04:12:43.343 (F) d:\win7beta\base\wcp\cmiadapter\installers.cpp(123): Error c002001b [Error,Facility=(0002),Code=27 (0x001b)] originated in function Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller::Install expression: hr
[gle=0x80004005]
2009-01-11 20:12:43, Error [0x018001] CSI 0000019c (F) Failed execution of queue item Installer: SppInstaller ({1b265fd2-721c-4e59-ad55-9d102a5d1d7f}) with HRESULT c002001b [Error,Facility=(0002),Code=27 (0x001b)]. Failure will not be ignored: A rollback will be initiated after all the operations in the installer queue are completed; installer is reliable (2)[gle=0x80004005]
2009-01-11 20:13:38, Error CSI [email protected]/1/12:04:13:38.578 (F) d:\win7beta\base\wcp\componentstore\com\advancedinstallerstore.cpp(489): Error HRESULT_FROM_WIN32(ERROR_ADVANCED_INSTALLER_FAILED) originated in function Windows::COM::CComponentStore::IAdvancedInstallerAwareStore_ResolvePendingTransactions expression: HRESULT_FROM_WIN32(14099L)
[gle=0x80004005]
2009-01-11 20:13:39, Error CSI 000002c5 (F) HRESULT_FROM_WIN32(ERROR_ADVANCED_INSTALLER_FAILED) #118# from Windows::COM::CComponentStore_IAdvancedInstallerAwareStore::ResolvePendingTransactions(dwFlags = (DontFailIfPrimitivesPending|IndicatePrimitiveRollback), Progress = NULL, Phase = 0, Disposition = (unknown enumerant 0)[3]" | "0)[gle=0x80073713]
2009-01-11 20:13:39, Error CBS Startup: Failed to process advanced operation queue, startupPhase: 0. [HRESULT = 0x80073713 - ERROR_ADVANCED_INSTALLER_FAILED]
2009-01-11 20:13:39, Error [0x030149] CMI Callback_CBS_Do_OnlineInstall:Calling startup processing failed 0x80073713
2009-01-11 20:13:39, Error [0x030153] CMI Callback_CMI_ConfigInstall: CBS startup processing re-run failed.
Any idea?
 


#2
I tried again, doing the update at the beggining of the install (through Windows XP) and making sure it could connect to the internet during the installation (I could see the light blinking on my router during installation, so it was connecting online). I also tried disconnecting as many devices I could. I'm still getting the same error. Here are the logs in X:\Windows\Panther\:

X:\Windows\Panther\setupact.log
X:\Windows\Panther\setuperr.log
X:\Windows\Panther\cbs.log
X:\Windows\Panther\DDACLSys.log
X:\Windows\Panther\UnattendGC\setupact.log
X:\Windows\Panther\UnattendGC\setuperr.log

I also know it's not a problem with the ISO, I redownloaded it and mounted it with DAEMON Tools Lite in Windows XP (no need to burn the ISO using this method).
 


#3
I have the same problem with this build, and noone can tell what is the problem... Maybe it something about hardware incompatibility?
 


#4
I got the same error at the end of Windows 7 64-bit installation.

I too got the same message in the last stage of Windows 7 64-bit installation. I installed Windows 7 64-bit as dual boot with my Windows Vista (32-bit). My processor is AMD64 Athlon X2 with 1GB RAM and 30 GB free space in the hard disk partition D: . After I restarted the system, and during the start up of Windows 7, I get another error message.

The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click "OK" to restart the computer, and then restart the installation
Please suggest a solution to this problem.
 


Last edited:
#5
This is the error I get during the install:



If I restart, I get this pop-up:

 


davehc

Essential Member
Premium Supporter
#6
Pardon me. I am ignorant on this, but what is "Panther" and why the curious path to the install? That would seem to be a possible problem??
 


#7
2 Steve81: I get the same error messages!
2 davehc: No, I don't think that the path is the problem, because I install it to default directory and have the same problem.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.