Windows Explorer not automatically refreshing

Discussion in 'Windows 7 Help and Support' started by ruggb, Dec 1, 2011.

  1. ruggb

    ruggb Honorable Member

    Joined:
    Jan 14, 2009
    Messages:
    510
    Likes Received:
    4
    with any WE window open - if I change/delete anything the window does not automatically refresh. I must hit F5 to see the correct view.

    What do I need to change to fix this??

    thx
    bill
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Since your situation is a little different from what normally happens, could you expand some on your circumstance? There are certain types of windows that will have to be refreshed, but if you open Windows Explorer to a folder and add or delete a folder, it does not go away or show up immediately?

    For now all I can suggest is you check the System dialog (Winkey+Pause) and select Advanced System Settings. I leave mine on let Windows handle, but maybe there is an option that might help.
     
  3. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    I have had this same problem on my home computer for a very long time now. Very annoying. I have researched this problem many times and have not found a solution yet. I have tried to change performance plans and messed around with display drivers and settings and so far nothing helped. I am just a very busy guy but I definitely will find a solution one day.

    Although, my gut tells me it's my ATI card and not Windows. Ruggb, tell me... do you have any other display problems like flickering on your screen or playback issues in youtube videos? Do your icons go out of whack if you refresh your desktop? Anything that might have to do with the graphic card? What Graphic card do you have?
     
    #3 zvit, Dec 3, 2011
    Last edited: Dec 3, 2011
  4. ruggb

    ruggb Honorable Member

    Joined:
    Jan 14, 2009
    Messages:
    510
    Likes Received:
    4
    I went back and tried to reproduce this on demand. Though it seems like it occurs EVER time I use WE, I could not make it do it in my short test. Maybe something happens when I am using it for an extended period?? Need more research.

    RE video, I have an nVidia card and the display appears normal.
    I did have issues with high DPCs on both desktop & laptop. Since laptop was new I got HP to address it and they got nVidia to fix their driver. UNBELIEVABLE!! - Incredibly, since then (last 9 months) every update from nVidia has been good for both desktop & laptop.

    It would seem like it is a Windows fct since F5 causes the OS to update what it is doing - as in refreshing a web page - but I suppose if the video driver could somehow be ignoring the memory update but then it should at times ignore the F5 also - which it does not.

    Windows was not set to handle the UI so I reset that - but there is no fct in there that would seem to effect this issue.
     
    #4 ruggb, Dec 3, 2011
    Last edited: Dec 3, 2011
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I would have been doing some testing, but you never got back to us on exactly how to try to duplicate the problem. I would need exact steps to include what was changing and not showing up until refresh...
     
  6. ruggb

    ruggb Honorable Member

    Joined:
    Jan 14, 2009
    Messages:
    510
    Likes Received:
    4
    sorry saltgrass, i just can't seem to make it happen on demand.
    if i figure out how i will let u know.
    since it happens so often it thought it was permanent, but that is what i get for thinking.
     
  7. Truth101

    Truth101 New Member

    Joined:
    Jun 5, 2013
    Messages:
    2
    Likes Received:
    0
    Here is an incredibly simple solution that worked for me. It may work for you as well:
    - In Windows Explorer: choose Tools, Folder Options > Click the Search tab > Check or uncheck ANY option
    - Apply.
    - If this solves your problem, you can revert to your original setting and the problem will remain solved.

    Microsoft obfuscates this problem by instructing you to delete your profile, update your bios, disable your antivirus, reverting to a restore point, etc. If the incredibly simple solution above helps just one person avoid the Microsoft nonsense, it is well worth the time cross-posting this solution to a few popular sites.

    Microsoft should have identified and solved this problem four years ago. This incredibly simple solution clearly demonstrates why Microsoft Windows Explorer should not be trusted for the management of sensitive documents for law enforcement, health care, national security and other critical industries.
     

Share This Page

Loading...