Windows folder not opening in explorer by default

#1
hi,:eek:
Recently i installed adobe photoshop cs5. After installing now when i try to open any folder by double clicking on it, it opens in adobe bridge.:confused::confused::confused::frown: I have to right click on the folder and then OPEN, then only it opens in explorer.:(:(:(
I tried the Default file associations in control panel but couldnt find the folder extension.
How can i change the default settingsso that when i open any folder by double clicking on it, it will open as usual in windows explorer.

I am using windows7 ultimate, 32bit. 3gb ram, 250 hdd, amd turion x2 processor with 2ghz speed.

thank u.:eek:
 


#2
Has this behavior always been the same since you installed Adobe? Have you tried their forums?


~~~~~~~~~

There must be a setting for this in Adobe bridge, if not then set defaults in control panel>folder options. If still no luck, try re-registerring Windows Shell library by opening up the elevated command prompt and typing regsvr32 shell32.dll and then hitting 'enter'. Restart the system.

(HKEY_CLASSES_ROOT\Folder\shell\open)
 


#3
Thanks CYberCore.:)
I haven't tried adobe's forum till now. Earlier i was using photoshop cs4 and i had no problem. But now when i installed photoshop cs5 this problem came up.
i reinstalled it every time the same problem crops up.

There is a setting in preference in adobe bridge about file extension but there is no option for folders.
I have tried Folder options in control panel but no effect. I re registered the shell library by opening command propmpt and restarted the system but no effect.

I also tried registry cleaner, error fixer but no effect. :mad::mad::(:(:confused::confused:
 


Elmer

Extraordinary Member
#4
Are you happy going into the registry (search regedit.exe), if you are GoTo this registry key:-

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\Directory.
..
Expand the Directory folder (key), you should have two sub-folders (keys) One is OpenWithList, the other is OpenWithProgids, (you may have more??).

What you need to check for is a key called UserChoice. If you find one, delete it. If you don't find one, this code saved as a .reg file should restore your default folder settings.
Code:
Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\Folder]

[HKEY_CLASSES_ROOT\Folder]
"ContentViewModeLayoutPatternForBrowse"="delta"
"ContentViewModeForBrowse"="prop:~System.ItemNameDisplay;~System.LayoutPattern.PlaceHolder;~System.LayoutPattern.PlaceHolder;~System.LayoutPattern.PlaceHolder;System.DateModified"
"ContentViewModeLayoutPatternForSearch"="alpha"
"ContentViewModeForSearch"="prop:~System.ItemNameDisplay;System.DateModified;~System.ItemFolderPathDisplay"
@="Folder"
"EditFlags"=hex:d2,03,00,00
"FullDetails"="prop:System.PropGroup.Description;System.ItemNameDisplay;System.ItemTypeText;System.Size"
"NoRecentDocs"=""
"ThumbnailCutoff"=dword:00000000
"TileInfo"="prop:System.Title;System.ItemTypeText"

[HKEY_CLASSES_ROOT\Folder\DefaultIcon]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
  00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,\
  65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,33,00,00,00

[HKEY_CLASSES_ROOT\Folder\shell]

[HKEY_CLASSES_ROOT\Folder\shell\explore]
"MultiSelectModel"="Document"
"ProgrammaticAccessOnly"=""
"LaunchExplorerFlags"=dword:00000018

[HKEY_CLASSES_ROOT\Folder\shell\explore\command]
"DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

[HKEY_CLASSES_ROOT\Folder\shell\open]
"MultiSelectModel"="Document"

[HKEY_CLASSES_ROOT\Folder\shell\open\command]
"DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
  00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
  65,00,00,00

[HKEY_CLASSES_ROOT\Folder\shell\opennewprocess]
"MUIVerb"="@shell32.dll,-8518"
"MultiSelectModel"="Document"
"Extended"=""
"LaunchExplorerFlags"=dword:00000003
"ExplorerHost"="{ceff45ee-c862-41de-aee2-a022c81eda92}"

[HKEY_CLASSES_ROOT\Folder\shell\opennewprocess\command]
"DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

[HKEY_CLASSES_ROOT\Folder\shell\opennewwindow]
"MUIVerb"="@shell32.dll,-8517"
"MultiSelectModel"="Document"
"OnlyInBrowserWindow"=""
"LaunchExplorerFlags"=dword:00000001

[HKEY_CLASSES_ROOT\Folder\shell\opennewwindow\command]
"DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

[HKEY_CLASSES_ROOT\Folder\ShellEx]

[HKEY_CLASSES_ROOT\Folder\ShellEx\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\Folder\ShellEx\ContextMenuHandlers\BriefcaseMenu]
@="{85BBD920-42A0-1069-A2E4-08002B30309D}"

[HKEY_CLASSES_ROOT\Folder\ShellEx\ContextMenuHandlers\Library Location]
@="{3dad6c5d-2167-4cae-9914-f99e41c12cfa}"

[HKEY_CLASSES_ROOT\Folder\ShellEx\ContextMenuHandlers\Offline Files]
@="{474C98EE-CF3D-41f5-80E3-4AAB0AB04301}"

[HKEY_CLASSES_ROOT\Folder\ShellEx\DragDropHandlers]

[HKEY_CLASSES_ROOT\Folder\ShellEx\DragDropHandlers\{BD472F60-27FA-11cf-B8B4-444553540000}]
@=""

[HKEY_CLASSES_ROOT\Folder\ShellEx\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\Folder\ShellEx\PropertySheetHandlers\BriefcasePage]
@="{85BBD920-42A0-1069-A2E4-08002B30309D}"

[HKEY_CLASSES_ROOT\Folder\ShellEx\PropertySheetHandlers\Offline Files]
@="{7EFA68C6-086B-43e1-A2D2-55A113531240}"

[HKEY_CLASSES_ROOT\Folder\ShellNew]
"Directory"=""
"IconPath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
  74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
  00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,33,00,\
  00,00
"ItemName"="@shell32.dll,-30396"
"MenuText"="@shell32.dll,-30317"
"NonLFNFileSpec"="@shell32.dll,-30319"

[HKEY_CLASSES_ROOT\Folder\ShellNew\Config]
"AllDrives"=""
"IsFolder"=""
"NoExtension"=""
Just for luck, if you save this code as a .reg file it wll remove Adobe Bridge from your folder context menu.
Code:
Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\Directory\shell\Bridge]
Hope that helps

Elmer
 


Last edited:
#5
Thanks Elmer for your rply.
I have chekd the registry as you have said. But didn't found a reg key called User Choice in the directory folder.
You have given a code, i have saved it as a .reg file in dektop. I want to know where i will save it or how.?
 


#6
Thank u elmer....
The second code you gave really solved the problem and now all the folders are opening as usual...
Rocking...
Thank u so much,Elmer... :) :)
 


Elmer

Extraordinary Member
#7
Not a problem.

I've devoted my life to dismembering Adobe Bridge and rendering it useless!

(It never used to work on my ancient XP set up, so I found alternatives. So now it wants to work on my new PC it can go and get stuffed!!)
 


ayo1

New Member
#8
Hello, kindly help out, i have the same issue. Would have followed the steps given above, only this is 6 years after this post, I windows 10 os and adobe cs6. This is the only place i could find that has a clue.
 


Neemobeer

Windows Forum Team
Staff member
#9
The keys should be the same even in Windows 10
 


#10
Thank u elmer....
The second code you gave really solved the problem and now all the folders are opening as usual...
Rocking...
Thank u so much,Elmer... :) :)
solved it for me too, thanks!
 


#11
Guys. Pls elaborate the steps. Please. Please
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#12
They are in the Elmer post above.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top