Windows headphone plug sensing is broken

#1
My system is:

Asus G51VX-X3A Laptop
Realtek HD Audio w/ latest drivers
Windows 7 Home

A few days ago, I noticed that the speakers on my laptop were no longer working. I could plug in headphones and the headphones still worked. After searching in other forums, others suggested the headphone jack being stuck in thinking it was in headphone mode instead of switching back to speakers. So, I got a flashlight, a pin and tinkered with it but with no fix.

Last night, I cleaned out all the old drivers and reinstalled the latest Realtek drivers with nothing. I remembered the laptop has an explosion sound that plays at POST, so I re-enabled the sound in the BIOS, rebooted and it the sound played. I had it narrowed down to a software issue. Someone has just suggested a registry edit to me that I tried:

Sorry to bump this topic, my Jack port failed again, but this time i decided to find a solution that does not involves replace a whole motherboard. So, i`ve managed to manually override the sound output, here it is:

But before... Warning: I can't measure the effects of this change, as far as i know it will override ALL jack ports. I'm still trying to find the value that matches only with Line-Out port. And, for now, you need to reboot the PC to make it work. So, if you want to try this it will be at your own risk.

Ok, assuming you are using Realtek HD Audio Driver, in regedit, go to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}

in there are a enumerated sequence of sub-keys in my case, from 0000 to 0007.

Search for the one that has a subkey named "Settings". This key has a value named "ForceDisableJD" with a value set (probably) to "00", double click it and change to "FF"

Reboot your computer.

For me it worked fine.
I gave it a shot, rebooted, and voila, speakers worked in Windows. I plugged in headphones, and nothing. I wasn't expecting a magic fix, but I got closer. This is where I'm stumped. Any ideas where to go from here?
 


#2
Install the driver from ASUS' site for your model, instead.
 


#3
When I try the Asus ones, I get the error: Unable to find a compatible SRS Audio Device.

I was told to use the Realtek HD ones as they'd install fine, and they did.
 


#5
Use Driver Sweeper in safe mode to clear all Realtek:

Phyxion.net | Driver Sweeper | Products | Products

Then install the driver from ASUS' site again.

Doesn't matter what anyone else told you. This is my advice above, here.
Took a bit longer to get around to, was busy this weekend. I still got "Unable to find a compatible SRS Audio Device" and then it cancels, asking me to reboot my computer.

Still no sound from speakers.
 


#6
32 or 64 bit Windows?
 


#7
Windows 7 64-bit Home.
 


#8
First, use the Driver Sweeper to clear all Creative and Realtek audio in safe mode.

Then boot to normal mode.

Install the driver from here for Creative (model is slightly different, no problem, use this it's good):

ASUSTeK Computer Inc.
 


#9
Done, tried it. Still nothing.
 


#10
Raz I'm gonna go with a long shot here and hope you see this reply. I have a newer model than you but had the same problem with the jack pin. I used the Registry Edit you posted and it is working as intended. What I was wondering is if in the time since your last post you have discovered a value other than "FF" that will bypass but still allow you to plug in speakers? Email me anytime Chrismichaeld@hotmail.com
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.