Windows Installer cannot be accessed

Discussion in 'Windows 7 Software' started by starstorms, Oct 13, 2011.

  1. starstorms

    starstorms New Member

    Joined:
    Oct 13, 2011
    Messages:
    8
    Likes Received:
    0
    Hello,

    I have never had to resort to using a forum to solve a windows OS related problem but after several hours this has truly stumped me.

    I was messing around with the uninstall a program feature and may have gotten a little overzealous as it seemed I uninstalled the windows installer. Almost every program won't open now including MS office, 3DS Max, IE, firefox, etc. Office programs fail throwing Error 1719: The Windows Installer Service could not be accessed. Several programs simply do nothing when ran for example IE. Firefox freezes up as soon as it tries to load any tabs. Many program suggest they just aren't installed at all when I try to run them. When I try to go control panel -> programs and features and hit the uninstall a program link nothing happens.

    One main issue that I am running into is people keep suggesting cleanup utilities but I can't install anything new at all so they just fail.

    Some programs still work though! Visual Studio C# 2010 still works fine along with a couple ftp programs and Opera (which is how I was able to post this post).

    I have tried installing random things like notepad++, reinstalling Firefox, etc but they all fail with Opera throwing the error "Error when initializing the file dialog: 0xFFFF Internal program error." before the installer can even start.

    I have tried every single trick in these forums and several others I lost track of...
    http://support.microsoft.com/kb/315353
    http://en.kioskea.net/forum/affich-390-windows-installer-service-could-not-be-access

    I would like to note that reinstalling windows is essentially not an option and I don't even have the windows 7 install disc (away from my house for a couple of weeks). Also, no restore points available.

    Any help appreciated, thanks.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I would think the first thing to try is opening an administrative command prompt and typing:

    sfc /scannow

    which should replace any system files that have problems. Give it some time to work and let us know what it says.

    If it won't run, we may have found the problem.
     
    #2 Saltgrass, Oct 13, 2011
    Last edited: Oct 13, 2011
  3. starstorms

    starstorms New Member

    Joined:
    Oct 13, 2011
    Messages:
    8
    Likes Received:
    0
    Hey, I have already tried that in an elevated command prompt. It scanned for a while and then said it found errors but couldn't resolve them. It did generate a log file but it is a full 8mb of pure text which I can't make any sense of. Also, I would post it but unfortunately this stupid thing has cut off all uploading capabilities of Opera... so I can't upload the log file (i have tried uploading to several sites to test and nothing, not even email attachments work it gives the same error as trying to install something from Opera).

    However, I did have access to a friends computer where I uploaded some snippets of the log file, that was in this forum here:

    Windows Installer cannot be accessed - Windows 7 Forums
     
  4. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Hi Starstorms and Welcome to The Forum.

    I deleted your second post as, it was in fact, basically a duplicate.

    In an effort to combat a recent proliferation of spam posts, new member posts usually require 'moderating' before they appear. This occurs especially if they contain attachments and/or links to outside sites. We are all volunteers here, so moderation may be as quick as a couple of minutes up to a couple of hours.

    Moderation on your posts stops when you reach the magnificent total of five posts(?) and then they will appear instantly.

    Hope that helps.

    Elmer.
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    This Microsoft site tells how to extract the necessary info from the CBS.log. If you have run the checker several times, there will be duplicate entries, so if that is the case you might edit the resulting file for dates.

    But basically you are looking, probably near the end for something like the following and you can use Notepad to search for such entries.

     
  6. starstorms

    starstorms New Member

    Joined:
    Oct 13, 2011
    Messages:
    8
    Likes Received:
    0
    So after trying every single fix I could find online and over 20 straight infuriating hours working on this I finally had to resort to doing a repair in place install. But even that barely worked. Most of my programs then just failed with different errors but at least this time I could reinstall them. So I've had to pretty much reinstall every major program.

    My advice to anyone else having this much trouble with this issue is just to give up and do a clean install, you'll have to reinstall most programs anyways.

    @Elmer Oh sorry about that I must not have noticed the moderation warning, that's actually rather good idea to moderate the first five though.
     
  7. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Not a problem!

    You're right though. Sometimes after trying whatever you can to repair, it's far better to just bite the bullet and start from scratch again. I learnt that many years ago! I now have an "installed programs" folder so I don't have to search/remember what was on the PC. My biggest installs being Photoshop and possibly an Office trial. That along with a couple or few compiled batch scripts and maybe a couple of dozen registry entries and I can have my Windows 7 back to its normal position (for me) within a couple of hours.

    A weekly backup regime is even quicker than the above though if you can pin point where it all went "Pete Tong". I use the Macrium Reflect free version for my weekly backups.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    If your system is having a problem with corrupted system files, something else may be going on. Perhaps is was being caused by somethig you picked up on the system or some other hardware situation. Keep an eye on it and you may want to make an image when you get it where you want it.
     
  9. starstorms

    starstorms New Member

    Joined:
    Oct 13, 2011
    Messages:
    8
    Likes Received:
    0
    @Elmer Ya I would have resorted to that much quicker if I had actually had my disks but unfortunately this caught me at a bad time away from home :( I also have a similar setup, just two drives in my laptop, a big hdd with every program and important file and then a small ssd with just windows on it that can be wiped really quick without having to worry about everything else. I'll have to look at Macrium though, that would be nice to have.

    @Saltgrass I agree there was definitely something going on that I wasn't entirely understanding but it seems to be working fine now and I made a good restore point :)

    Thanks for the help guys.
     

Share This Page

Loading...