windows management instrumentation - slow upload speed

Discussion in 'Windows 7 Help and Support' started by RangerPivot, Oct 28, 2012.

  1. RangerPivot

    RangerPivot New Member

    Joined:
    Oct 28, 2012
    Messages:
    6
    Likes Received:
    0
    Hi,

    I swapped out the MB, CPU and memory in my rig. I did not reinstall windows 7. I was pretty impressed that this worked as well as it did but I have one nagging problem... The network upload speed has suffered a lot. It's not just throughput but the initial "connecting" handshake seems to take a while.

    For instance, if I go to one of the speed test sites the download is fine. It starts up immediately and is steady at around 20mbs. When this is complete it takes between 10 and 20 seconds for the upload test to start (just says connecting)... and only uploads at .5 to 1mbs. Historically this has been immediate and much faster.

    After much searching I found that disabling windows management instrumentation in msconfig restored my upload network connectivity. In a speed test the download didn't change, but after that was complete the upload started immediately and was around 5mbs.
    I disabled/re-enabled this several times to make sure that I got the same results.

    Is there any way to "fix" WMI without wiping/reinstalling? That's my last resort.

    Other info
    MB upgrade was from a ASUS p5qse2 to ASUS p8z77-vlk
    CPU went from Q9550 to I7 3770K

    Troubleshooting went in this order:
    bounced router/modem
    bypassed router
    reinstalled network adapter
    disabled/reenabled windows firewall
    disabled wmi

    Thanks
     
  2. RangerPivot

    RangerPivot New Member

    Joined:
    Oct 28, 2012
    Messages:
    6
    Likes Received:
    0
    Well. Since I had time today and got impatient I reformatted the drive and reinstalled windows 7.
    Same symptoms!

    My phone and tablet (running android jellybean) are fine. But something with windows 7 and WMI seem to be capping the upload speed.
     
  3. RangerPivot

    RangerPivot New Member

    Joined:
    Oct 28, 2012
    Messages:
    6
    Likes Received:
    0
    Sort of solved.
    The ASUS MB came with several utilities. I wanted just the temperature probe software but it only came bundled with several other ASUS utils... including some kind of network tweaker. After uninstalling the suite the network speed returned to normal.
    I have no idea why disabling WMI worked but was obviously not the root cause.
    Anyway, maybe this will help someone else.
     
  4. AdeBe

    AdeBe Member

    Joined:
    Dec 1, 2013
    Messages:
    1
    Likes Received:
    0
    Great, thanks.
    I have a Realtek PCIe GBE Family Controller. The download speed was fine, up to 100 Mb, but the upload was as low as 1Mb. Tried pausing the Windows Management Instrumentation, as someone suggested, which actually sort of solved this problem, but that of course was not an optimal solution.

    So, following your suggestion, well it was not necessary to uninstall the suite, if was sufficient just turning the Network iControl off in the ASUS AI Suite II. That did the trick. Back up to 100Mb upload speed as well.
     

Share This Page

Loading...