Windows Media Player 12 won't start (7, 64bit)

#1
It happened a week ago and I haven't found a solution.
I tried searching here and some other sites for a solution but nothing helped.

Basically, when I click the wmplayer exe (both x86 and x64) it just does nothing.
If I try playing an associated video/audio file it says: "Server execution failed".
What I have, basically, already tried:
1. sfc /scannow,
2. Adding admin rights to the services (already had),
3. Tried unchecking and rechecking the "feature" of media player,
4. Tried system restore, but for some weird reason I have only restorations available from the last few days,
5, Tried opening the wm_setup exe but it says that the latest version is already installed and I'll need setup verion 7600.0.7000.7000 to reinstall it (what...?).

I would be happy with any suggestions you give me before I end up formatting.
Thanks.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Go to control Panel, Programs and Features, Turn Windows features on or off. Select Media Player and uncheck it, then come back and recheck it. Perhaps this would basically reinstall it.
 


reghakr

Essential Member
#3
Couldn't he run it from the C:\Program Files (x86) directory. This would be the 32-bit version I believe.
 


#4
Saltgrass, that exactly what I ment on comment 3 (Tried unchecking and rechecking the "feature" of media player), sorry if I wasn't clear enough.
reghakr, you're right. Both 64 bit and 32 bit version don't work.
I believe its a screwed up reg key or something like that rather than a damaged file.

Thanks.
 


reghakr

Essential Member
#5
Are you using a purchased version or the RC?
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
Do you have any music selections shown in the jumplist? Maybe something there is corrupt.

Could it have anything to do with Homegroups or perhaps media sharing?
 


#7
Its a purchased Windows 7 Ultimate Edition (64 bit), version 7600.16385.
How can I check/reset the jump list - not from the WMP itself? Are there any registry keys/files that can be removed to reset it?
Since, as I said, right now, when I try opening the WMP its just thinking for awhile and opens nothing.
 


reghakr

Essential Member
#8
Just wondered, so you could re-burn the DVD if it was the RC version.

I'll take a look at the registry keys.
 


reghakr

Essential Member
#9
Give this atry in the Run box:
%SystemRoot%\system32\unregmp2.exe /SetWMPAsDefault
 


#10
Didn't work as well :(
If I weren't clear again (sorry, but English is not my native language), the WMP worked fine till a week ago,
so I do believe that reinstalling 7 should solve the problem.
Just wondered (and hoped) that I could solve the problem locally before taking these moves.
Haven't given up yet, though :)

Thanks again for all your help, guys.
Really appreciate it!
 


reghakr

Essential Member
#11
Sorry, I messed around with the registry and hoses my Media Pllayer,

That;s OK, because I never use it
 


Last edited:
#12
Sorry to hear that.
WMP12 really sucks.
Took too many sicknesses from the WMP11 of the Vista.
 


reghakr

Essential Member
#13
I could car less if it's gone:D

POS application
 


Last edited:
#14
ALright so os there any solution for this ... ? Its still not working ... Windows 7 WMP12 .. and it doesnt even load ,,, its a joke ..!!!
 


#15
This For anyone having this problem could be due to a corrupted library happened to me all i did was delete in C:\Users\UserName\AppData\Local\Microsoft\Media Player\ A file called CurrentDatabase372.wmdb it will redo itself when you start WMP.
 


#16
try this!

1. Click Start, click Accessories, the right click on Command Prompt and choose "run as administrator", then type regsvr32
jscript.dll, and then hit enter.
2. Type regsvr32 vbscript.dll then hit enter.
3. Now type exit and hit enter. Now try media player and it should work.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top