Windows taskbar I.E. icon not showing

Discussion in 'Windows 7 Help and Support' started by Evincar, Jan 30, 2010.

  1. Evincar

    Evincar New Member

    Joined:
    Jan 30, 2010
    Messages:
    18
    Likes Received:
    0
    Hello,

    I just installed Windows 7 a few days back, and I am loving the new features, stability and speed compared to Vista. I upgraded Vista Home Premium to W7 Home Premium, and the process went flawless.

    Now I have a strange problem. The new taskbar shows a large icon of the running programs. All icons seem to work correctly, except for the Internet Explorer icon. That icon is a white 'file' icon. See the attached picture.

    IE icon problem.JPG

    When I toggle between 'locking' and 'unlocking' the program to the taskbar, the icon suddenly appears and then disappears again.

    Has this been happening to anyone else? Any suggestions to a solution?
     
  2. Evincar

    Evincar New Member

    Joined:
    Jan 30, 2010
    Messages:
    18
    Likes Received:
    0
  3. Evincar

    Evincar New Member

    Joined:
    Jan 30, 2010
    Messages:
    18
    Likes Received:
    0
    Funny how things seem to solve itself when you keep trying solutions.

    I noticed that the icon for Internet Explorer in my Start menu was also generic. Going to the Properties of that shortcut, I was able to change the icon into something else. That solved the problem, and my task bar now shows the new icon (also an Internet Explorer icon, in my case).

    So for some reason the upgrade to W7 corrupted my iexplore.exe icons. Weird, but solved.
     
  4. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    I suggest you open the Control Panel (icon view) and then open "Programs and feaures"
    Over on the right, select "Turn windows features on and off" Scroll down and turn off IE. Reboot and reenable the IE.
    You might then have to repin the IE shortcut to the taskbar.
     
  5. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    If you have the same problem in the future,just delete the IconCache.db from the C:\users\yourusername\AppData\Local
     
  6. Evincar

    Evincar New Member

    Joined:
    Jan 30, 2010
    Messages:
    18
    Likes Received:
    0
    Thanks for the suggestions.

    To reghakr, I tried that and it did not solve the problem.
     
  7. Tony Mathews

    Joined:
    Oct 16, 2015
    Messages:
    1
    Likes Received:
    0
    Mine is a Windows 7 64 bit - So what I did was I right clicked on "iexplore.exe" located at C:\Program Files\Internet Explorer\Internet Explorer, in the right click menu it shows "Pin to Taskbar", choose this and you should be able to see Internet Explorer in your Taskbar.

    Regard, Tony Mathews.
     

Share This Page

Loading...