Windows update problem unsolved

Discussion in 'Windows 7 Help and Support' started by edspiderelrod, May 20, 2013.

  1. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    I have searched Windows Update threads and tried a number of things suggested, all to no avail.

    I have prepared a long, detailed list of what was wrong and what I have done to correct it, but it's too long to paste here. I attached it below. Any help would be appreciated. Thank you. w9pto@embarqmail.com
     

    Attached Files:

  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The error message is telling you:

    After you renamed the Software Distribution folder, did the system try to start downloads again? It does have to rebuild its data base and takes some time and might need several restarts and complete shutdowns to complete the install of some updates.

    What anti-virus software are you running?

    Have you run the System Update Readiness tool? If so, what does the log say? The link does not mention your error message as one it will repair, but you could try if you have not already.

    %SYSTEMROOT%\Logs\CBS\CheckSUR.log

    System Update Readiness Tool fixes Windows Update errors in Windows 8, Windows 7, Windows Vista, Windows Server 2008 R2, and Windows Server 2008

    There is a Log file in the Windows directory called WindowsUpdate.log which you can copy to the desktop and copy the last 10 days of entries and paste in a text file, or use the whole thing, but zip it and attach. Maybe I can find something relevant.

    Make sure the Windows Update service is running in the Services panel.
     
  3. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    Thank you for your reply.

    1. When I looked up the error message I received, it basically told me to try Fix It, which I did, and that did NOT help.
    2. If I renamed the Software Distribution folder, it was unknowingly done when I ran one of the programs suggested by others. I certainly did not rename it myself. But it clearly did not help the situation, as I still can't get automatic updates.
    3. I am running MS Security Essentials.
    4. I have NOT run the System Rediness Tool, but I am attempting to download it now. Projected download time is 2 hours. I will run it as soon as it is finished downloading.
    5. What should I do with %SYSTEMROOT%\Logs\CBS\CheckSUR.log ?
    6. I finally found WindowsUpdate.log.
    7. The Services panel says Windows Update is "started", but the "Startup type" is "Automatic (Delayed Start)"
    8. I'm still downloading The System Rediness Tool. 8% down; 92% and over 2 hours to go. Don't understand that; we're on a local cable system; should be faster than that.
     

    Attached Files:

  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    It might take me a while to look through the log, but I am seeing the WinHTTP errors and ERROR_FAIL_REBOOT_REQUIRED errors. I have seen some anti-virus programs that will interfere with the update reboot process, but MSE does not.

    You might check your services panel and see if WinHTTP Web Proxy Auto-Discovery service is set to a Manual start and can you start it.

    The Automatic (Delayed) is the correct Startup Type for Windows Update.

    The CheckSUR.log will be generated by the readiness tool so you can check it after running.

    I am wondering if the download situation you seem to be having might be related to the update problem. Do other Microsoft sites appear to be normal?

    You may want to run a System File check by opening an Administrative command prompt and typing SFC /scannow and let it finish. I would not expect yours to not find errors, but let us know. Maybe it will repair something you need.

    You may also want to use something like Malwarebytes to do a scan of your system in case some virus is involved.
     
  5. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    Thanks again for trying to help.
    1. The only anti-virus program I have is MS Security Essentials, and you say that doesn't create this problem
    2. I checked WinHTTP Web Proxy Auto-Discovery, and it says "Started" and it's set on a manual start. Should it be set on something else?
    3. I couldn't find a CheckSUR.log. The only reference that came up was to the email quoting you
    4.The slow download corrected itself. It took far less than originally stated. It did take a long time to install, though. I find no reference to the Readiness Tool in programs or anywhere else.
    5. I don't know how to open an administrative command prompt. I assume that's like going back to DOS, but I don't know how to start that process.
    6. I'll explore Malwarebytes.
    Thanks again. I would really like to get this solved.
     
  6. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    Forgot to mention before #1:
    After installing System Update Readiness Tool, I did reboot.
    I got the "Windows can't check for updates" balloon again

    Update:
    I DID run Malwarebytes, and i have NO malware
    I did remember how to get into the C: prompt, but I can't recall how to sign myself in as an administrator. It insists on labelling me a "user."
     
  7. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    I checked, and User accounts/Manage an account/Change an account shows me as the only account, and as an administrator. But when i go to the Command priompt and type in SFC/scannow, i get the message that I have to be signed in as an administrator in a console session. But I'm the only user, and have administrator privileges. Suggestion?
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    An administrative command prompt can be opened by using Winkey and typing cmd, then Ctrl+Shift+enter or just going to start menu - all programs - accessories and right click Command prompt and selecting Run as Admin.

    If the Readiness tool ran, it would leave the CheckSUR.log where indicated.

    You Update log shows the Windows Automatic update is in error status and finds no updates when it should be checking. It also says it is only checking 5 categories. It should be checking around 70 categories. You are not showing any BITS activity, which is the background transfer service. Basically nothing seems to be working regarding Automatic Updates. It seems to start, but never actually checks finishes. The WinHTTP error seems to be the reason. It is not communicating correctly with the update site.

    Edit: There is one more thing you can check. If you open msinfo32.exe, it will have a list of drivers in the Software Environment-System Drivers section. Look for http and make sure it is running and a manual start.

    I assume manually checking for updates does not help.
     
    #8 Saltgrass, May 23, 2013
    Last edited: May 23, 2013
  9. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I found this site you might try. But it continues to appear something is blocking the internet connection, or something on your system is not working. Whether it might be a Firewall or anti-virus situation, or a corrupted system file, such as .Net suggested on the site..hard to know.

    RegMender - Computer Problem and Solution

    As you can tell, the error 80070bc9 is referenced on page 15 of the site.
     
  10. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Another possibility, and purely a guess...

    Normally, when a reboot is necessary during installation of updates, a message is given as either a pop-up or on your Start Menu power button. If you are not getting those but you still get the Reboot Required error message, maybe something has gotten stuck in the registry.

    Even though it is not a likely possibility since you are not getting reboot messages, you might check the following registry entry to see if you have it and how it is set, if you do. The RebootRequired should be in the right pane of the registry editor. Don't change anything unless you know the safety rules, but let us know.

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired
     
  11. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    Never have been able to find the CheckSUR.log
    Did run SFC/scannow, and it found "corrupt files but unable to fix some of them."
    Then looked for the CBS.log, which was allegedly generated, even looked for windir\logs\CBS\CBS.log,
    [listed when SFC/scannow run finished] and could not find that log, either.
    Could not find HKLM\SOFTWARE\.... in registry.
    Did find the correct string under HKEY but did not end up with "Reboot Required" in right-hand pane. Tried to duplicate the string so I could tell you all of it, but was unable to find the right combination a second time. I did NOT modify anything; just looked.
    My error number was not listed on RegMender - Computer Problem and Solution I could try some of those solutions, however.

    Would the best bet be to reinstall all of the files associated with Windows Update
    ?
     
  12. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    Also, Malwarebytes found NO malware.
     
  13. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The 80070bc9 reference is on the linked site, page 15.

    The CBS.log is on every Windows 7 system, and it not just for Windows Update entries. So look again for the path. If you can't find it, tell me where the path ends. Do you have the CBS folder and any files in it? If you are using Explorer to search for it, start in the Windows directory. It is not a hidden file, so you may see CBS or CBS.log depending on whether you have the Hide extensions of know file types box checked.

    C:\Windows\Logs\CBS

    Copy the CBS.log to your desktop to check it.

    The CheckSur.log is the same thing, but it will not be present until the readiness tool in run. Again, it is at:

    C:\Windows\Logs\CBS

    Reinstalling the Windows Update components might help, if you could. One of the log entries in your WindowsUpdate.log shows it is trying but gets the reboot needed error.

    At this point, you may want to think about doing a Repair Install. If you want to try to reinstall the Windows Update components first, go to the linked site. If the Windows Update Agent is not already installed, you should be prompted to install it. The Second Link is the page that references the first link.

    http://www.update.microsoft.com/

    How to get the latest version of the Windows Update Agent

    Edit: On the Updates you do show listed, did any show a failed status and not reinstall later. If any did, you might try uninstalling it/those. But you can only uninstall updates that are listed in the Installed Updates window.
     
    #13 Saltgrass, May 24, 2013
    Last edited: May 24, 2013
  14. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
  15. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    I tried to reinstall (repair, whatever) updater, but whenever I clicked on the URL you supplied, it forced me to reboot. So i gave up on that. I tried to find the two logs and was unable to find them. When I get the command prompt as an administrator, I get C:\windows\system 32\ > and can't get back to just Windows. THought the command to go back was \cd, but that didn't work. It's been a long time since i used DOS. I still plan to follow all the suggestions listed in RegMender, and I certainly will try your latest suggestion, Temporary connection-xxx. But I was bummed out yesterday and had to do other things: sleep, eat, practice the clarinet, etc. So this afternoon I'll resume my pursuit. Thanks for all your help this far. I may just have to hire someone to reinstall Windows update.
     
  16. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You don't have to use a command prompt to find the log files, just explorer...

    If you get a reboot when connecting to the linked site regarding winHTTP, it might confirm the problem lies in that area.

    Run this command from an administrative command prompt and post the resulting text file. Just copy from here then use the right click paste options in the command prompt.

    findstr /c:"[SR]" %windir%\Logs\CBS\CBS.log >"%userprofile%\Desktop\sfcdetails.txt"
     
  17. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    Sorry I have been away from this problem for a couple of days, but other things took precedence.

    I brought up Command Prompt as Administrator, right clicked, and pasted findstr /c:"[SR]" %windir%\Logs\CBS\CBS.log
    >"%userprofile%\Desktop\sfcdetails.txt", and I immediately got a new command prompt. I did NOT get an error message of any sort, now did it look like anything happened.

    With your suggestion to use Windows Explorer, [thank you] I was able to find both the CBS.log and the CheckSur.log. Every time I tried to open the CBS.log, I got a window that said "Access Denied." But I was able to open the CheckSur.log and save them, and I have attached both versions.

    I have not yet tried the suggestions in Temporary connection-related errors may occur when you use Windows Update or Microsoft Update , but I will do so. I also have not yet tried RegMinder, and I will go through those procedures, too.

    Thanks again for your continued assistance. We may beat this yet.
     

    Attached Files:

  18. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
  19. edspiderelrod

    Joined:
    May 17, 2013
    Messages:
    39
    Likes Received:
    0
    I ran the RegMender section of "How to fix Windows Update Error 80070BC9" which you found in a log. When I ran http://www.microsoft.com/en-us/download/details_aspx?id=3965 I got a window that said this was not applicable to my system. So then I ran http://support.microsoft.com/kb/971058 and got "Fix It" again, which ran through some mascinations and then a got a window that said "Repair Windows Update components-Fixed." This is the same window I've gotten every time I've run Fix It, and we're still not downloading updates.
     
    #19 edspiderelrod, May 29, 2013
    Last edited: May 29, 2013
  20. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I suppose where we stand right now is the CheckSur.log indicated your Windows Update components are OK. You could not get the text file from the System file check, so we do not know what system files might be bad, and you did indicate you had some bad system files. The sfcdetails.txt file should be on your desktop if you ran the command. If it did not work by copying and pasting, try typing it directly or copy it to Notepad first and then copy from there and paste in the Command Prompt.

    You have not addressed the WinHTTP errors which are consistent in your WindowsUpdate.log. There is a possibility the SFC scan found a bad system file relating to its operation. If the troubleshooter you did has not shown any problems, I do not know where to go next. Method F concerns BITS, which runs in the background to download the updates. Your system is not finding any updates to download, even we know there are many.

    Again, you might think about doing a repair install. If the Updates continue to not work, you may end up with a Not Genuine or other type of message on your OS...but not sure about how or when.
     
    #20 Saltgrass, May 30, 2013
    Last edited: May 30, 2013

Share This Page

Loading...