Windows updates not updating

#1
When I try to do the windows update, I get the following messages & they will not install. I have Windows 7 OEM 64 bit
My systems specs are as follows:

CoolerMaster HAFX942 Blue
ASUS P8Z68 DELUXE GEN3
i7-2700k
Corsair H100
Corsair Dominator 16GB, 1866 DDR3
(X2) EVGA GTX560ti DS
(X2) OCZ Vertex 3, 256GB SSD set in RAID0
WD 500GB VelociRaptor
WD1.5TB 7200RPM Bare Black
Creative Labs Recon Fatility Champion
AEROCOOL Touch 2100 Fan Controler
CoolerMaster Silent Pro Gold 1200W
ASUS DVD - OEM
ASUS Burner/DVD - OEM

AntiVirus- Kasperski Internet Security
Windows 7 64 bit OEM
currently I have NOT installed Windows 8 & really don't intend to do so as this Deslktop is primarially a back-up Gaming Rig

( 1 ) Update for Microsoft .NET Framework 4 on Windows XP, Windows Server 2003, Windows Vista, Windows 7, Windows Server 2008, Windows Server 2008 R2 for x64-based Systems (KB2468871)
Download size: 27.5 MB
You may need to restart your computer for this update to take effect.
Update type: Recommended
Install this update to resolve issues in Microsoft .NET Framework 4. For a complete listing of the issues that are included in this update, see the associated Microsoft Knowledge Base article for more information. After you install this item, you may have to restart your computer.
More information:
Update for the .NET Framework 4
Help and Support:
Microsoft Support

( 2 ) Update for Microsoft .NET Framework 4 on Windows XP, Windows Server 2003, Windows Vista, Windows 7, Windows Server 2008, Windows Server 2008 R2 for x64-based Systems (KB2533523)
Download size: 37.5 MB
You may need to restart your computer for this update to take effect.
Update type: Recommended
This update addresses stability, reliability, and performance issues in Microsoft .NET Framework 4. After you install this item, you may have to restart your computer.
More information:
Reliability Update 1 for the .NET Framework 4
Help and Support:
Microsoft Support

When I try the updates it will not install these & I've completed some reasearch but haven't found the fix as of yet. I would deeply appreciate any help you might offer to resolve this issue. My system runs fine without any glitches except for the following & I'd really like to get this resolved. As of lately I've been extremely busy & haven't had time to devote to it in detail. Thank You VERY MUCH :)
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
A couple of possibilities. Some Anti-virus applications can block the installation of certain updates, especially those that require a reboot or shutdown and restart to install. Check Kasperski and see if you can find a setting for virus scanning during boot. The terms they use might be specific for that application, but it should mention something about boot scans.

In addition to turning off the above setting, you might disable the whole thing for testing, you could disconnect your internet connection for safety.

As I mentioned, some updates may require a complete shutdown, not a restart. Mine will show a "Shutdown" message on the power button.

The .Net 4 Client install is listed in Programs and Features in the Control Panel. You can right click the listing and select Change/Uninstall and you will receive an option to repair the install.
 


#3
I did as follows, disconnected from internet ( after trying the repair with no success ). Kasperski didn't block the installation, not sure what to try now! :-(
 


#4
Turn off Kasperski completely and retry updates.
 


#5
Okay, I'll try that as well! :-D
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.