Windows wont let me enable wifi adaptor

Discussion in 'Windows 7 Networking' started by tallon, Jun 30, 2011.

  1. tallon

    tallon Well-Known Member

    Joined:
    Jun 30, 2011
    Messages:
    11
    Likes Received:
    1
    I've just installed a wireless PCI adaptor (Tenda W322P 11N) in my desktop PC but I can't 'enable' it - every time I double click it starts to enable then stops and leaves it disabled with no warning or error messages.

    The system is definitely seeing it as it's listed in Device Manager, and if I bring up Network Connections (using ncpa.cpl) it's listed and shown as disabled. Why would windows stop it from being enabled??

    I've tried downloading new drivers from the manufacturers site in case the drivers on the disk were old - no difference. I uninstalled it and removed the drivers and then re-booted so windows would use it's own drivers - no difference.

    It seems the system has a problem with it, but surely ONE of the drivers would work if it was a driver problem?
     
  2. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,884
    Likes Received:
    318
    Is this PCI adaptor Win 7 compatiable? The only thing I can find on their web site is windows 2000 or higher on the and no specific 7 drivers. The adaptor itself could be bad.
     
  3. tallon

    tallon Well-Known Member

    Joined:
    Jun 30, 2011
    Messages:
    11
    Likes Received:
    1
    Well, I bought it from ebuyer and the 39 user reviews give it a total of 4.5 stars out of 5 and several people mention immediate and easy installation with Windows 7, so I don't think that's it.

    UPDATE:


    I read elsewhere that anti-virus progs can interfere with driver installation, so tried this:


    - Disabled AVG 2011, then uninstalled the wifi card
    - rebooted into 'safe' mode (with networking), installed the wifi card and let windows supply the driver
    - it works!
    - rebooted into 'normal' mode and it still works - BUT THE PC HAS SLOWED TO A CRAWL
    - by that I mean it takes between 40-80- seconds to execute every key press or mouse click


    Re-did all the above twice using the latest drivers from Tenda's website and Ralinks website - same problem with each.


    So, this leaves me thinking it's nothing to do with the Tenda card or it's drivers (these are very common cards and most people on the net post good things about them) but is a Windows 7 problem (well, no suprise there.....) compounded by AVG not allowing driver installation.


    I'm even more baffled - any thoughts?
     
  4. kaos

    kaos Senior Member

    Joined:
    May 9, 2011
    Messages:
    1,747
    Likes Received:
    33
    go in to device manager (right my computer ) and see if there is a yellow triangle with a ! in it, if there is you will need to locate the driver for the deive


    so right click the card wifi

    click propterties
    click update driver

    search my compjuter


    click on the driver downloaded from the net ( one of your post said you downloaded one?
     
  5. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,884
    Likes Received:
    318
    So it seems to be an AV issue. Try using different AV porgrams, the top 2 are MSE and Avast and both are free. See if one of them work for you so that your speed is not compromised. I'm currently using Avast but I have used MSE.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Maybe a couple if things. If the device is slowing down the system, possibly it is having problems communicating with the router. What router do you have and is it configured for 802.11n? Both devices may be backward compatible, so it will probably work, but maybe not as well as it should. Also, if it is working on the wrong internal network, or using the Microsoft supplied IP address, it might be slow, so make sure you check the IP addresses it is using.

    Do you have Mac Filtering on your router, and if so is the new MAC address allowed, and set for the proper security. It would seem if the adapter was seeing the network at all, the Mac Filtering has to be set up correctly--assuming it is looking at YOUR network. Click the Wireless icon and see if your network shows up and what signal strength.

    Not really sure as to what effect the anti-virus might have during an install, but it seems strange you would have to go into safe mode to install it. You can select the installer to run as admin if that would help. I also do not understand your comment about double clicking to enable. I right click and select enable in the Network and Sharing Center Adapters window. But is should have installed as enabled, so maybe the fact it may not is part of the problem.

    If you cannot get it working to your safisfaction, I would suggest you go into Device Manager and uninstall the drivers. When it asks if you want to uninstall all instances, select yes. Then reboot and try installing the drivers again with the anti-virus off if necessary. If you can, select the Run As Administrator option.
     
  7. tallon

    tallon Well-Known Member

    Joined:
    Jun 30, 2011
    Messages:
    11
    Likes Received:
    1
    SOLVED IT.

    Thanks to 'bassfisher6522's suggestion, I uninstalled AVG, then ran avgremover to strip out all the cr#p it left behind. (Then I found remnants of Kaspersky anti-virus installation from 2 years ago so used kavremover to get rid of that too.)

    Then uninstalled wifi card and it's drivers, and rebooted into safe mode. Installed latest card drivers and it worked fine.

    Re-booted into normal mode - still working fine - and then installed Avira Free version, which doesn't seem to have any problems with it as it's all working.

    So, it looks like it was down to AVG having issues with driver installation, or at least THESE drivers as I've not experienced this before.
     

Share This Page

Loading...