winload.exe errors (repair console still shows vista install??)

#1
I recently installed windows 7 from an OEM disk. During the drive selection screen, I entered the "drive options" screen and deleted the vista partition, created a new partition encompassing the entire drive capacity, and then selected "format." I then installed Windows 7 on this empty partition.

My issue: 4 out of 5 boots result in the winload.exe error 0x00000428 (no digital signature). I select "Enter" to "continue without this file" and the only choice listed for an operating system to start is Windows Vista (which I supposedly wiped out).

I tried utilizing the windows 7 install cd to repair the boot and after searching for installations, again only Vista shows, and not Windows 7.

I feel I should mention that I have a secondary hard drive for storage that has never had a windows install on it. However, upon showing hidden and protected OS files, the drive's root directory contains the boot folder and the file "bootmgr."

I already attempted to backup, move and rebuild the Bcd, to no avail.

Setup:
cpu-Core2Quad q9550
ram-8GB DDR3 1333
mob-EVGA 790i FTW
vid-GTX 260 SLI
hdd-150GB SATA Velociraptor (windows)
hdd-1TB SATA 7200 (storage)
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#2
Hi

Download EasyBCD and run it.
It will show you your boot setup information.

If it is showing Vista as a boot option it will let you remove it.

EasyBCD - Free software downloads and software reviews - CNET Download.com

It should show what OS is available to boot to and let you stipulate that you want the computer to boot to Windows 7. If necessary it will create a new boot manager file.

Normally the bootmgr file would be on the same drive that the operating system is on.
It sounds like your have somehow created a second one on your number 2 hard drive and that is interfering in the boot process somehow.

I would not recommend deleting it before you get the computer to boot normally, you might find that the computer would not boot at all if you do.

Get the computer to boot normally then make sure that the bootmgr file is is using it the one on you main drive.

Mike
 


Last edited:

Captain Jack

Extraordinary Member
#3
Hello and Welcome to W7F !

Is your Windows 7 disk legit ? Did you buy the upgrade disk ? Or you got the retail ?
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#4
It sounds like the boot file you were trying to rebuild may not be the one that the computer is using.
Is there one on both of your hard drives?

Let us know what EasyBCD shows.

It should look like this...

http://img156.imageshack.us/img156/6299/easybcd20.jpg

Mike
 


Last edited:

Saltgrass

Excellent Member
Microsoft Community Contributor
#5
Attaching a snipping tool picture of your Disk Management window may help us see what is going on....
 


#6
Thanks Mike! I utilized EasyBCD and the problem in indeed gone. My status screen now looks like the one you previously attached.

http://img217.imageshack.us/img217/2148/dskmgt.jpg

There is still a boot directory on the D: drive, which is unable to be deleted without a "trusted installer." Is there a way to around this?

(To Captain Jack: Yes, I purchased my OEM disk.)
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#7
Hi

Glad you got it fixed.

Try logging in a administrator via this procedure and see if it will let you delete it.

How to Enable the Administrator Account

Open the command prompt with elevated privileges by clicking the Start orb, All Programs, Accessories, right-click Command Prompt and then select Run as administrator.

Type

net user administrator /active:yes

and then press Enter.

Log out and log back in as Administrator.

When you are done undue the process by doing the same thing and pasting in ….

net user administrator /active:no

Mike
 


#8
Unfortunately, that route didn't work for me, Mike. I still got the same "require permission from TrustedInstaller" message.

Maybe it wouldn't be so bad to just leave it there now that it doesn't seem to cause any booting issues now.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#9
As long as you know for sure it is not being used, try moving then deleting or take ownership and delete.

I don't think EasyBCD will remove it, but you might check.

And no, it will not interfere if it is not in the first active partition.
 


#10
Well changing permissions isn't going to work because the options are completely grayed out. As I said, it's not interfering now and it only takes up a small amount of hard drive space so I'm just going to leave it there. What's important is that my computer now boots every time and so long as window's protected files are hidden, I won't even notice it anyway.

Thank you everyone for all of your help!
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#11
Hi

You might want to check out a little app called Take Ownership.
I have found it to be useful.

It adds a Take Ownership command to your right click drop down and will let you access a lot of things that Windows 7 blocks.

Add "Take Ownership" to Explorer Right-Click Menu in Win 7 or Vista - How-To Geek

Mike
 


#12
Hey, that worked! Thanks again, Mike! You've been great!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.