Wireless doesn't have a valid IP configuration

#1
Intermittenly, I can't get wireless for some reason and get the msg: "Wireless doesn't have a valid IP configuration", with "unidentified network, no network access". In the past, I could just plug in to the wired connection and theIn suddenly, it would recognize the wireless. I can't seem to get it to work after reboot, turning off the router, etc. I've looked through other posts and tried various things and I don't have bonjour anywhere either that i can tell.
Any ideas? This makes me crazy! Thanks!

If i run ipconfig, i get:
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.
C:\Users\sheederj>ipconfig
Windows IP Configuration

Wireless LAN adapter Wireless Network Connection:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . : hsd1.co.comcast.net.
Link-local IPv6 Address . . . . . : fe80::e4b1:7869:2645:dcdc%12
IPv4 Address. . . . . . . . . . . : 192.168.0.5
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
Wireless LAN adapter Wireless:
Connection-specific DNS Suffix . :
Autoconfiguration IPv4 Address. . : 169.254.82.105
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
Tunnel adapter isatap.hsd1.co.comcast.net.:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : hsd1.co.comcast.net.
Tunnel adapter 6TO4 Adapter:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Tunnel adapter isatap.{E9C5C728-D4C1-4F56-AF52-F78198880CBE}:
Connection-specific DNS Suffix . :
Default Gateway . . . . . . . . . :
Tunnel adapter Teredo Tunneling Pseudo-Interface:
Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:2c9a:2ad9:bc51:9cb8
Link-local IPv6 Address . . . . . : fe80::2c9a:2ad9:bc51:9cb8%14
Default Gateway . . . . . . . . . : ::
Tunnel adapter isatap.{45467C39-91F7-49EB-AE0B-B76AB9DF2CB5}:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Tunnel adapter Reusable Microsoft 6To4 Adapter:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
 


#2
Try this:

The Fix
  1. Start by running cmd from the start menu
  2. Type “ipconfig /all” without the quotes
  3. Write down the physical address of which ever connection is/are not working. If you are hard wired to your router, then use the Ethernet adapter physical address. If you are running wireless, then use the Wireless LAN adapter. I had to do this for both.
  4. Go to your router's firewall and find the physical addresses of the connections.
  5. Find the physical address(s) of your blocked adapter(s) and unblock it.
Sorry I can't be more specific for everyone's router but that is the general idea. I'm using Win 7 but I don't think it makes any difference.

referenced:Local Area Connection doesn't have a valid IP configuration (W7)
 


#3
CALL YOUR ISP, TELL THEM WHAT HAPPENED AND THEY CAN CONFIGURE A NEW IP ADDRESS FOR YOUR CONNECTION. IT ONLY TAKES ABOUT HALF AN HOUR.

During this time you must keep your router/modem turned off, and after the ISP has fixed the problem (in my case it took half an hour) you must restart your machine with the router/modem on and connected. From then on it should be like nothing ever happened.

Just for the fun of it, here's a list of things I have tried without results:

release/renew ipconfig
restarting modem/router and computer about a zillion times
changing LAN card
creating a static IP
resetting winsock in command prompt
reinstalling Windows 7
reinstalling XP (I had a dual boot and I did both, losing all installations)
manually entering IP address
disabling/enabling local area connection
plugging and unplugging LAN cable
uninstalling and reinstalling LAN card driver
resetting modem/router using the reset button

And after all this, all it took was just a phone call.
This is because your ISP is THE ONLY authority when it comes to configuring your IP address. In this case, it can only be done from the outside. this is also the reason why Microsoft didn't announce any patches or fixes for this problem, because it is not their problem and responsibility
 


#5
Answer In reply to 04749s post on December 14, 2009


Fixed it ... after thinking about it and trying a few suggestions .

Start > Control Panel ( Large Icons ) > Windows Firewall > Allow a program or feature > Allow another program > Right click on Bonjour Sevices and delete .
Close and reboot .

Hope this helps those with this issue .
  • December 23, 2009
  • Reply with quote
  • Report abuse
    • Child exploitation or abuse
    • Harassment or threats
    • Inappropriate/Adult content
    • Nudity
    • Profanity
    • Software piracy
    • SPAM/Advertising
    • Virus/Spyware/Malware danger
    • Other Term of Use or Code of Conduct violation


referenced: Wireless Network Connection doesn't have Valid IP Configuration - Microsoft Answers
 


#6
Try this:

The Fix
  1. Start by running cmd from the start menu
  2. Type “ipconfig /all” without the quotes
  3. Write down the physical address of which ever connection is/are not working. If you are hard wired to your router, then use the Ethernet adapter physical address. If you are running wireless, then use the Wireless LAN adapter. I had to do this for both.
  4. Go to your router's firewall and find the physical addresses of the connections.
  5. Find the physical address(s) of your blocked adapter(s) and unblock it.
Sorry I can't be more specific for everyone's router but that is the general idea. I'm using Win 7 but I don't think it makes any difference.

referenced:Local Area Connection doesn't have a valid IP configuration (W7)
** Hello, bassfisher6522 ** Thanks SO much for posting this. All this time, I was thinking it was my cable modem or Linksys router. I never really approached it as a Windows 7 issue. Thanks for pointing me (and others, I'm sure) in the right direction.
Thanks - Elizabeth (RebootITNow)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top