Wireless-G USB Network Adapter "limited access"

#1
I have a Linksys Wireles-G USB Network Adapter (Model #: WUSB54GC) that wont fully connect to my home Wi-Fi network. "Limited Access" is as far as I can get. The Windows Troubleshooter just says there might be a problem with the driver, even though I downloaded the latest version driver and installed correctly. I'm at a loss, I don't even know where to begin to try and fix this problem, could use some help.
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#2
First step is to run ipcnfig and loo at the adapter configuration:

Goto run programs, accessories, right click on command prompt, run as admin. Enter the following command into the command screen:

ipconfig /all

If you need help interpreting the output you can post it here.
 


#3
Yeah I could use some help interpreting this...


C:\Windows\system32>ipconfig /all


Windows IP Configuration


Host Name . . . . . . . . . . . . : PCT-48
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No


Ethernet adapter Local Area Connection:


Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR8132 PCI-E Fast Ethernet Contro
ller (NDIS 6.20)
Physical Address. . . . . . . . . : 00-23-5A-F2-D4-CD
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes


Wireless LAN adapter Wireless Network Connection:


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR5007EG Wireless Network Adapter


Physical Address. . . . . . . . . : 00-26-5E-59-9C-19
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : fd6a:7f7c:3ccb:0:e5c7:6bc2:2beb:db5f(Pref
erred)
Temporary IPv6 Address. . . . . . : fd6a:7f7c:3ccb:0:64e3:1b9d:4e88:d99a(Pref
erred)
Link-local IPv6 Address . . . . . : fe80::e5c7:6bc2:2beb:db5f%10(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.134(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Friday, November 30, 2012 3:18:53 PM
Lease Expires . . . . . . . . . . : Sunday, December 02, 2012 3:22:59 PM
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 184559198
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-41-A0-10-00-23-5A-F2-D4-CD


DNS Servers . . . . . . . . . . . : 192.168.1.254
192.168.0.1
NetBIOS over Tcpip. . . . . . . . : Enabled


Tunnel adapter isatap.{9E09B4DE-E418-4340-A60B-44D4DD636F7B}:


Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


Tunnel adapter Teredo Tunneling Pseudo-Interface:


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:2cf6:675:9c4a:67dd(Prefe
rred)
Link-local IPv6 Address . . . . . : fe80::2cf6:675:9c4a:67dd%12(Preferred)
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled


Tunnel adapter isatap.{DA280DD5-E460-4CD6-990F-DA6AAE524182}:


Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes


C:\Windows\system32>
 


helpifIcan

Fantastic Member
#4
The DNS server info looks strange.
Two things to try.
1. Disable IPv6
2. Use either Open DNS or Google DNS

Open DNS 208.67.222.222 & 208.67.220.220

Google DNS 8.8.8.8 & 8.8.4.4
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#5
DNS Servers . . . . . . . . . . . : 192.168.1.254
192.168.0.1
helpifIcan is right - the DNS server addresses are an odd combination. The first one 192.168.1.254 is completely wrong - looks like it might be left over from another router. The second one is ok and should replace the first one. You can either configure your aireless adapter to get DNS addresses automatically (which I would expect to result in setting to 192.168.0.1) or, if that fails then set manually to this value. IPv6 is known to have some issues and as your are not using it then it is best disabled as advised.
 


#6
You can either configure your aireless adapter to get DNS addresses automatically (which I would expect to result in setting to 192.168.0.1) or, if that fails then set manually to this value.
How might I do this?
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#7
Control Panel, Network and sharing centre, change adapter settings, right click on the wifi adapter, properties, left click on Internet protocol versions 4, click on properties, check the item "obtain dns server address automatically".

If this doesn't work click on "use the following dns server address" and enter the value 192.168.0.1
 


#8
Okay, I've gotten it off of "Limited Access" but now I can't load a web page. When I use the built in network adapter, I can still connect just fine...
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#9
Can we have a look at your updated ipconfig please?
 


#10
Updated ipconfig:



C:\Windows\system32>ipconfig /all


Windows IP Configuration


Host Name . . . . . . . . . . . . : PCT-48
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No


Wireless LAN adapter Wireless Network Connection:


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR5007EG Wireless Network Adapter


Physical Address. . . . . . . . . : 00-26-5E-59-9C-19
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : fd6a:7f7c:3ccb:0:e5c7:6bc2:2beb:db5f(Pref
erred)
Temporary IPv6 Address. . . . . . : fd6a:7f7c:3ccb:0:b4a8:b999:c930:6835(Pref
erred)
Link-local IPv6 Address . . . . . : fe80::e5c7:6bc2:2beb:db5f%10(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.134(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Monday, December 03, 2012 3:28:52 PM
Lease Expires . . . . . . . . . . : Wednesday, December 05, 2012 1:10:04 PM
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 184559198
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-41-A0-10-00-23-5A-F2-D4-CD


DNS Servers . . . . . . . . . . . : 192.168.1.254
192.168.0.1
NetBIOS over Tcpip. . . . . . . . : Enabled


Tunnel adapter Teredo Tunneling Pseudo-Interface:


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6ab8:344a:1ea9:9c4a:6289(Pref
erred)
Link-local IPv6 Address . . . . . : fe80::344a:1ea9:9c4a:6289%12(Preferred)
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled


Tunnel adapter isatap.{9E09B4DE-E418-4340-A60B-44D4DD636F7B}:


Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#11
You still have an odd dns server address:

DNS Servers . . . . . . . . . . . : 192.168.1.254
192.168.0.1
NetBIOS over Tcpip. . . . . . . . : Enabled
You need to get rid of that 192.168.1.254. Go to the description I gave earlier about manuall setting dns server address and set them both to 192.168.1.254. You also have Internet Protocol Version 6 enabled on your wireless adapter. You will not be using it and it has been identified as causing some problems so you should diable it in the wireless adapter settings.
 


#12
It works! Thank you guys so much, really appreciate the help.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top