Wireless Problems: rosewill RNX-N300 having long latencies/drops on 7 x64

Discussion in 'Windows 7 Networking' started by egerrish, Sep 4, 2010.

  1. egerrish

    egerrish New Member

    Joined:
    Sep 4, 2010
    Messages:
    10
    Likes Received:
    0
    I'm running Windows 7 x64 Ultimate edition. I had an old Wireless card - Linksys WMP54GS - which was having problems with dropping the network connection and high pings. The chipset is supposedly Ra-link 2500.

    I ordered a Rosewill RNX-N300 because that was supposed to work on x64 bit systems (which I assumed was the problem). The chipset is Ra-Link 2860+2820.

    The new card is still dropping, and has high latencies (3,000ms+) when it does connect.

    I downloaded the newest drivers - v1.5.1 from their website to no avail. I have emailed Rosewill but have not received a response as of yet.

    I have a laptop with Windows 7 x64 home edition which has no problem connecting to the same wireless router.

    Anyone have any ideas?

    Thanks for the help!
     

    Attached Files:

  2. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    You don't say if you've checked out the first things - location, distance (too close/too far?) obstructions, sources of potential wireless interference?
     
  3. egerrish

    egerrish New Member

    Joined:
    Sep 4, 2010
    Messages:
    10
    Likes Received:
    0
    Ok, sure. When I connect I have 4/5 bars, and I can set the laptop right next to the desktop and get 4/5 bars as well. The computer is about 20 ft. away from the wireless router through 1 wall.
     
  4. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    what router is it and have you tried running with 802.11g?
     
  5. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Make sure the router is set to short preamble instead of long.

    Set a lower Beacon Interval than it currently is set for.
     
  6. egerrish

    egerrish New Member

    Joined:
    Sep 4, 2010
    Messages:
    10
    Likes Received:
    0
    The router is WRT54G firmware 1.02.7

    I'm not familiar with how to broadcast (is that the right word?) in g, and I'm in the router settings trying to set a short preamble and whatever else you said.

    Thanks.
     
  7. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    It looks like you have your adapter set to use 802.11N talking to an 802.11G router. Set the adapter to use 802.11G .
     
  8. egerrish

    egerrish New Member

    Joined:
    Sep 4, 2010
    Messages:
    10
    Likes Received:
    0
    Solved!

    Awesome. So here are the changes I made:

    1) I switched The router to only broadcast in g
    2) I changed the Beacon Interval to 20 from 100
    3) I changed the broadcast channel to 7 from 4

    I now have no drops and 30-40ms pings

    Thanks!
     
  9. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Excellent - thanks for the feedback.
     
  10. egerrish

    egerrish New Member

    Joined:
    Sep 4, 2010
    Messages:
    10
    Likes Received:
    0
    Update: I'm having more problems. I've now figured out that I only have requests time out from continuous pinging when I have BOTH my desktop and laptop trying to connect at the same time. Either they are interfering with either other or the router is no longer capable of routing.

    Anyone know of a way to stop two computers from interfering with one another?

    Thanks.
     

Share This Page

Loading...