WMC and hd5770 can't play anything...

#1
Hi all, first time posting here and I'm hoping some of the more technically minded individuals here can help me identify the root cause of my problem. Not sure if this is in the right section please move this thread if it's in the wrong subforum.

Right, the problem is that I can't seem to get windows7 WMC to work with my hd5770 card regardless of driver installation I've gone through the ATI tech support and all they say is they can't replicate the issue and don't have a setting in catalyst to fix the problem.

Basically it siezes up whenever I try and run either a recorded programme or live tv stream. It slows the system to a crawl and every 30 seconds or so I get a snippet of sound from the relevant programme being shown. I've tried updating bios on two boards with the system (asus p7p55d-pro and gigabyte p55-ud5), and even tried using it in an x58 setup I have as the gaming computer and this also seizes up. I've reinstalled both windows7 RC (the original OS) and tried out the just released RTM as well and neither fixes the issue. I'm at my wits end frankly and it's driving me nuts. I managed to get an "end task" report on the issue and it seems that ehshell.exe is the culprit. I can change the card to a hd4770 and this fixes everything, but I had bought the 5770 to enable some better gaming to this htpc. If I can't use the 5770 with WMC though it doesn't really make much sense to have it in there, as it will primarily be used to watch tv. I've tried two different motherboards, two different tv cards (leadtek dtv1000s and compro e700) and it would appear this isn't the main problem.

Here's a copy of the end task report and if any other information would be helpful in diagnosis I would be more than happy to supply it. I also got a log from SFC as well and I'll include a copy of that below the WMC end task report.

Problem signature:
Problem Event Name: AppHangB1
Application Name: ehshell.exe
Application Version: 6.1.7600.16385
Application Timestamp: 4a5bd053
Hang Signature: dd6a
Hang Type: 6400
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 3081
Additional Hang Signature 1: dd6a63488e4cb8d18ae23e4091f51df8
Additional Hang Signature 2: 7658
Additional Hang Signature 3: 765868fa06a331abb0ffed0df768be7d
Additional Hang Signature 4: dd6a
Additional Hang Signature 5: dd6a63488e4cb8d18ae23e4091f51df8
Additional Hang Signature 6: 7658
Additional Hang Signature 7: 765868fa06a331abb0ffed0df768be7d
2009-11-01 01:35:49, Info CSI 00000068 [SR] Cannot repair member file [l:46{23}]"DevicePairingFolder.dll" of Microsoft-Windows-DevicePairingFolder, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2009-11-01 01:35:50, Info CSI 0000006a [SR] Cannot repair member file [l:46{23}]"DevicePairingFolder.dll" of Microsoft-Windows-DevicePairingFolder, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2009-11-01 01:40:11, Info CSI 00000297 [SR] Cannot repair member file [l:28{14}]"iassdo.dll.mui" of Microsoft-Windows-Networking-Internet_Authentication_Service_Iassdo.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2009-11-01 01:40:12, Info CSI 0000029a [SR] Cannot repair member file [l:28{14}]"iassdo.dll.mui" of Microsoft-Windows-Networking-Internet_Authentication_Service_Iassdo.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2009-11-01 01:40:54, Info CSI 000002f2 [SR] Cannot repair member file [l:46{23}]"DevicePairingFolder.dll" of Microsoft-Windows-DevicePairingFolder, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2009-11-01 01:40:54, Info CSI 000002f4 [SR] Cannot repair member file [l:28{14}]"iassdo.dll.mui" of Microsoft-Windows-Networking-Internet_Authentication_Service_Iassdo.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2009-11-01 01:40:54, Info CSI 000002f6 [SR] Cannot repair member file [l:46{23}]"DevicePairingFolder.dll" of Microsoft-Windows-DevicePairingFolder, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2009-11-01 01:40:54, Info CSI 000002fc [SR] Cannot repair member file [l:28{14}]"iassdo.dll.mui" of Microsoft-Windows-Networking-Internet_Authentication_Service_Iassdo.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch

Not sure how helpful this will be for anyone out there, but I can't think of anything else to do aside from dump the new card and return to the 4770 instead. I did a few other diagnostic tests for the ATI tech support and can post the results of these as well.

Thanks very much for reading and hopefully someone out there can help me to sort out this mess and get my WMC working again!
 


#2
Okay, I've done some more poking around and it would appear I can play .wmv files okay, but .mpg files make windows7 media player 12 do similar behaviour as seen in Windows media center, blank screen, system slows to a crawl, have to shut down the programme through task manager.

Here's the error from the latest shutdown in Media Player 12.


Problem signature:
Problem Event Name: AppHangB1
Application Name: wmplayer.exe
Application Version: 12.0.7600.16415
Application Timestamp: 4a98ae4b
Hang Signature: eb0f
Hang Type: 6153
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033
Additional Hang Signature 1: eb0f8aa5d32f010c6709a7f9cb5ecc7c
Additional Hang Signature 2: d452
Additional Hang Signature 3: d452a2e96d1f29ee0f4276a7a7619b6c
Additional Hang Signature 4: 14fd
Additional Hang Signature 5: 14fd2dbf0d236ce6ae1b127325b2dcc3
Additional Hang Signature 6: 089b
Additional Hang Signature 7: 089bdc7c154c939cc76bb22f644f9b36

It would appear that the codec or codecs, (does WMC use .wtv or .mpg?) is crashing in conjunction with the hd5770 card. Everything else plays fine.

Hoping someone out there can help.
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.