WMP 12/11 persistent library corruption

Discussion in 'Windows 7 Help and Support' started by Eternal Cat, Jul 24, 2009.

  1. Eternal Cat

    Eternal Cat New Member

    Joined:
    Mar 18, 2009
    Messages:
    10
    Likes Received:
    0
    So I've been having some major issues with Windows Media Player. I wouldn't really mind, because the general library function works perfectly otherwise and it's perfect with foobar2000, but Windows 7 has a very nice integration with the Sonos music system (UPnP) which allows streaming over the network. I've installed 7000, 7048, 7057, and 7100 32-bit as they were released (oh, I mean leaked xD), and recently installed 7600 to see what had changed. I decided to try going 64-bit with 7600, to see how my laptop handles it (haven't noticed any difference, to be honest). To migrate between the OSes I've been installing the older version over the new, and then copying the Users folder from Windows.old, and then reinstalling programs for the registry/start menu entries.

    The issue is that Windows Media Player doesn't have a library. No matter what I do, it refuses to add anything: by going Organize -> Manage Libraries -> Music I can add folders, and they stay there (Googling my problem has found that folders vanishing from that list is pretty common), and then WMP usually says "Scanning new folders..." or something similar. This ends a couple of seconds later, with nothing showing up my library - and, in fact, the Library entry in the left menu is greyed out.

    I've also tried Tools -> Advanced -> Restore media library..., and that's had no effect. I've manually deleted the wmdb file (and sometimes wiped out the entire C:/Users/David/AppData/Local/MicrosoftMedia Player folder, it has exactly the same effect) many times. It just causes WMP to scan new folders the next time it's opened, and still not find anything.

    I found a partial workaround in earlier versions of Win7 by downgrading to WMP 11 (detailed at devrexster - WMP 11 - For Windows 7), which - to be honest I've forgotten exactly how it happened - worked to a limited extent. I added my library at the time and I'd be able to browse and stream those files perfectly from various Sonos devices, but I couldn't update the library with any new files.

    After a while I moved all my music from C:/Users/David/Music to C:/Music to see if that would have any effect; it hasn't. I've checked the attributes of the files, they're all neutral (no system, no hidden attribute). I can't find anything wrong with the files themselves: they're from various sources (some ripped from CDs in WMP10 on an XP machine and then copied over, some from various free music sites such as Newgrounds, some plain pirated), their metadata is pristine (works in both iTunes [grr, but I have to use it to sync my iPod] and foobar2000).

    I ran a Windows Troubleshooter for solving WMP Library problems, and when run in administrator mode it reported that my database file was corrupted and offered to remove it so that WMP would rebuild it. I tried that, it had the same effect as manually deleting the file or folder in question (namely, a very quick scan by WMP and an empty library). If I run the troubleshooter again it says exactly the same thing, no matter how many times or what I do in between as regards WMP or the .wmdb.

    So. I've tried various solutions, one of which has resulted in a limited-use but sadly lost solution, and none of which have produced my ultimate outcome (the library wmdb file actually updating). I don't care about playing my music in WMP or WMC, but I need to get the .wmdb file working for the Windows Media Player Network Sharing Service. Has anyone encountered this kind of issue before, and what kind of success have they had?
     
  2. svtdragon

    svtdragon New Member

    Joined:
    Jun 6, 2010
    Messages:
    2
    Likes Received:
    0
    Another voice with this problem

    This has to have something to do with the Users folder. There has to be some application data that's stored there outside of the Media Center folder in yourprofile/AppData.

    I've just done the same thing after a reimage and I am having the same problem. The troubleshooter says the same thing (that I have a corrupt database) and tries to repair it, then when I re-run it it says the same thing. I've also checked the permissions (all the files reside on a network drive so they haven't changed since the last time this worked) and deleted/restored the database.

    I've also uninstalled and reinstalled WMP from the "turn windows features on or off" control panel.
     
  3. Eternal Cat

    Eternal Cat New Member

    Joined:
    Mar 18, 2009
    Messages:
    10
    Likes Received:
    0
    Thread necromancy

    Wow, it's been a while since I posted this :p to be honest, I just gave up on it, disabled all Windows-integrated media streaming, and started using a foobar2000 extension (foo_upnp) and the Sonos Desktop Controller software to replace the functionality I was looking for in WMP, which of course doesn't solve the original problem. 'fraid I can't help.
     

Share This Page

Loading...