Wrong certificate being used when using different browsers

alexhen

New Member
Hello,
I am using a Windows server 2019 with IIS and active websites, for some reason when i enter a website that exits in our IIS with HTTPS with valid R3 certificate from our server it loads an expired certificate ( i have tried Chrome Edge and Mozilla to test this). I entered me certificate manager using MMC and i cant find this certificate anywhere on the server (and the updated certificate is chosen in the binding options), i reinstalled all the browsers i even removed the new certificate that was granted to the website and created a new one but still the same error. This problem occurs only in the server and not on any other computer. What could be the problem?
Thank you in advance
 

Neemobeer

Cloud Security Engineer
Staff member
My guess is there is a mismatch between the store selected in IIS and MMC cert store. Make sure you are in the 'local computer' context in MMC on not current user. IIS uses computer certs
 

alexhen

New Member
i checked the "local computer" certificates and "current user" certificates and i did not find any certificate that matches the certificate that is used by the browsers, that what makes me so confused.
 

Neemobeer

Cloud Security Engineer
Staff member
Look in IIS > Certificates and see what cert store is in use. It doesn't have to be personal
 

alexhen

New Member
All the certificates are up to date and the proper one is binded to the website
Server Cert.PNG


and this is the Certificate that is binded to the site
IIS binding.PNG
 

alexhen

New Member
I found the problem, i have two servers (one production and and the second is a hot standby) when i entered the website the request went to the standby server where the certificate was old (only renewed in case of a crash) and not the to the server itself, i just shutdown the iis service at the standby.
 
Top