Windows 7 X3 : Terran Conflict


whenever i try to run the game (X3:terran conflict), an error comes up saying:
Insufficient Rights: to perform this applications for the first time, u have to be administrator
or something like that, its in dutch hope i translated it good
why do i have this problem?
ive installed it today, tried to run as admin, or with compatibility mode, nothing worked
also tried to enable the Real admin account and run it from there, same problem

k fixed myself

I have exactly the same problem, could you write here the solution?

well, is your game legit or downloaded?

Can you post the two solutions?
I'll be grateful :)

i only have it for the downloaded version (torrent)
seemed that crack didnt help me, so i downloaded an mini image, used deamon tools to mount it and yasu to cloack the protection and then it worked

good idea.
Can you send me a PM with the link for the mini image?
I didn't found it :)

terran cionflict

I have the same problem as Eilerdor.I have a legit copy of x3 terran conflict. If anyone knows of a fix (with full and concise instructions please, unless it is simple:)) I would be very appreciative,



@inigo go to the egosoft website and install the 1.0.1 to 2.1 x3 terran conflict update

it got me to the game load screen so i assume it works.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.