XCOPY doesn't backup "Share with nobody" folders - help?!

Discussion in 'Windows 7 Help and Support' started by garfonzo, Feb 7, 2011.

  1. garfonzo

    garfonzo New Member

    Joined:
    Feb 7, 2011
    Messages:
    4
    Likes Received:
    0
    I have a computer in an office setting with a number of users. Each user has one folder on a "Data" partition which is set to "share with nobody" for their privacy.

    I'm trying to write a script to backup these folders, but these "private" folders aren't copied over. My script is a one-liner and looks like this:

    Code:
    XCOPY D:\* F:\ /E /H /R /Y /I /D /M
    Any ideas why these "share with nobody" folders don't get copied over?

    Thanks
     
  2. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    Are you doing this as a domain administrator on the network? Make sure that you have full access to share with nobody folders and that these permissions do not break the chain of inherited permissions. If inherited permissions are being disabled, the only rights that take precedence over that type of folder (or entire drive) would be circumvented. Therefore, even as the domain administrator of the Windows network, you would still not have access.

    Mind you, I am assuming several things. One, is that you are on a Windows domain network, because you have mentioned users, an office setting, and a bunch of computers. Second, you are writing a script, which you will likely use Active Directory/Group Policy or Netlogon to initialize in some manner.

    I could be entirely wrong and you are just on a workgroup or something....

    /O Copies file ownership and ACL information.

    You may want to try this in your XCOPY.

    You may also want to check *your* account's user group and *your* access to these folders. If you are part of the domain administrator group, on a Windows AD network, you should make sure that you have complete access to these folders.
     
  3. garfonzo

    garfonzo New Member

    Joined:
    Feb 7, 2011
    Messages:
    4
    Likes Received:
    0
    Wow, thanks for the quick reply! This was my first post to there forums too, so it is nice to see a healthy community willing to help out.

    Unfortunately your assumptions are incorrect. The office setting only has 3 users, and this computer is acting as a file and print server. Thus, I am only setting up a workgroup for the office, not a domain situation. When I say "I am trying to do backups" I am logged in as the Administrator (I'm the sysadmin for the company) so I was perplexed as to why the "nobody" folder was not being copied when I ran it as the administrator. Thanks for the info regarding the permissions, I will have to do more studying on the topic.

    Having said all that, your suggestion of adding /O to the script worked like a charm! With that flag, the "nobody" folders are copied over and keep their "nobody" status. Fantastic!

    Thanks a bunch!

    Garfonzo.
     
  4. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    I'm very happy to have helped.
     

Share This Page

Loading...