XP network: Can ping IP and server name, but still can't browse

#1
Recently upgraded one machine on our small office network to 7 in order to learn the product. All other transition went smoothly and impressed with increase in speed and ease of use for the average user.

Stats are:
Dell Dimension E520
Dual Core 1.8GHz
2GB Ram
Windows 7 Ultimate
PC is wiredAll other machines on network are XP or NAS drives

I've had trouble accessing XP machines on the network so after searching the forum I've already worked on these items I've seen mentioned:
MDNSresponder is not running
No weird strings or Bonjour in Services
Computer browser and tcp/ip netbios helper services are started and on automatic
Ipv4 has netbios over tcp/ip selected
Ipv6 has been disabled
Flushed DNS and netbios cache

However, I still cannot browse any XP machine or NAS drive on our network. I can ping, both the IP address and server name, but none show up in browse network area. I have also tried to map network drives manually, using the syntax from the successful ping and it still can't access.

Any help you can give would be greatly appreciated.

JCIII
 


#2
Update....1 problem resolved, new problem discovered

I'm an idiot...I had the new machine named the same as another...it got an IP address but obviously some sort of conflict. Changed and rebooted, voila the xp's and NAS drives showed up.

HOWEVER, even though I can now see them, there's something weird going on with logging on to the NAS. I know I am typing the correct Name and password, I've tried editing the credentials, using different credentials etc. Still won't let me login. It seems to automatically adding the machine name to the preface of the name password. When I try to login using a different name, it shows a "Domain:XXX" which is the computer name. What am I missing this time?

JC
 


Trouble

Noob Whisperer
#3
try using the NAS netbios name and then a backslash and then a known good username for nas access and the password for that name.
Like
MyNas\username
password for that user
 


Last edited:
#4
Thanks, not sure why I didn't think of that before. Even with the syntax "ABCNAS\username" and then "password" I still get the "Login failure: unknown username or bad password". The username and password works with any other XP machine.
 


Trouble

Noob Whisperer
#5
Strange...it seems that everyone of these types of devices has its' own particular quirks so try a couple other things,
First, in the networking setup utility within the NAS itself, make sure that the workgroup name is the same as your windows workgroup name.
Does the NAS have an admin account login (username and password that you normally use to get into the web interface you might try using that with the same format ABCNAS\Admin and password.
Also if the XP machine account works try using that and see if it works XPmachineName\XPuserName and password.
Finally you might try something like, WorkGroupName\MachineName\Username and then the password and see if that works.
 


Trouble

Noob Whisperer
#6
You might also trying taking a look at this post, referencing using the secpol.msc management console to edit the NTLM version that Windows 7 uses and see if it helps. This is usually used when you can't access the Windows 7 machine from the NAS, rather than the other way around, but you can try it and see if it helps.
http://windows7forums.com/windows-7...ge-link-mapping-network-drive.html#post133543
 


#7
Got it!

Thanks Randy, I appreciate your help. After a bit more research, it seems as if the Buffalo Terastations have an issue with Vista and 7 security protocols. I had to download a registry patch from Buffalo that actually lowers 7's security to a level of XP...or at least to my layman's understanding. No matter how I entered username/password, it would continue to require it. Now with the patch, one login and I'm golden. Another lesson learned. Again, I appreciate your time.

JC
 


Trouble

Noob Whisperer
#8
could you provide me with a link to that patch
 


Trouble

Noob Whisperer
#9
Never mind, I found it. It's a .reg file which sets the LMCompatibilityLevel to "2" similar to what the Link I posted above suggests except I suggested Level "1"
The difference
Level 1 - Use NTLMv2 session security if negotiated
Level 2 - Send NTLM authentication only
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top