Yet another networking issue

Discussion in 'Windows 7 Networking' started by ypdmd, Aug 10, 2010.

  1. ypdmd

    ypdmd New Member

    Joined:
    Aug 10, 2010
    Messages:
    10
    Likes Received:
    0
    Hi -
    I seem to be having a similar problem that others have with windows 7 -have gone through the usual issues and none have solved it.
    I have a Dell Optiplex 745 -just did a clean install of Home Premium.
    Started dropping the internet connection. ipconfig release and renew solves the problem, as does disabling and re-enabling the nework adapter.
    I disabled power saving options on the network adapter and gave the machine a static ip.
    This did not solve the problem.
    I have verizon DSL and a westell router. I can usually log in to the router @ 192.168.1.1, but no internet access. (router reports good connection and another machines on network can access the internet)
    Weird thing is - the router says my machine's ip is 0.168.x.x instead of 1.168.x.x
    I don't know if this is related to the issue at all. This is getting very frustrating. Any help is appreciated.
     
  2. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Can you just confirm this quote please? The format is wrong - if your address is starting anything but 192.168 . . . you have a problem with address allocation.
     
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    ypdmd:
    Hello and welcome to the forums.
    Not exactly sure what you are seeing in so far as what the router is saying since neither of the addresses you have typed above make much since as far as private reserved ip address and NAT.
    I suggest you check what your computer thinks it's ip address is when the problem is present and again with everything is working fine, just launch a command prompt and type ipconfig /all examine the information pertaining to your network adapter.
    Additionally if we are talking wired ethernet here, you might try adjusting the speed and duplex of your adapter to see if that improves overall performance/reliability.
    Type ncpa.cpl into the search or run dialog box and hit enter
    Select then right click the problem adapter usually "Local Area Connection(?)" and choose properties, near the top of the properties dialog box you should see a "Configure" Button click that and then select the advanced tab look in the left frame box for something called Speed & Duplex, try experimenting with different value selections from the drop down box on the right, try 100 full, 100 half, 10 full, 10 half. See if any of them help your issue. Reboot after each change to make sure the changes take effect.
     
  4. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    I'd focus on the addressing problem first - instead of looking at what address the router has given your pc have a look at the pc itself and see what address it is holding:

    Goto programs, accessories, command prompt and enter the command:

    ipconfig /all

    If you would like any help checking he output you can display it here.
     
  5. ypdmd

    ypdmd New Member

    Joined:
    Aug 10, 2010
    Messages:
    10
    Likes Received:
    0
    Update: my computer was reporting my ip address as 192.168.1.46
    the router was reporting it as 0.168.1.46

    I set up static IP - the router is now properly identifying my machine. But the problem is not resolved.

    I disabled bonjour and I thought that fixed the problem but it did not.

    When the problem occurs, I am able to ping and login to my router, and I can ping machines on my hamachi vpn, but not machines on the internet.

    I don't know if this is related, but when I exit configuration of tcp/ip 4 I get
    "Warning - Multiple default gateways are intended to provide redundancy on a single network (such as and intranet or the Internet). They will not function properly then the gateways are on two separate, disjoint networks (such as one on your intranet and one on the Internet). Do you want to save this configuration?"

    I'm not sure what this is referring to, because I only have one gateway, but I disable IP 6 if that was causing a conflict.

    Is it possible that Hamachi is causing the conflict and it is looking for an internet connection through Hamachi? (windows thinks it is an internet gateway?)

    Here is my ipconfig

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Optiplex-745
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controlle
    r
    Physical Address. . . . . . . . . : 00-18-8B-23-B0-B4
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv4 Address. . . . . . . . . . . : 192.168.1.225(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 8.8.8.8
    151.197.0.39
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Hamachi:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Hamachi Network Interface
    Physical Address. . . . . . . . . : 00-23-C3-06-85-FD
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IPv4 Address. . . . . . . . . . . : 5.6.133.253(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.0.0.0
    Lease Obtained. . . . . . . . . . : Thursday, August 12, 2010 7:32:12 PM
    Lease Expires . . . . . . . . . . : Friday, August 12, 2011 7:34:19 PM
    Default Gateway . . . . . . . . . : 5.0.0.1
    DHCP Server . . . . . . . . . . . : 5.0.0.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{FC21D309-1E22-4DA2-8ECB-90FBD01F9FAC}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:2c42:3a46:b805:5637(Pref
    erred)
    Link-local IPv6 Address . . . . . : fe80::2c42:3a46:b805:5637%13(Preferred)
    Default Gateway . . . . . . . . . :
    NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter isatap.{92371EFC-66E4-46D4-85CE-2D2C86E4B7C9}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter 6TO4 Adapter:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft 6to4 Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2002:506:85fd::506:85fd(Preferred)
    Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
    NetBIOS over Tcpip. . . . . . . . : Disabled


    Thanks for the help.
     
  6. ypdmd

    ypdmd New Member

    Joined:
    Aug 10, 2010
    Messages:
    10
    Likes Received:
    0
    you are correct, I mistyped it. my ip was 192.168 etc, and the router had me as 0.168 etc. It also had weird characters in the device name - it was calling it "intel adapter" and then gibberish. I switched to static ip, and things seem to be ok now, although the (verizon westell) router still calls my machine a "media adapter" but calls all the other machines "computers." The internet dropouts are still occurring though, see above post.
     
    #6 ypdmd, Aug 12, 2010
    Last edited: Aug 12, 2010
  7. ypdmd

    ypdmd New Member

    Joined:
    Aug 10, 2010
    Messages:
    10
    Likes Received:
    0
    The router has let me rename the device "computer" but its just weird that I didn't have to do that with any of the other machines on the network
     
  8. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    The reference to multiple gateways is probably due to the fact that you have two defined - one for your router and one for your vpn but that shouldn't be a problem. The settings you have for DNS server could be a problem. As you are using static IP addressing (for which you have correctly set the ip address, subnet mask and default gateway) it might be safer to set your DNS address to that of the router instead of the external DNS server addresses - doing this should cause all DNS requests to be sent to the router which it should then automatically forward to the correct DNS server address supplied by your ISP.
     
    #8 patcooke, Aug 13, 2010
    Last edited: Aug 13, 2010
  9. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Try this please... Enable DHCP. Remove the other DNS servers. Set your only DNS server to your router's IP... 192.168.1.1

    The DNS you are using is from WAN side of the network. You will not get a routable, IP address inside your own LAN which will likely prevent the router from managing your internet/sharing access.
     
  10. ypdmd

    ypdmd New Member

    Joined:
    Aug 10, 2010
    Messages:
    10
    Likes Received:
    0
    Thanks for the suggestions, but I only changed to static ip AFTER the problem started, so using an external DNS is not the cause of the problem. In fact, I switched to an external DNS because when the DNS was set to my router, I was not getting access. I switched to static ip because I wanted to be sure that the error was not with dhcp.

    Also, if the problem (with the failing internet connection) was DNS, I would still be able to ping an external ip address. But I was not able to do so.
    I will try switching back just for the heck of it, but I seriously doubt it is a solution.

    And Tater - Why do you say that you cannot use an external DNS? The configuration currently IS working, it is just that the internet connection drops off every so often. And reseting the adapter solves that problem.
     

Share This Page

Loading...